1. Frankieanime158's Avatar
    I have an ASUS Memo Pad HD 7, bought brand new. The device has been working fine,
    no problems for the month I have had it. But today, every time I tried downloading
    an app from the Google Play Store, it gave me a server error (RPC S-3). So I tried
    looking up some fixes, like clearing the data, logging out of all of my accounts,
    and rebooting. None of the fixes corrected the problem. But after deleting all of
    the data and cache, google play store than couldn't connect at all, and kept asking
    me to "Retry" connecting. All of my other internet using apps were fine. Facebook
    messaging and such. Than I went to look for more solutions, but the majority of
    everyone, was suggesting, force stopping "Google Play Services", but no matter where
    I looked in my settings>apps>all, it wasn't in there at all. Or in my task managers
    or anything. So I than uninstalled google play store completely, and tried downloading
    it again from a trusted source, as well as google play services. Installed them both,
    but when I login to my google account, and go to download an app, it crashes, and
    says "Unfortunately google play has stopped working". I tried 2 versions of the Play
    store. 4.8 (the new one), and 4.6 I believe. But no matter what it doesn't let me get
    into it anymore. So now I'm left, without Google Play Services, and the Google Play
    Store. I really don't want to try and search for the stock asus memo pad rom, and
    install. Since I live far from town, with satellite internet that barely hits 60 kb/s,
    with a 900 ping, and a very tight bandwidth cap, which usually drops downloads. Than
    I also won't want to completely wipe the tablet of everything just to install it,
    losing everything. There HAS to be some sort of fix, so please help me out, I have
    no idea what to do.

    I've been banging my head against the wall trying to figure this out. But at least I found
    an awesome Android forum site. Gonna start using this ! Thanks in advance for replies.
    06-08-2014 02:11 AM
  2. Paul627g's Avatar
    I hate to recommend it but I think a factory reset would be your best option. I know its not something you want to do but it really sounds like things are out of wack on the device and this is needed.
    06-08-2014 09:03 AM
  3. Golfdriver97's Avatar
    Try resetting app preferences. Sometimes it helps with Play issues. Settings>Apps>Menu>reset app preferences.
    06-08-2014 09:41 AM
  4. Frankieanime158's Avatar
    Alright guys, thanks for the help ! Just wanted a second opinion before I lost all hope .-. Haven't had any luck, so just gonna go ahead and restore .-.
    06-08-2014 10:02 PM
  5. Mooncatt's Avatar
    I'm not familiar with this problem, but googling the error code brought up a lot of results and threads that may help.

    I know this is from the S3 form, but there's several tips to try resolving the issue. http://forum.xda-developers.com/show....php?t=2579401
    06-08-2014 11:40 PM
  6. jonathanlisto's Avatar
    Try uninstalling Google play updates. Worked for me. I have the galaxy s5.
    10-19-2014 06:41 PM

Similar Threads

  1. swift key not working on my Galaxy s5??
    By jenpossy in forum Samsung Galaxy S5
    Replies: 7
    Last Post: 07-12-2015, 04:23 PM
  2. Google Play Store Not Working. Help Please !
    By Frankieanime158 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 1
    Last Post: 06-09-2014, 09:31 AM
  3. Some music files won't play anynore
    By Michelle Doran in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 06-08-2014, 01:13 AM
  4. S Pen not working in Internet
    By Larg in forum Samsung Galaxy Note
    Replies: 0
    Last Post: 06-07-2014, 08:11 PM
  5. How to use Google TTS with Polaris Office or MyLibrary
    By Vitani in forum General Help and How To
    Replies: 0
    Last Post: 06-07-2014, 06:18 PM
LINK TO POST COPIED TO CLIPBOARD