Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 2 12 LastLast
Results 1 to 25 of 37
Like Tree4Likes
  1. Thread Author  Thread Author    #1  

    Default Error: "Avoided poor internet connection"

    I have an ASUS Memopad 173X tablet, Android v4.2.2, which has developed a problem that I can't connect to wifi networks. Symptoms are a long delay whilst "obtaining IP address" and then the error message "avoided poor internet connection".

    It first happened at a public wifi hotspot in a hotel, and I assumed it was a problem with the hotel network. However then I went back home and I get the same symptoms with my tablet on my home network ... whereas other devices connect up fine. So I deduce it's a problem with the tablet. I have rebooted; "forgotten" my home network details and re-entered them and that doesn't work. Short of doing a factory reset, I don't know what to do. Any ideas?
  2. #2  

    Default Re: Error: "Avoided poor internet connection"

    Welcome to Android Central! Go to Settings>Wi-fi, tap the Menu button, then Advanced, and see if there is an option for "Avoid weak connections." If so, make sure it's unchecked.
  3. Thread Author  Thread Author    #3  

    Default Re: Error: "Avoided poor internet connection"

    No, there's no option "Avoid weak connections"

    Thanks for your help anyway. Grateful for any other suggestions!
  4. #4  

    Default Re: Error: "Avoided poor internet connection"

    Similar problem discussed in this thread: http://androidforums.com/asus-memo-p...mopad-hd7.html
  5. Thread Author  Thread Author    #5  

    Default Re: Error: "Avoided poor internet connection"

    Just to close this out ... I have given up and done a factory reset, which has fixed the problem. I'm hoping this isn't going to be a regular occurrence.
    B. Diddy likes this.
  6. #6  

    Default Re: Error: "Avoided poor internet connection"

    Factory reset did not help me. Don't know what else to try except the hard reset on the router. But I was specifically told not to do this by the installation guy. Wonder what happens if i push the red button?
  7. #7  

    Default Re: Error: "Avoided poor internet connection"

    Quote Originally Posted by Xenagirl487 View Post
    Factory reset did not help me. Don't know what else to try except the hard reset on the router. But I was specifically told not to do this by the installation guy. Wonder what happens if i push the red button?
    Well, there's a "factory reset" for most routers which resets all the settings, and then there's just rebooting it. Unplug the power cord for a minute, then plug it back in.
  8. #8  

    Default Re: Error: "Avoided poor internet connection"

    Exactly the same thing happened to me today. Has anyone figured this out yet?
  9. #9  

    Default Re: Error: "Avoided poor internet connection"

    Hi, don't know if you solved this yet, but I just got the same message on a brand new Sony Xperia M on my wifi. After some trying around, I found that if I went in to the advanced settings under the wifi panel and set the frequency band option from "auto" to "5 GHz Only" (seeing that your router is a 5GHz router of course) it worked right away. Don't ask me why, but it did for some reason. Maybe it works for others too.
  10. #10  

    Default Re: Error: "Avoided poor internet connection"

    just wasted 2 hours searching until i found this line: under data/misc/dhcp

    I found that deleting the contents of /data/misc/dhcp and then restart your device would cleared the issue.

    I hope this helps someone

    thanks
    HuiNa, Mithila Singh and LasNet like this.
  11. #11  

    Default Re: Error: "Avoided poor internet connection"

    Hi, This has started happening to me now. I cannot find the data/misc/dhcp directory on my Asus ME173X, any ideas on where else the DHCP settings may be stored so I can delete them? Thanks....
  12. #12  

    Default Re: Error: "Avoided poor internet connection"

    The quickest way to solve this is to go to "Settings" and turn off the wifi. Wait 30 seconds. Turn it back on and most devices will quickly connect. A simple fix, but it took me a long time to figure it out. Good luck!
  13. #13  

    Default Re: Error: "Avoided poor internet connection"

    Hello I have an LG Optimus L3 phone that will say obtaining Ip address while connecting to the router and soon after it will say avoided poor internet connection I go into advanced setting and uncheck avoid poor internet connection but it still says avoided poor internet connection can anyone please help?

    Posted via the Android Central App
  14. #14  

    Default Re: Error: "Avoided poor internet connection"

    Whoever does it, it's illegal
    It could be done by Google or Mobile network operator
    I will explain you everything now
    Once you make free wifi network at home, they are not happy about it, so they shut down your keyboard and modem to push you to pay for wifi services
    However legally you are on the right side of the river
    You bought the wifi modem which is sold legally throughout the world
    You connected it to the monthly paid internet, so you can start legal case against those who cause these headaches
    ----------------------
    P.S. You may solve this problem temporarily by resetting you wifi modem, unplug the power cord and replug it ,then turn it on
  15. #15  

    Default Re: Error: "Avoided poor internet connection"

    Welcome to Android Central! Sorry, but I don't believe that Google or internet service providers are purposely causing this issue. They would have no incentive to block your router, especially if you're paying for the internet service. It's not like these providers are trying to sell you routers to use in place of the one you have. Modems are a different story, but we're talking about routers here.
  16. #16  

    Default Re: Error: "Avoided poor internet connection"

    Yup, I had the exact same problem with my ASUS MeMo 7 (ME173X) only yesterday.
    After 3 or 4 hrs, resetting the broadband, resetting the tablet, clearing caches, messing with settings and generally fladdling about, I decided that the best thing to do is to perform a FACTORY RESET.
    (Go to Settings, Bckup & reset, then Factory data reset)
    Extreme? Maybe, but it has worked.
    I made a note of all my apps and things with screenshots, etc. backed up this 'n' that, saved stuff on the SD card, then did the reset and restored apps from Google PLAY.
    I hope this works for you (or anyone else reading this).
  17. #17  
    Rukbat's Avatar

    Posts
    20,065 Posts
    Global Posts
    20,067 Global Posts
    Carrier
    Modified Stock 4.4.2

    Default Re: Error: "Avoided poor internet connection"

    To save a lot of effort in the future, back the apps up, back the data up and back the launcher setup up. Factory reset, restore the app backup app, restore the apps, restore the data, restore the launcher setup and you're back in business with a few presses.
  18. #18  

    Default Re: Error: "Avoided poor internet connection"

    This worked for me when nothing else did: Tap Settings-> Tap Wi-Fi-> Tap Menu-> Tap Advanced
    (#1)
    Make sure that the:
    Network notification
    Notify me when an open network is available. IS CHECKED!
    (#2)
    Make sure that the:
    Avoid no internet connections
    Don't use a Wi-Fi network unless it has a internet connection IS NOT CHECKED!

    So #1 will check for YOUR internet (Wi-Fi) connection and notify you.
  19. #19  

    Default Re: Error: "Avoided poor internet connection"

    I knew something weird was going on when I WAS ABLE to connect to McDonald's WiFi but NOT my home WiFi router.
    I also rebooted the router too by unplugging it, removing the battery pack, waiting a minute and powering it back up again. STILL no good. I pushed the WiFi button on top of the router a few times, held it in the first time for 3 seconds and then again the second time for about 10 seconds. STILL no good. Then I found this site and dug around a little and found something that DID work.

    My phone didn't have the "Avoid weak connections" option either but it DID have this option:
    This worked for me when nothing else did: Tap Settings-> Tap Wi-Fi-> Tap Menu-> Tap Advanced
    (#1)
    Make sure that the:
    Network notification
    Notify me when an open network is available. IS CHECKED!
    (#2)
    Make sure that the:
    Avoid no internet connections
    Don't use a Wi-Fi network unless it has a internet connection IS NOT CHECKED!

    So #1 will check for YOUR internet (Wi-Fi) connection and notify you.
  20. #20  

    Default Re: Error: "Avoided poor internet connection"

    100% working !!! First you must forget the network. Then click the network again ! After that check the 'advanced option' change dhcp to static. Retype the ip shown there !!! Enjoy ! ???😄😄😄😊☺😍😘
  21. #21  

    Default Re: Error: "Avoided poor internet connection"

    doesn't work its just connected but no internet access
  22. #22  

    Angry Re: Error: "Avoided poor internet connection"

    I have tried turning the ASUS me173x on and off. same with the wi-fi button. I also tried switching over to the static and it says connected but doesn't actually connect. if i do a factory reset will i loose my pictures? or just my apps and settings.
  23. #23  

    Exclamation Re: Error: "Avoided poor internet connection"

    forget your connection then reconnect in advance option set Dhct to static and fill the ip address of your network
    100 worked
  24. #24  

    Default Re: Error: "Avoided poor internet connection"

    100% work # solved it final
    modify network or forget and reconnect then in advance setting do this :
    IP setting: Static
    IP address: 192.168.1.128
    Gateway: 192.168.1.1
    Netmask: 255.255.255.0
    DNS 1: 8.8.8.8
    DNS 2:8.8.4.4
    Connect
  25. #25  

    Default Re: Error: "Avoided poor internet connection"

    Mine has always been unchecked, however, I still cannot connect. Any other suggestions?
Page 1 of 2 12 LastLast

Similar Threads

  1. how to connect external hard drive
    By bluenite in forum ASUS MeMO Pad 10
    Replies: 3
    Last Post: 07-10-2014, 09:17 PM
  2. Better internet reception on Note 3 versus Note 2 ?
    By Casey Cheung in forum Verizon Samsung Galaxy Note 3
    Replies: 5
    Last Post: 06-12-2014, 02:47 PM
  3. error message
    By KemikalViking99 in forum Samsung Galaxy S4 Zoom
    Replies: 0
    Last Post: 06-12-2014, 05:57 AM
  4. Connect to WiFi
    By ventura726 in forum HTC One M8
    Replies: 1
    Last Post: 06-11-2014, 10:23 PM
  5. poor speaker qualithy on my m8?
    By richlev in forum HTC One M8
    Replies: 4
    Last Post: 06-11-2014, 05:12 PM

Posting Permissions