1. doll's Avatar
    I've tried hitting settings from search history screen but it won't come up. Help please
    01-30-2010 11:53 PM
  2. thebizz's Avatar
    Just go into setting search clear search shortcuts which should clear the history
    01-31-2010 12:02 AM
  3. bamafan77's Avatar
    settings> Appilications>manage appilications>menu filter all apps> scroll down to quick search bar > clear data hope this helps
    01-31-2010 08:28 AM
  4. doll's Avatar
    Thanks so much!
    01-31-2010 11:47 AM
  5. Zorro1's Avatar
    *whew* huh?
    01-31-2010 04:35 PM
  6. prometheus's Avatar
    )
    settings> Appilications>manage appilications>menu filter all apps> scroll down to quick search bar > clear data hope this helps
    That seems a bit complex to just clear history.... I just open the browser, menu, more, settings, and then select either clear history or clear cache.
    Does the OP want to clear the browser history, the market search history, or the google search history?
    01-31-2010 06:40 PM
  7. doll's Avatar
    I wanted to clear the browser history. sorry i was vauge. the first posted solution worked great. now if i can just remember it for the future...
    02-01-2010 10:46 PM
LINK TO POST COPIED TO CLIPBOARD