04-18-2013 10:12 PM
70 123
tools
  1. Takenover83's Avatar
    Introduction

    Groove IP makes things simple. It cuts out the need for several programs or services. You no longer need to use Google Call Back (GV callback/Voice+), a SIP Provider (sipgate) or Sip Client (sipdroid/csipsimple). The downside? It's not a totally free solution. See below for what you need.


    Requirements
    1. A Google Voice account (Free)
    2. Groove IP (Cost $2.99)

    Google Voice Setup
    1. Sign up for a account if you do not already have one. Google will give you a local number.
    2. Once Signed in, click the Settings Gear icon in the top right corner. Image
    3. Make sure your Google Voice is not forwarding to any other phones. I have mine set to forward to Google Chat/Gmail. Image

    Groove IP Setup
    1. Purchase the app and install it on your android phone.
    2. Sign in with your google voice account.
    3. There are various preferences when clicking the Settings button.


    Note #1: Have problems with the party not being able to hear you? Go to Settings>Troubleshooting, and enable the Audio Routing Hack.
    Note #2: The app is still under heavy development.
    Note #3: A update was released to help with audio routing issue's.
    Add new settings in troubleshooting to fix call quality on some phones (If you have stuttering/choppy voice try the new Audio Processing settings)
    04-29-2011 02:28 AM
  2. rockneo's Avatar
    Worked beautifully, free calling, aww yeah!
    05-02-2011 10:27 PM
  3. daskydivr's Avatar
    it wont work whats going on?
    05-03-2011 09:13 PM
  4. Takenover83's Avatar
    What won't work? Can you be more specific?
    05-04-2011 09:05 PM
  5. Superorb's Avatar
    So this works for calling out without requiring GV to call back the phone?

    I have an App called Nettalk which is free outgoing calls, but I can't receive calls. I'm fine with that since I only have wireless at home.
    05-08-2011 12:30 PM
  6. Takenover83's Avatar
    Yes, works for incoming and outgoing. No need for callbacks.
    05-09-2011 07:32 PM
  7. Superorb's Avatar
    Thanks for this, voice quality is pretty good compared to netTalk that I was using before. I was having problems where the person on the other end could barely hear me talking when they were on a landline, but I can adjust the mic gain on this app. The only problem I have is that it will drop wifi/3g after a few seconds when I call out. I also run GreenPower, and it doesn't do this with GP off.
    05-09-2011 11:16 PM
  8. baseballfanz's Avatar
    Don't seems to be receiving incoming calls
    05-10-2011 10:31 AM
  9. Superorb's Avatar
    Don't seems to be receiving incoming calls
    They need to be calling your Google Voice phone number, and Groove IP needs to be running and green/registered for it to work.
    05-10-2011 10:48 AM
  10. baseballfanz's Avatar
    Yes Groove is on with green indicator. Call my GV # and it would ring than go to vm.
    I can use groove to do out going no problems
    05-10-2011 11:07 AM
  11. Superorb's Avatar
    Yes Groove is on with green indicator. Call my GV # and it would ring than go to vm.
    I can use groove to do out going no problems
    There's a setting in Groove that has to do with pushing 1 when you answer a call to send it to voicemail. Maybe try checking/unchecking that box and see if that helps.
    05-10-2011 11:14 AM
  12. baseballfanz's Avatar
    Tried that, no dice. Thanks for the help, I'll keep playing around with the settings
    05-10-2011 12:21 PM
  13. baseballfanz's Avatar
    Read somewhere that I have to log out of all my Gmail accounts elsewhere.
    Still didn't work but a fresh new GV # and now incoming calls is working.
    05-10-2011 01:18 PM
  14. Superorb's Avatar
    Read somewhere that I have to log out of all my Gmail accounts elsewhere.
    Still didn't work but a fresh new GV # and now incoming calls is working.
    I'll keep that in mind if incoming calls for me doesn't work.

    Have you tried calls on 3g only? I'm only sticking to 3g right now.
    05-10-2011 01:23 PM
  15. baseballfanz's Avatar
    I'll keep that in mind if incoming calls for me doesn't work.

    Have you tried calls on 3g only? I'm only sticking to 3g right now.
    Calling over 3G only work great
    05-10-2011 01:33 PM
  16. Superorb's Avatar
    Calling over 3G only work great
    Hmmm... What are your normal 3g speeds? I normally only get around 200kbps down and under 100kbps up.
    Aaron Houk likes this.
    05-10-2011 01:46 PM
  17. baseballfanz's Avatar
    Here is my speed
    05-10-2011 03:04 PM
  18. Superorb's Avatar
    Here is my speed
    Yeah, that is WAY faster than what I get, so I won't be able to do 3g at least.
    05-10-2011 03:16 PM
  19. Takenover83's Avatar
    Make sure Gmail/Google Chat is not open somewhere. I heard that causes problems,.
    05-11-2011 09:37 PM
  20. baseballfanz's Avatar
    Make sure Gmail/Google Chat is not open somewhere. I heard that causes problems,.
    I read that too and closed every Gmail/Google account I can think of.
    Still no go so I use a different GV account and it's working great.

    To test the theory I left a few Gmail/Google account of the new GV # open and
    it's still working fine. Don't know what it is that my other GV # didn't work for incoming.
    05-11-2011 10:20 PM
  21. gravyflux's Avatar
    interesting...
    05-12-2011 09:18 AM
  22. wseyller's Avatar
    At first I didn't get incoming calls either. I don't have google chat. But in your google account settings I checked on Forward calls to google chat and that did the trick.
    05-12-2011 02:22 PM
  23. Takenover83's Avatar
    If you are not receiving incoming calls, it's likely because gmail, google chat, etc.. is signed in somewhere on another pc or program. You can always create another dummy google voice (they are free) account and use it only with Groove IP. This will help confirm the above.
    05-13-2011 09:14 AM
  24. j.m.f's Avatar
    Hello, I've purchased grooveIP, but am having a problem. Once installed and configured with my googlevoice account, grooveip connects and registers to google properly (green icon). Once i attempt to make a call (hit send), it changes to a red icon however. So, i cannot complete an outgoing call. Incomming calls do not complete either. Whats wierd is sometimes the call goes partialy through; I will call my girlfriends phone to test, and sometimes it will ring and even show callerid - even though grooveip on my samsung galaxy tab (verizon version, running on wifi) already shows a red icon. When she answers she just gets a fast busy signal.
    I was previously using sipdroid, but it was very unstable. Is there anything i can do - such as run a debug build - that would help you diagnose my problem?
    05-13-2011 11:04 AM
  25. Superorb's Avatar
    ^^ Do you use GreenPower or another data manager? I had to set mine to "keep data active during a call" for it to work. It also doesn't work when calling myself, as once it starts ringing data turns off. I don't think it can use both antennas at once.
    05-13-2011 11:09 AM
70 123
LINK TO POST COPIED TO CLIPBOARD