Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  

    Default Bad speed

    I made a wipe data on my Samsung Ace 3 S7275R mobile and still has jerky and choppy speed. I reinstalled all apps from a backup from Samsung Kies. What else can i do? Also, should i install the apps from the beginning and not use the already available backup with the maybe broken apps and os faulty settings or that is not necessary?
  2. #2  

    Default Re: Bad speed

    I would try without the backup.. Just wipe and try the phone. If it is fine after that there could be something within your backup that is causing your issue.

    Sent from my T-Mobile Note 3 using AC Forums.
    Thanked by:
  3. Thread Author  Thread Author    #3  

    Default Re: Bad speed

    How about rewriting the OS?. Should i use an external rom image in case the Internal rom became corrupted or is it the Internal rom safe?
  4. #4  

    Default Re: Bad speed

    As long as you're on the stock ROM a factory reset should be fine.

    Sent from my T-Mobile Note 3 using AC Forums.

Similar Threads

  1. Battery Drain SOOOOOOOOOOOOO Bad
    By Obsolete01 in forum Samsung Galaxy Note 3
    Replies: 13
    Last Post: 03-18-2014, 04:15 AM
  2. Fake or bad Note 3? please explain?
    By bgbagz in forum T-Mobile Samsung Galaxy Note 3
    Replies: 4
    Last Post: 03-18-2014, 12:51 AM
  3. Is Airpush bad?
    By Jalopiejoe in forum Samsung Galaxy Note 3
    Replies: 4
    Last Post: 03-14-2014, 10:18 AM
  4. Nexus 5: Bad Image Pixilation since yesterday
    By Harrison2000 in forum Google Nexus 5
    Replies: 1
    Last Post: 03-12-2014, 08:44 PM
  5. Nexus 5: Bad Image Pixilation since yesterday
    By Harrison2000 in forum Nexus 5 Accessories
    Replies: 1
    Last Post: 03-12-2014, 08:44 PM

Posting Permissions