1. Dissaster's Avatar
    Hello everyone,this might be wrong thread to post and i apologise,i'm new, just bought Xperia L few days ago,well firstly i could use wifi usually,but next day it stopped connecting,i mean it says that i'm connected to wifi,but does not letting me open webpages,neither youtube aplication and anything what is connected to network. as i said above i'm connected to my router but still,just loading and then says that theres problem with network.could anybody help me,what to do? thanks
    05-04-2014 02:37 PM
  2. B. Diddy's Avatar
    Welcome to Android Central! Does the phone work on other wifi networks?

    Review this guide, and see if any of the tips help: http://forums.androidcentral.com/amb...-problems.html
    05-05-2014 02:22 AM
  3. Kelly Burby's Avatar
    Hello everyone,this might be wrong thread to post and i apologise,i'm new, just bought Xperia L few days ago,well firstly i could use wifi usually,but next day it stopped connecting,i mean it says that i'm connected to wifi,but does not letting me open webpages,neither youtube aplication and anything what is connected to network. as i said above i'm connected to my router but still,just loading and then says that theres problem with network.could anybody help me,what to do? thanks
    I'll say have you tried restarting your router I am sure the problem is your router might be lacking restart, try restarting the router as well as your device and remove your network from your Xperia then again try connecting and entering the password in your device. It will start working fine again, i don't think rather than this there are any problem with your device.
    05-05-2014 03:26 AM

Similar Threads

  1. Calendar problem
    By dart4605 in forum Android 4.4 KitKat
    Replies: 4
    Last Post: 05-15-2014, 07:51 PM
  2. Help wifi issues
    By allen silfies in forum Samsung Galaxy S4
    Replies: 2
    Last Post: 05-05-2014, 03:34 AM
  3. Galaxy Tab 3 with WiFi Issues - Help!!
    By myetman23 in forum Samsung Galaxy Tab 3
    Replies: 1
    Last Post: 05-04-2014, 04:41 PM
  4. Problem with contacts on Moto X
    By Doug B in forum Moto X (2013)
    Replies: 0
    Last Post: 05-04-2014, 06:32 AM
  5. Lg gpad 8.3 kit kat update problem
    By Maria Roberts in forum Android 4.4 KitKat
    Replies: 0
    Last Post: 05-04-2014, 03:19 AM
LINK TO POST COPIED TO CLIPBOARD