Results 1 to 16 of 16
  1. Thread Author  Thread Author    #1  

    Default Chromecst not working on Denon AVR-1912

    Hello All

    My first post on this forum.

    I have Denon-AVR 1912. The specs mentions it has HDMI 1.4a.

    I cannot get Chromecast work on this receiver. With nothing plugged in HDMI port, I get a "no signal" message. When I plug in Chromecast, I do not get a "no signal" message implying that the receiver does detect some signal. However, I do not see any video.

    I plugged in Chromecast directly to my TV and was able to set up Chromecast. However, I have only one HDMI port on TV, so cannot use that port strictly for Chromecast. In addition, I have disconnected my TV speakers, so I cannot get audio through Chromecast.

    I looked up on net but no avail.

    Any help would be appreciated.

    Thanks
  2. #2  

    Default Re: Chromecst not working on Denon AVR-1912

    The device is meant to cast to a TV, not a receiver.
    Pat
    Nook Color - CM10.1 ( Jelly Bean 4.2.2) on eMMC
    Google Galaxy Nexus - stock Jelly Bean 4.3
    Galaxy Nexus 10 - stock KitKat 4.4.2
    Galaxy Nexus 7 (2nd Generation) - stock KitKat 4.4.2
    Chromecast
    Nexus 5 - stock KitKat 4.4.2
  3. #3  

    Default Re: Chromecst not working on Denon AVR-1912

    worked fine on my Sony A/V reciever until the input died [Am now using a HDMI switch into the only working in put in the receiver] . not sure if mine is 1.4 or earlier
    I think your skills are improving.
    Moto X
    Nexus10 2012
    Nexus 7 2013 [Son's]
  4. #4  

    Default Re: Chromecst not working on Denon AVR-1912

    I have a low end Denon (avr-1312) that I leave the Chromecast cast plugged into all the time and it works great.

    Have you tried another hdmi input or switched another device to the one that isn't working for the Chromecast?

    Posted with Nexus 5 via Android Central App
  5. #5  

    Default Re: Chromecst not working on Denon AVR-1912

    Welcome to Android Central! I have a Denon AVR-2310CI, and Chromecast works fine on it. I hired someone to install my entertainment system, so unfortunately I can't give many details about the setup. But let me ask you a silly question--your Chromecast is plugged into a power outlet, correct?
  6. #6  

    Default Re: Chromecst not working on Denon AVR-1912

    Quote Originally Posted by manbearpiggy View Post
    Hello All

    My first post on this forum.

    I have Denon-AVR 1912. The specs mentions it has HDMI 1.4a.

    I cannot get Chromecast work on this receiver. With nothing plugged in HDMI port, I get a "no signal" message. When I plug in Chromecast, I do not get a "no signal" message implying that the receiver does detect some signal. However, I do not see any video.

    I plugged in Chromecast directly to my TV and was able to set up Chromecast. However, I have only one HDMI port on TV, so cannot use that port strictly for Chromecast. In addition, I have disconnected my TV speakers, so I cannot get audio through Chromecast.

    I looked up on net but no avail.

    Any help would be appreciated.

    Thanks
    Are you using the Power adapter when you plug it into your Denon? Even if you have 1.4a on the receiver you still need to use the power adapter. I have a AVR-2113CI and I need to use the USB power adapter.
  7. Thread Author  Thread Author    #7  

    Default Re: Chromecst not working on Denon AVR-1912

    Yes. I first tried using the USB port for power, then switched to the power adapter.

    I changed the HDMI ports in case it was defective

    I tried casting both from my laptop and iphone.

    It casts when directly switched into TV's HDMI port but cannot cast it through receiver.

    Nothing seems to work.
  8. #8  

    Default Re: Chromecst not working on Denon AVR-1912

    I assume when you power the device while plugged into the receiver it shows a white light?

    Also, have you tried plugging it into an HDMI port that is known to be good (e.g. Blu Ray)? I know you said you tried a different port but I want to make sure you plugged it into one that you frequently use and is a known good one.

    Does the HDMI cable you have running from the receiver to the TV support 1.4a?
  9. Thread Author  Thread Author    #9  

    Default Re: Chromecst not working on Denon AVR-1912

    Quote Originally Posted by macleod52 View Post
    I assume when you power the device while plugged into the receiver it shows a white light?
    Yes

    Also, have you tried plugging it into an HDMI port that is known to be good (e.g. Blu Ray)? I know you said you tried a different port but I want to make sure you plugged it into one that you frequently use and is a known good one.

    Does the HDMI cable you have running from the receiver to the TV support 1.4a?
    Good point. Will find out and let you know.
  10. Thread Author  Thread Author    #10  

    Default Re: Chromecst not working on Denon AVR-1912

    Quote Originally Posted by macleod52 View Post

    Also, have you tried plugging it into an HDMI port that is known to be good (e.g. Blu Ray)? I know you said you tried a different port but I want to make sure you plugged it into one that you frequently use and is a known good one.
    I plugged the Chromecast into the blu-ray HDMI port, and surprise, it worked. Thanks for the tip.
    However, I am surprised - theoretically, all the receiver ports are supposed to be same even though Denon labels them as blu-ray/DVD/Sat-Cbl/Game etc. I have the functionality to change the name, so why would it work on one port and not work on another.

    Now I need to find out whether it can stream 5.1 audio. For now, I have to "force" the receiver to change the audio to 5.1

    Also, somehow I cannot stream live news channels (Al Jazeera/RT/Zee news) on YouTube. Any idea why?
  11. #11  

    Default Re: Chromecst not working on Denon AVR-1912

    I don't think Chromecast streams 5.1 audio (not yet, anyway). Can't tell you about the live YouTube streams.
  12. #12  

    Default Re: Chromecst not working on Denon AVR-1912

    Quote Originally Posted by B. Diddy View Post
    I don't think Chromecast streams 5.1 audio (not yet, anyway). Can't tell you about the live YouTube streams.
    Chromcast streams 5.1 but it's based on the source. I cannot say for all apps but I can confirm that Netflix broadcasts using Dolby Digital + on Chromecast but you need a receiver that can decode DD+. Also, if you have Chromecast attached to your TV you have to make sure your TV supports (and you're using the correct HDMI port) ARC (Most TVs don't).
    Thanked by:
  13. #13  

    Default Re: Chromecst not working on Denon AVR-1912

    Quote Originally Posted by manbearpiggy View Post
    I plugged the Chromecast into the blu-ray HDMI port, and surprise, it worked. Thanks for the tip.
    However, I am surprised - theoretically, all the receiver ports are supposed to be same even though Denon labels them as blu-ray/DVD/Sat-Cbl/Game etc. I have the functionality to change the name, so why would it work on one port and not work on another.

    Now I need to find out whether it can stream 5.1 audio. For now, I have to "force" the receiver to change the audio to 5.1

    Also, somehow I cannot stream live news channels (Al Jazeera/RT/Zee news) on YouTube. Any idea why?
    put the Blu-ray into the other ports that failed with the Chromecast . It could be you have bad ports

    Also It didn't occur to me until now but when Chromecast first launched some people had tropuble with the Chromecast Hdmi plug not being long enough however if they used the extension cable then it did work. you may want to try that to see if that is the case with your device.
    I think your skills are improving.
    Moto X
    Nexus10 2012
    Nexus 7 2013 [Son's]
  14. #14  
    emuu's Avatar

    Posts
    1 Posts

    Default Re: Chromecst not working on Denon AVR-1912

    Quote Originally Posted by manbearpiggy View Post
    I plugged the Chromecast into the blu-ray HDMI port, and surprise, it worked. Thanks for the tip.
    However, I am surprised - theoretically, all the receiver ports are supposed to be same even though Denon labels them as blu-ray/DVD/Sat-Cbl/Game etc...
    Hi manbearpiggy - I have the same receiver and I had a very similar problem with my Chromecast. I couldn't get about 5 of my HDMI inputs to work at all. It took me a while but each port has to be assigned an HDMI number eg. "HDMI4" to work with any input. I had only assigned two ports when I originally set up the receiver.

    So, yes, Chromecast works fine with the Denon 1912 on any port.
  15. #15  

    Default Re: Chromecst not working on Denon AVR-1912

    I also have a denon avr 1912 and can confirm that the chromecast does work with the receiver. In order for any hdmi port to work you must set up an input in the input settings and set it to receive audio and video from a selected hdmi port. Hope this helps.

    Posted via Android Central App
    HTC G1Nexus OneDroid X | HTC Amaze 4G | LG Nexus 4 | LG Nexus 5 | Nexus 7 (2012) | Note 10.1 (2014) | Moto X
  16. #16  

    Default Re: Chromecst not working on Denon AVR-1912

    Quote Originally Posted by marktrav44 View Post
    I also have a denon avr 1912 and can confirm that the chromecast does work with the receiver. In order for any hdmi port to work you must set up an input in the input settings and set it to receive audio and video from a selected hdmi port. Hope this helps.

    Posted via Android Central App
    That seems like an awful setup asking for trouble. Wonder how much their customer service gets bogged down because of it.

    Sent from my Nexus 5 using Tapatalk
    -Retired -
    8GB Toshiba Thrive
    AT&T Apple iPhone 3G
    AT&T Samsung Galaxy S2 SGH-i777

    -Current-
    Google Nexus 5 32GB Black
    Apple iPad 4 64GB Black

Similar Threads

  1. DO NOT UPDATE to 4.3 READ THIS
    By frankc1900 in forum Samsung Galaxy S3 in Canada (Bell/Telus/Rogers)
    Replies: 8
    Last Post: 01-26-2014, 09:04 AM
  2. Disabled camera on lock screen
    By Nabeelah Khalid in forum Sony Xperia Z1
    Replies: 4
    Last Post: 12-18-2013, 08:40 AM
  3. Phone going to sleep while on speakerphone
    By legaldeejay in forum HTC One
    Replies: 4
    Last Post: 12-09-2013, 02:23 PM
  4. Active Notification on Wave
    By sebolains in forum Moto X
    Replies: 1
    Last Post: 12-09-2013, 09:40 AM

Posting Permissions

B