Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 4 of 4
  1. Thread Author  Thread Author    #1  

    Question Subtitles Issue while casting to TV using Play Movies

    Hi all,

    I first noticed this problem with subtitles this past weekend, after purchasing and watching the Hobbit, the Desolation of Smaug, using Play movies app and casting to my TV via chromecast.

    The movie itself played well - only problem was with the subtitles. Subtitles would disappear randomly, show up again, then disappear again throughout the entire movie. There were sometimes long spans (several minutes or so) at a time when no subtitles were displayed at all. This problem only appeared when I was casting to TV via chromecast - when I watched it on my devices the subtitles worked fine. But I can't have people all huddled up and watched it on my 7" tablet together... lol

    I've tried several basic things like rebooting my devices (N5 & N7 2013, both running on stock 4.4.2), clearing play movies app cache, etc. I believe my app is up-to-date as well. But so far I'm still running into the same issue. It seems not all titles from play store suffer from this issue though. For instance, subtitles worked just fine when I tested watching Frozen.

    Normally having no subtitles didn't bother me much but since I am not that familiar with the world of the Hobbit (nor Lord of the Rings,) having no subtitles made it somewhat difficult to watch as there are many specific names and terms. I've contacted the Google Support but thus far only received a standard response suggesting me to reboot my devices, etc.

    Is there any other step I could try that could maybe help resolve this issue? Or have anyone else run into similar problems?
    Thanks everyone in advance for any comments and tips.
  2. #2  

    Default Re: Subtitles Issue while casting to TV using Play Movies

    your issue might not be with your device or chromecast, but with how you stream the content, a movie has 3 different streams, one for video, one for audio and one for subtitles. If one of the streams didnt download properly, it would be missing sections of it and not display when streamed. If you have a way to manually attach a cable from your device to your tv, I suggest to do that. That is the best way to get 100% of the content directly from your device to your tv.
    Thanked by:
  3. #3  

    Default Re: Subtitles Issue while casting to TV using Play Movies

    Quote Originally Posted by Christian Binder View Post
    your issue might not be with your device or chromecast, but with how you stream the content, a movie has 3 different streams, one for video, one for audio and one for subtitles. If one of the streams didnt download properly, it would be missing sections of it and not display when streamed. If you have a way to manually attach a cable from your device to your tv, I suggest to do that. That is the best way to get 100% of the content directly from your device to your tv.
    This doesn't make any sense. The CC streams right from Google. The portable device has nothing to do with how it shows on the display other then telling the CC to play it. It is either the CC or the content. I will test a few movies I have and see how it works. I have honestly never tried the subtitles from play movies.

    Posted via Android Central App
    Craig
    Phone :: BB880>>BB9000>>Captivate>>Galaxy Note1>>Galaxy Note 3
    Tablet :: B&N Nook >> Xoom >> Nexus 10
    Game/Mini-PC :: Zealz G802 >> Ouya
    Thanked by:
  4. #4  

    Default Re: Subtitles Issue while casting to TV using Play Movies

    Figured I would let you know my brief experience with subtitles. Basically I had them on for a little while during a movie yesterday. They appear to show up but were very often either slow to show up or showed at the very wird timing. There is a decent chance it could be dependent on the content as well and how the video is encoded.

    Subtitles can be encoded in the video stream in a few ways. They can either be part of the video file but part of there own stream, read from a separate file and then displayed based on time coding which means downloading two things at once, or encoded in the video stream on top of the video. I can see a few ways this could get out of sync, and I can see how the timing could be off. I wasn't impressed with it.

    The problem is without having a better way to view the file I don't know how to tell you what exactly is happening there. I would expect it to be part of the video stream and passed down as you are downloading the movie.

    Another possibility is the person that encoded it or the CC itself was having issues with forced Subtitles. I could be wrong but it sounds like your complaint was about subtitles that would typically be forced and not selected.
    Craig
    Phone :: BB880>>BB9000>>Captivate>>Galaxy Note1>>Galaxy Note 3
    Tablet :: B&N Nook >> Xoom >> Nexus 10
    Game/Mini-PC :: Zealz G802 >> Ouya
    Thanked by:

Similar Threads

  1. Nexus 7 Play store missing after factory reset
    By chappers1976 in forum Google Nexus 7 Tablet (2013)
    Replies: 12
    Last Post: 05-21-2014, 01:22 AM
  2. The KitKat update doesn't seem to have much
    By Crispy in forum Verizon LG G2
    Replies: 10
    Last Post: 04-15-2014, 08:56 PM
  3. Replies: 6
    Last Post: 04-08-2014, 06:38 PM
  4. Verizon Messages SMS App reduced character limit to 90
    By kingharis in forum Verizon Galaxy S3
    Replies: 7
    Last Post: 04-08-2014, 03:51 PM
  5. pica to SD card
    By Baber1305 in forum Other ZTE Android Phones
    Replies: 1
    Last Post: 04-07-2014, 03:10 PM

Posting Permissions