11-12-2014 08:12 PM
61 123
tools
  1. I Can Be Your Hero's Avatar
    This thing is so (language cleanup) terrible. Sometimes it'll want to be found on the network, other times it won't. Sometimes I'll actually be able to watch some YouTube through it, then all of a sudden it'll disconnect and start playing on my phone whilst still playing on the TV.

    Too many times it cannot be found on the network at all, when every single other WiFi device can be found 100% of the time with no problem. From phones, laptops, tablets, gaming consoles, TV's etc. Only the Chromecast has issues.

    I've frigging had it . For a few weeks now I've tried and tried to fix it but nothing works. I hate when Google release beta products to market and they barely work. If there's one thing I'll praise Apple for is when they release something they have a polished device from day one and it'll at least do what it's advertised to do.

    I'll just sell this crap and wait for Chromecast v2 which hopefully is a functioning device.



    Every time.
    Sent from my HTC One M8 using Tapatalk
    06-22-2014 03:25 AM
  2. mdcraig's Avatar
    That's really unfortunate. I've had the Chromecast since right after it was launched and have never had any problems with it.

    My only suggestion since nothing else on your network seems to be affected is check the powers supply. Is its through USB, make sure it's giving off enough juice. Or if it plugged into the wall, make sure nothing is hitting it and loosening it in the outlet.

    Posted via Android Central App
    Rick Bell and sGooss like this.
    06-22-2014 06:45 AM
  3. Ezduzit's Avatar
    They until might be defective, try exchanging it.

    Sent from my busa!
    06-22-2014 07:10 AM
  4. Rick Bell's Avatar
    That's really unfortunate. I've had the Chromecast since right after it was launched and have never had any problems with it.

    My only suggestion since nothing else on your network seems to be affected is check the powers supply. Is its through USB, make sure it's giving off enough juice. Or if it plugged into the wall, make sure nothing is hitting it and loosening it in the outlet.

    Posted via Android Central App
    DITTO!!

    Posted from my VZW GALAXY S3
    06-22-2014 11:01 PM
  5. I Can Be Your Hero's Avatar
    Definitely not anything to do with the power supply. It's in its own socket and it's flush against the wall. I can pull it out and put something else in there and it works fine.

    I'm just going to sell the chromecast. I spend more time trying to fix the damn thing then I do watching the content I want to watch. I'll just go back to putting stuff on USB sticks and plugging them into the TV's USB port. At least that's reliable.
    06-22-2014 11:33 PM
  6. GadgetGator's Avatar
    Definitely not anything to do with the power supply. It's in its own socket and it's flush against the wall. I can pull it out and put something else in there and it works fine.

    I'm just going to sell the chromecast. I spend more time trying to fix the damn thing then I do watching the content I want to watch. I'll just go back to putting stuff on USB sticks and plugging them into the TV's USB port. At least that's reliable.
    But it is pretty reliable for other people, including myself, so you are blaming an entire product for what in reality sounds like just a bad unit.

    Posted via Android Central App
    06-23-2014 06:22 PM
  7. neonworm's Avatar
    Mine has worked flawlessly since the day I got it. I love my Chromecast.
    Rick Bell likes this.
    06-23-2014 06:35 PM
  8. Lok52's Avatar
    I'm on my second because I lost the first one while traveling. Had occasional connection issues with this one on my home WiFi, but nothing major.

    Posted via Android Central App
    06-23-2014 06:52 PM
  9. scipper77's Avatar
    I had some of the problems the OP is complaining about if not all of them. Switching from USB to the wall wort power supply fixed pretty much everything. I think I did a factory reset on mine as well. Now it is very reliable.
    06-23-2014 07:31 PM
  10. I Can Be Your Hero's Avatar
    But it is pretty reliable for other people, including myself, so you are blaming an entire product for what in reality sounds like just a bad unit.

    Posted via Android Central App
    All the more reason to get rid of then don't you think?

    Funny who the entire Chromecast forum on Android central is just thread after thread of people with issues. It well and truly feels like a device in beta, and we're the subjects to bug test it.
    06-23-2014 08:27 PM
  11. GadgetGator's Avatar
    All the more reason to get rid of then don't you think?

    Funny who the entire Chromecast forum on Android central is just thread after thread of people with issues. It well and truly feels like a device in beta, and we're the subjects to bug test it.
    To get rid of that one defective unit? Yes. To bag the whole product line as beta and write them all off? No.

    Posted via Android Central App
    Jonneh likes this.
    06-23-2014 09:33 PM
  12. Devlyn16's Avatar
    All the more reason to get rid of then don't you think?
    Depends on one's ethics about knowingly selling a bad device. Personally I wouldn't.

    Funny who the entire Chromecast forum on Android central is just thread after thread of people with issues.
    Right, because people without problems are notorious for going on forums and starting countless threads praising a product that works.
    06-24-2014 12:06 PM
  13. frankenhooker's Avatar
    We've had one for a month or so and it's worked flawlessly.
    06-25-2014 01:05 AM
  14. Shmoopty's Avatar
    Smart money says the issue is with your router. It was discovered that a few of the cheaper routers don't have multicast enabled by default.

    Look into using Chromecast with your brand of router.

    Or just continue your "annoying frigging friggin damn" fit.
    afrozeke likes this.
    06-25-2014 05:04 PM
  15. TimmE's Avatar
    My family loved my first Chromecast so much I bought a second one for my 5 year old son's room. He can operate it without issue. Maybe you are doing it wrong?

    Posted via Android Central App
    GadgetGator likes this.
    06-27-2014 08:18 PM
  16. joselito76's Avatar
    Mine is doing the same thing, but I don't know if is chromecast or the phone. Because resetting the phone is the only thing that make it work. Actually resetting the router fix the problem

    Posted via Android Central App
    06-28-2014 12:31 AM
  17. carter17's Avatar
    Never had a problem with mine. I come home turn my hot spot on my phone it connects right away and works every time. this thing is great

    Posted via Android Central App
    07-01-2014 09:57 AM
  18. Almeuit's Avatar
    All the more reason to get rid of then don't you think?

    Funny who the entire Chromecast forum on Android central is just thread after thread of people with issues. It well and truly feels like a device in beta, and we're the subjects to bug test it.
    Some have issues... Some don't. I agree it definitely isn't perfect.. With my old router I had to do some trickery to get it going the first time but honestly... Once it's connected once. Zero issues... Always on and always pulls up when I demand it.

    Sent from my T-Mobile Note 3 using AC Forums.
    07-01-2014 12:09 PM
  19. gabbott's Avatar
    I bought 2 right when they were announced last year and a third shortly after. All three are in use in my house regularly. Haven't had any issues other than one that had some connectivity issues once and had required a power cycle.

    I'd say the OP either has a bad unit or there is some external variable (wifi router settings, interference, etc) that is making their experience subpar.
    07-01-2014 02:04 PM
  20. clownin72's Avatar
    Just got mine last night and played around with it. Having the same issue. Right now it's plugged into the. 5 amp USB on the tv. I will try the 1 amp USB and see if it helps. If not the wall plug in.
    07-15-2014 12:52 PM
  21. scipper77's Avatar
    Just got mine last night and played around with it. Having the same issue. Right now it's plugged into the. 5 amp USB on the tv. I will try the 1 amp USB and see if it helps. If not the wall plug in.
    Mine needs the outlet adapter (wall wart) to work properly. I have tried the USB port on my 6 year old Phillips TV and on my 2 year old Onkyo receiver. Neither one put out enough power for the chrome cast.

    Can anyone confirm that they have a USB port powering there Chromecast reliably?

    Posted via Android Central App
    07-15-2014 01:03 PM
  22. Almeuit's Avatar
    I would highly suggest using the wall plug if you guys aren't and are experiencing issues...

    Sent from my T-Mobile Note 3 using AC Forums.
    07-15-2014 04:54 PM
  23. Golfdriver97's Avatar
    Mine needs the outlet adapter (wall wart) to work properly. I have tried the USB port on my 6 year old Phillips TV and on my 2 year old Onkyo receiver. Neither one put out enough power for the chrome cast.

    Can anyone confirm that they have a USB port powering there Chromecast reliably?

    Posted via Android Central App
    I have a Samsung Series 403 LCD TV that can power my Chromecast through the USB port.
    07-15-2014 05:08 PM
  24. scipper77's Avatar
    I have a Samsung Series 403 LCD TV that can power my Chromecast through the USB port.
    Reliably, I would assume?
    07-15-2014 05:12 PM
  25. Golfdriver97's Avatar
    Reliably, I would assume?
    Yes

    Signed, an M8, Liquidsmooth, and the AC Forums App
    07-15-2014 05:29 PM
61 123

Similar Threads

  1. How to root ZTE N919D (MBLAZE 5 of MTS)
    By Unregistered in forum Ask a Question
    Replies: 2
    Last Post: 04-11-2015, 09:02 PM
  2. Selecting specific text from an incoming sms
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 09-12-2014, 11:05 PM
  3. International Call is barred. Asking for password
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-26-2014, 09:27 PM
  4. DSMLawmo, what is it?
    By Mokujon in forum Samsung Galaxy S5
    Replies: 1
    Last Post: 06-21-2014, 09:06 PM
  5. Why is "HTCDM" using so much WiFi?
    By parkerd97 in forum HTC One M7
    Replies: 2
    Last Post: 06-21-2014, 08:53 PM
LINK TO POST COPIED TO CLIPBOARD