Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 1 of 1
  1. Thread Author  Thread Author    #1  

    Default Chromecast won't display anything despite being "ready to cast"

    The problem occurs when I connect the CC to a brand new projector, an Acer H6510BD.

    Please note that all tests are done with CC connected to a working wall socket.

    Also, I've tested the CC on other HDMI monitors, and it works flawlessly and as expected.

    Also, BOTH HDMI INPUTS on the Acer have been tested with a PC and work flawlessly.

    My modem/router is a Motorola Surfboard SBG6580 and has multicast and UPnP enabled, and is in the room with the CC when hooked up to the projector (excellent signal).

    I read this thread and did what triolight and susanoo26 suggested and GOT IT TO WORK, but ONLY ONCE, but after turning off the projector and/or unplugging the CC from the HDMI and plugging it back in, I can't get it to work again.

    I followed a process like this using my android phone to set up the chromecast (without a display):

    • CC set up with wifi, but BOTH HDMI AND USB UNPLUGGED
    • Projector unplugged
    • plug in projector
    • plug in USB to CC until it holds white
    • plug in CC to HDMI
    • turn projector on
    • Phone does NOT find CC on wifi through chromecast app
    • unplug CC HDMI, refresh the app
    • phone now shows CC as "ready to cast"
    • plug back the HDMI into the same port, and it will display correctly


    What I find really weird is that every time I plug or unplug the CC from any HDMI port, my phone's app refreshes automatically and re-finds the CC on the network.

    Any suggestions would be greatly appreciated, I'd like to watch world cup on the big screen tomorrow if possible!

    Thanks!

Similar Threads

  1. iPhone 5 earphones not connecting to HTC One?
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 08-02-2014, 06:28 AM
  2. Which navigation software to use on the tablet with no data connection?
    By MarkHansen in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 15
    Last Post: 07-07-2014, 10:01 PM
  3. Replies: 10
    Last Post: 07-04-2014, 06:17 AM
  4. I need to install CWM 6.0.4.5 but my computer wont detect my tablet.
    By nexusclocker in forum Samsung Galaxy Tab 2 10.1
    Replies: 0
    Last Post: 06-29-2014, 03:21 AM
  5. how can i force my moto x to 3g only...
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-29-2014, 02:26 AM

Posting Permissions