Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 1 of 3 123 LastLast
Results 1 to 25 of 61
  1. Thread Author  Thread Author    #1  

    Default WiFi sleeps when device is locked!

    As the title says,


    I want you guys to test the new email notifications when the device is connected through WiFi.

    For this you've to set the WiFi sleep policy to never and the Background and Auto sync option needs to be checked.

    Well, I don't get any notifications. I went an extra mile ahead and pinged the IP address and found that I get "request timed out" error when device is locked and when it is unlocked, the packets are received properly.

    Waiting for you guys response.

    Thanks and Regards,
    resplendent2209
  2. #2  
    Duvi's Avatar

    Posts
    875 Posts
    Global Posts
    19,919 Global Posts

    Default

    Yes, that is because the Android OS (at least for me) by default puts wifi to sleep when has been inactive. The bad part about that is that it seems to shut the data services from the carrier down as well.

    My solution was actually using wifi only when I needed to d/l a file (rom... etc).

    If you're rooted, you can use "Spare Parts". There is an option so you can disable wifi sleep.
    CrackBerry Mod | Retired Android Central Mod | Tech Enthusiast
  3. Thread Author  Thread Author    #3  

    Default

    So you mean to say this is a bug on 2.1 Android?

    I mean the device is not honoring the "Never" option under WiFi policy?
  4. Thread Author  Thread Author    #4  

    Default

    Please check your PM, thanks.
  5. Thread Author  Thread Author    #5  

    Default

    My N1 isn't rooted and I installed spare parts and there is no new option for WiFi there.
  6. #6  
    Duvi's Avatar

    Posts
    875 Posts
    Global Posts
    19,919 Global Posts

    Default

    Sorry, fell asleep. (pun not intended)

    I honestly do not use wifi anymore unless I want
    to download a file. When it is done, I turn it off.
    CrackBerry Mod | Retired Android Central Mod | Tech Enthusiast
  7. #7  

    Default

    Quote Originally Posted by Duvi View Post
    I honestly do not use wifi anymore unless I want
    to download a file. When it is done, I turn it off.
    Why?

    If you have wifi available in your house, it uses WAY less power than 3G.

    But the WIFI Sleep NEVER has nothing to do with your ability to shut it off, all it does is keep the wifi radio listening while your phone sleeps, UNLESS you turn wifi off.
  8. #8  
    Duvi's Avatar

    Posts
    875 Posts
    Global Posts
    19,919 Global Posts

    Default

    In the house I'm always connected to a power source,
    but wifi does not work well for me when it is on. When
    I did have it on, I would receive my Gmail 30secs-2/3
    minutes after my iPhone and BlackBerry would get it.
    With wifi off, I now receive it within 10 seconds of
    them.
    CrackBerry Mod | Retired Android Central Mod | Tech Enthusiast
  9. #9  

    Default

    For the record, I tested this with resplendent2209 and with WIFI sleep NEVER, the phone remains ping-able while locked, screen off.

    For testing, tap Settings / Wireless and networks / Wifi Settings / then tap your router's SSID (which should say connected below it).

    A pop up will show you your IP address. Remember that.

    Dismiss the pop up, and, on the same screen, tap Menu / Advanced / Wifi Sleep policy.

    Set to NEVER to cause the phone to keep the wifi radio on while in sleep mode, saving batterty, and allowing notifications over wifi.

    Then from another computer on the same network, ping your N1 via its ip address, then put the N1 to sleep, (lock it) and ping it again. The pings should go thru in all cases as long as NEVER is set.

    CAVEAT: Most users would not care if the phone fell off wifi and reverted to 3G. Other than the extra power consumption, 3G is just as good as WiFi for a locked phone.

    But in this case resplendent2209 is testing with a N1 without a data plan, and fall over to 3G leaves him with no notifications.
    Last edited by icebike; 06-12-2010 at 12:20 PM.
  10. #10  
    Duvi's Avatar

    Posts
    875 Posts
    Global Posts
    19,919 Global Posts

    Default

    Yes, I've had that option selected for a while as well.
    My phone just refuses to listen sometimes. Or maybe
    I'm expecting my gmail to push faster than my iPhone.
    CrackBerry Mod | Retired Android Central Mod | Tech Enthusiast
  11. #11  
    Duvi's Avatar

    Posts
    875 Posts
    Global Posts
    19,919 Global Posts

    Default

    Also... one of my buddies actually returned his for that
    reason. His 3Gs was getting emails 1-2 minutes faster.
    Maybe it's my device that is messed up, but I'm definitely
    SOL as my phone is unlocked.
    CrackBerry Mod | Retired Android Central Mod | Tech Enthusiast
  12. #12  
    z0phi3l's Avatar

    Posts
    120 Posts
    Global Posts
    122 Global Posts

    Default

    Quote Originally Posted by Duvi View Post
    Also... one of my buddies actually returned his for that
    reason. His 3Gs was getting emails 1-2 minutes faster.
    Maybe it's my device that is messed up, but I'm definitely
    SOL as my phone is unlocked.
    Just don't mention it's unlocked :P

    It really sounds like a device issue, on WiFi or 3G I sometimes get notification on my phone before it pops up in Gmail
  13. #13  

    Default

    Yes there is a bug for some 2.1 nexus sinner where the WiFi sleep policy does not work for some reason, but it seems to work for me no problem. It actually saves battery setting sleep policy to never because then it doesn't switch to 3g when the WiFi goes to sleep.
  14. #14  
    Duvi's Avatar

    Posts
    875 Posts
    Global Posts
    19,919 Global Posts

    Default

    Quote Originally Posted by z0phi3l View Post
    Just don't mention it's unlocked :P

    It really sounds like a device issue, on WiFi or 3G I sometimes get notification on my phone before it pops up in Gmail
    Isn't HTC able to see that I unlocked it in their system?
    CrackBerry Mod | Retired Android Central Mod | Tech Enthusiast
  15. #15  

    Default

    Quote Originally Posted by Duvi View Post
    Isn't HTC able to see that I unlocked it in their system?
    Yes but so many people have had their warranty honored anyway even after they unlocked the bootloader that its definitely worth a shot.
  16. #16  
    Duvi's Avatar

    Posts
    875 Posts
    Global Posts
    19,919 Global Posts

    Default

    Quote Originally Posted by RogerPodacter View Post
    Yes but so many people have had their warranty honored anyway even after they unlocked the bootloader that its definitely worth a shot.

    Yeah, you're right. I just figured that it was a
    small issue and that I'd keep it in hopes I don't
    get a device that actually has real issues. This
    would be a good poll to start.
    CrackBerry Mod | Retired Android Central Mod | Tech Enthusiast
  17. Thread Author  Thread Author    #17  

    Default

    Lets see what the replacement NEXUS one has to offer me in the coming week. I will see to it that the replacement phone is near to perfect.

    icebike has helped alot in troubleshooting my WiFi issue and I can now confirm that it is my device which is at fault as rogerpodcaster also said the same above in one of his post.

    Regards
  18. #18  

    Default

    I'd be surprised if it turns out to be a hardware issue. I am experiencing the same thing with my Nexus One, but so are my friends with Incredible's and EVO 4G's.

    It is most noticeable for us with loss of gtalk connectivity after a few minutes of the phone sitting idle (as soon as you open gtalk you get a signing in message or just a rush of new incoming messages). I don't experience gtalk disconnects or delays if I stay in 3G mode.

    The whole wifi stack seems immature. if you have wifi on when you go to sleep you often wake up in the morning to find 3G connection only, requiring manually reconnecting to router. Also, unlike my BlackBerry which could connect and disconnect from wifi automatically, as I walked into a building, the Nexus One rarely automatically connects. I suspect it all is related.

    Strange coincidence if its a hardware thing.
  19. #19  
    Duvi's Avatar

    Posts
    875 Posts
    Global Posts
    19,919 Global Posts

    Default

    Great... please let me know.
    CrackBerry Mod | Retired Android Central Mod | Tech Enthusiast
  20. #20  
    Duvi's Avatar

    Posts
    875 Posts
    Global Posts
    19,919 Global Posts

    Default

    Quote Originally Posted by BigVDawgy View Post
    I'd be surprised if it turns out to be a hardware issue. I am experiencing the same thing with my Nexus One, but so are my friends with Incredible's and EVO 4G's.

    It is most noticeable for us with loss of gtalk connectivity after a few minutes of the phone sitting idle (as soon as you open gtalk you get a signing in message or just a rush of new incoming messages). I don't experience gtalk disconnects or delays if I stay in 3G mode.

    The whole wifi stack seems immature. if you have wifi on when you go to sleep you often wake up in the morning to find 3G connection only, requiring manually reconnecting to router. Also, unlike my BlackBerry which could connect and disconnect from wifi automatically, as I walked into a building, the Nexus One rarely automatically connects. I suspect it all is related.

    Strange coincidence if its a hardware thing.
    I actually have the opposite happen... it won't
    automatically disconnect when I'm out of range.
    It's actually quite annoying because I'll leave my
    house, go on the road and since I'm driving, I use
    the voice recognition to dial, but it requires data,
    but since I'm already on the highway, it needs to
    use 3G. The probably is that it shuts off 3G and
    is still trying to latch on to either my home network
    or any wifi signal (not sure which yet). I have to
    manually shut wifi off to be able to get it to work.
    At this point, I would have been better off finding
    the contact manually in my recent call log.
    CrackBerry Mod | Retired Android Central Mod | Tech Enthusiast
  21. #21  
    ItnStln511's Avatar
    Banned

    Posts
    626 Posts
    Global Posts
    2,984 Global Posts

    Default

    Is the WiFi sleep function intended to save battery life when the phone is asleep?
  22. #22  

    Default

    Yes but it has the reverse effect. Leaving WiFi always on is actually much more battery friendly than 3g.
  23. #23  

    Default

    Quote Originally Posted by Duvi View Post
    I actually have the opposite happen... it won't
    automatically disconnect when I'm out of range.
    It's actually quite annoying because I'll leave my
    house, go on the road and since I'm driving, I use
    the voice recognition to dial, but it requires data,
    but since I'm already on the highway, it needs to
    use 3G. The probably is that it shuts off 3G and
    is still trying to latch on to either my home network
    or any wifi signal (not sure which yet). I have to
    manually shut wifi off to be able to get it to work.
    At this point, I would have been better off finding
    the contact manually in my recent call log.
    And what does your wifi sleep policy say?
  24. #24  
    Duvi's Avatar

    Posts
    875 Posts
    Global Posts
    19,919 Global Posts

    Default

    Quote Originally Posted by icebike View Post
    And what does your wifi sleep policy say?
    "Never" sleep. Did this even when I wasn't using
    that.
    CrackBerry Mod | Retired Android Central Mod | Tech Enthusiast
  25. #25  
    ItnStln511's Avatar
    Banned

    Posts
    626 Posts
    Global Posts
    2,984 Global Posts

    Default

    Quote Originally Posted by RogerPodacter View Post
    Yes but it has the reverse effect. Leaving WiFi always on is actually much more battery friendly than 3g.
    Kind of makes sense.....
Page 1 of 3 123 LastLast

Posting Permissions