1. Amylase453's Avatar
    I've collected some free apps the Amazon app store but the Appstore app, itself, doesn't work or forces a login each time. You can get it to work if you're persistent but it's a hassle. Has anyone else had success?
    11-19-2012 07:22 AM
  2. PaulH2's Avatar
    From reading around, it seems this is an issue with Android 4.2 rather than specifically with the Nexus 10 (Nexus 7 and Galaxy Nexus users are having the same problem after upgrading to 4.2). In one of the threads on the Nexus 7 forum, it was mentioned that somebody had reported the issue to Amazon and they were aware of the issue and working on an update that they expected to not take long.

    Hopefully the microscopic text size on the Nexus 10 will be fixed too...
    Caveman419 likes this.
    11-19-2012 09:09 AM
  3. Amylase453's Avatar
    Oh good, thanks!
    11-19-2012 09:17 AM
  4. dmaul3300's Avatar
    here is a response I got from Amazon. I am at work and my tablet is home.I will try it when I get home tonight.

    I'm sorry for the trouble you had with Amazon Appstore apps on your Android device. I've reported this to our technical team, and they're working on taking care of it.

    In the meantime, I request you to please download and install the previous version of Amazon Appstore by visiting the link below on your device, as the issue is with all customers using version 4.2 of Android.

    https://s3.amazonaws.com/public-mas-...lease-v4.3.apk

    Please note that this is a temporary work around and is only for the time-being --until weve the permanent fix available.
    11-19-2012 10:59 AM
  5. Amylase453's Avatar
    Is working much better, thanks!
    11-19-2012 03:50 PM
  6. dmaul3300's Avatar
    I just installed it and it seems to work. who knows when it will be fixed but at least this appears to work.

    now to get a hold of electronic arts to see how to to download the data for Madden 12 and let them know nba Jan doesn't work.
    11-19-2012 06:56 PM
  7. crxssi's Avatar
    https://s3.amazonaws.com/public-mas-...lease-v4.3.apk

    Please note that this is a temporary work around and is only for the time-being --until weve the permanent fix available.
    Thank you! This was driving me crazy. I had to get a magnifying glass out to actually log in, then I would have to uninstall and reinstall to get it to actually work, then it would work for a while and die. Makes you quickly realize how HORRIBLE the DRM is when even the apps you did manage to install all say "you have to be signed in to use this application".

    Update: Worked like a charm!
    11-19-2012 07:09 PM
  8. PaulH2's Avatar
    It looks like an updated Amazon Appstore was released overnight which appears to have fixed both the login and text size issues. Just redownload from amazon and you should be good to go: Install Amazon Appstore
    11-20-2012 08:24 AM
  9. Pamela Vazquez's Avatar
    I just replaced my polaroid tablet with a new one and have the same problem. Anyone else having this still?
    01-07-2013 07:36 AM
  10. srvctec's Avatar
    I just replaced my polaroid tablet with a new one and have the same problem. Anyone else having this still?
    I have this happening on my Droid X2. Never had the issue until the last few weeks. My latest version of the Amazon App Store, 4.5.16.0C.
    01-08-2013 10:32 PM
  11. lets_go_android's Avatar
    I have this happening on my Droid X2. Never had the issue until the last few weeks. My latest version of the Amazon App Store, 4.5.16.0C.
    Yeah, same here (on a Verizon Galaxy Nexus running Android 4.1.1).
    01-09-2013 04:56 PM
  12. msndrstood's Avatar
    Yeah, same here (on a Verizon Galaxy Nexus running Android 4.1.1).
    I'm having trouble with the Amazon mp3 store. I keep getting an error code of 139. It directs me to a FAQS/Help page. While digging through that page, it tells me that I am on a Linux machine and it is not compatible with the mp3 store. I have a Sprint Gnex on JB 4.1.1 stock and locked. Any ideas? Never had this problem with my Nexus S 4G on JB 4.1.1, stock and locked...

    What?! ...I'm msndrstood.
    via Gnex
    01-09-2013 05:57 PM
  13. lets_go_android's Avatar
    I'm having trouble with the Amazon mp3 store. I keep getting an error code of 139. It directs me to a FAQS/Help page. While digging through that page, it tells me that I am on a Linux machine and it is not compatible with the mp3 store. I have a Sprint Gnex on JB 4.1.1 stock and locked. Any ideas? Never had this problem with my Nexus S 4G on JB 4.1.1, stock and locked...
    I'm assuming you get that while trying to buy an mp3? I've never bought using their Amazon MP3 app before, so I don't have any experience with that. But I have just downloaded and installed their Amazon MP3 app and the songs+albums I had previously bought from a desktop do show up fine at least. Have you tried re-installing the Amazon MP3 app? A couple of users (link below) suggested checking that your credit card info is there or doing a "force stop" on the Amazon MP3 app.
    Amazon.com: Customer Discussions: Android MP3 Download Error

    Hope that helps.
    msndrstood likes this.
    01-10-2013 11:23 AM
  14. RonD's Avatar
    I would clear cache for the app and see if it works. If that doesn't work clear data and see if it works. Finally if that doesn't fix the problem, uninstall the app and start over with a fresh install.
    msndrstood likes this.
    01-10-2013 12:43 PM
  15. msndrstood's Avatar
    I'm assuming you get that while trying to buy an mp3? I've never bought using their Amazon MP3 app before, so I don't have any experience with that. But I have just downloaded and installed their Amazon MP3 app and the songs+albums I had previously bought from a desktop do show up fine at least. Have you tried re-installing the Amazon MP3 app? A couple of users (link below) suggested checking that your credit card info is there or doing a "force stop" on the Amazon MP3 app.
    Amazon.com: Customer Discussions: Android MP3 Download Error

    Hope that helps.
    I got it fixed...uninstalled the Amazon MP3 app and deleted my checking account as one of the options to pay and just left my CC, now it works fine. Probably the checking account info, because the App was a fresh install. Who knows, but it works now. Thanks for the help! It seems there were a few people with the error problem, thanks for the Amazon link lets_go_android! ...
    01-10-2013 12:49 PM
  16. lets_go_android's Avatar
    I got it fixed...uninstalled the Amazon MP3 app and deleted my checking account as one of the options to pay and just left my CC, now it works fine. Probably the checking account info, because the App was a fresh install. Who knows, but it works now. Thanks for the help! It seems there were a few people with the error problem, thanks for the Amazon link lets_go_android! ...
    Cool, I'm glad you got it resolved! RonD's suggestion (try clearing cache and/or data) was also a good one.
    01-10-2013 01:57 PM
  17. msndrstood's Avatar
    Cool, I'm glad you got it resolved! RonD's suggestion (try clearing cache and/or data) was also a good one.
    I had done both first, no joy. So moved on to uninstall/install and Amazon acct update (I did this before reinstalling) which fixed it for me.

    What?! ...I'm msndrstood.
    via Gnex
    lets_go_android likes this.
    01-10-2013 05:58 PM
  18. lets_go_android's Avatar
    I had done both first, no joy. So moved on to uninstall/install and Amazon acct update (I did this before reinstalling) which fixed it for me.
    Ah, I see. Good to know. Thanks for the info. I'm sure it'll help others with this problem or may also be applicable to problems with other apps.
    msndrstood likes this.
    01-10-2013 07:57 PM
  19. dewmanc's Avatar
    Anyone still having problems with amazon appstore? It was working before the latest update. Now it won't open. Any suggestions?
    08-05-2013 01:40 AM
  20. JasW's Avatar
    Anyone still having problems with amazon appstore? It was working before the latest update. Now it won't open. Any suggestions?
    No problem here, even after 4.3.
    08-07-2013 09:20 AM

Similar Threads

  1. Voice to Text sometimes doesn't work
    By hal1 in forum Verizon HTC Thunderbolt
    Replies: 2
    Last Post: 05-22-2011, 03:28 AM
  2. activation fee each time you activate...
    By Xm_jdm in forum Motorola Xoom
    Replies: 23
    Last Post: 02-22-2011, 12:39 AM
  3. Is there a way to get Local IPs given each time phone reboots?
    By nebody00 in forum LG Optimus S Rooting, ROMs, and Hacks
    Replies: 7
    Last Post: 01-17-2011, 05:16 PM
  4. Requiring login every visit
    By biggbrother2 in forum Site Feedback & Help
    Replies: 1
    Last Post: 12-01-2010, 09:03 AM
  5. Replies: 8
    Last Post: 05-19-2010, 05:52 PM
LINK TO POST COPIED TO CLIPBOARD