Results 1 to 25 of 25
Like Tree2Likes
  • 2 Post By Billeeee
  1. Thread Author  Thread Author    #1  

    Default Slow WiFi after 4.4 upgrade on Nexus 10 (solved)

    Immediately after the 4.4 upgrade I noticed that my WiFi was significantly (25%) slower and very choppy. Three other wireless devices on the same network still run at the normal speed. I have done all of the normal troubleshooting steps like resetting the router and modem, rebooting the Nexus 10, DNS, IP, etc.

    One of the speed test apps I used has a graph of download speed vs. time. It shows the speed drop off to almost zero every few seconds in a very regular pattern. It almost looks like a buffer is filling up and transfer is delayed until it can empty. The problem occurs on both 2.4 and 5 GHz and is not dependent on signal strength or distance from the router.

    Any suggestions would be welcome
    Last edited by Billeeee; 11-23-2013 at 02:37 PM.
  2. #2  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10

    Have you tried wiping the cache partition?


    • If your tablet is on, power it off.
    • Press and hold Power, Volume Up, and Volume Down at the same time for several seconds. You will see the wordStart with an arrow drawn around it.
    • Press Volume Down twice, until you see the option Recovery mode.
    • Press Power to restart into Recovery mode. You should see an image of an Android with a red exclamation point.
    • While holding down Power, press Volume Up.
    • Use the Volume keys to scroll to wipe cache partition and press Power to select it.
    • When complete, highlight reboot system now, and press Power​.
  3. Thread Author  Thread Author    #3  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10

    Thanks for the input B. Diddy. It was worth trying based on the symptoms but it didn't fix the problem. Any other thoughts?
  4. #4  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10

    Do you have it set to 2.4, 5 or auto? Mine works best on auto.
    Pat
    Nook Color - CM10.1 ( Jelly Bean 4.2.2) on eMMC
    Google Galaxy Nexus - stock Jelly Bean 4.3
    Galaxy Nexus 10 - stock KitKat 4.4.2
    Galaxy Nexus 7 (2nd Generation) - stock KitKat 4.4.2
    Chromecast
    Nexus 5 - stock KitKat 4.4.2
  5. Thread Author  Thread Author    #5  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10

    patruns: Yes it's on auto.
  6. #6  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10

    Try changing the wifi channel on the router? Check the local traffic using to see if there are a lot of nearby routers using the same channel.
  7. Thread Author  Thread Author    #7  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10

    Not much local traffic but I tried other channels anyway. No luck.
  8. Thread Author  Thread Author    #8  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10

    Solved it !

    The culprit was location services mode being in "battery saving". If I switch to either of the other two modes it runs solid as a rock. Ping drops from 40 to 15ms, speed goes from 14 to 23 Mbs, and the speed is constant over time. I tried switching back and forth several times and I can repeat the effect.

    This only started after the 4.4 upgrade so there may be a bug.

    Thanks to all who replied to my problem.
    Thanked by 5:
    crxssi and ChrisS#AC like this.
  9. #9  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10

    Interesting! I have Battery Saving mode on for my 2013 N7, and I haven't noticed any issues like that yet. Will watch out for it. Thanks for the followup!
  10. #10  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10

    Quote Originally Posted by Billeeee View Post
    Solved it !

    The culprit was location services mode being in "battery saving". If I switch to either of the other two modes it runs solid as a rock. Ping drops from 40 to 15ms, speed goes from 14 to 23 Mbs, and the speed is constant over time. I tried switching back and forth several times and I can repeat the effect.

    This only started after the 4.4 upgrade so there may be a bug.

    Thanks to all who replied to my problem.
    Hiya! I've been suffering from the same problem! How do I get to 'location services' to change the settings? Cheers
  11. #11  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10 (solved)

    I'm a new Nexus owner and have experienced this.

    It would say it was connected but constantly drop signal and not load web pages/play store.

    The tablet was on Android 4.2.2 when first started and one if the first things I did was get the latest OTA. After that the wifi was terrible. I did think it was a faulty tablet until I decided to root it, then eventually unroot it. I was then left with the tablet in the state I first had it, Android 4.2.2. The WiFi is now brilliant. I'm not updating until I know 100% this has been fixed. Its a shame because Im the type who gets fidgety if I know there's an update out and I can't have it! I must be up to date! Haha.

    Any help would be appreciated.
  12. #12  
    dhawk1202's Avatar

    Posts
    83 Posts
    Global Posts
    87 Global Posts
    ROM
    AOKP/ Franco Kernal

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10

    Quote Originally Posted by Billeeee View Post
    Solved it !

    The culprit was location services mode being in "battery saving". If I switch to either of the other two modes it runs solid as a rock. Ping drops from 40 to 15ms, speed goes from 14 to 23 Mbs, and the speed is constant over time. I tried switching back and forth several times and I can repeat the effect.

    This only started after the 4.4 upgrade so there may be a bug.

    Thanks to all who replied to my problem.
    Dude! I've been looking for a solution for awhile to this! I'm currently waiting on a replacement divice because of this! I did not try the battery saving mode! Ugh!

    Posted via Android Central App
  13. #13  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10

    I recently purchased a 2013 Nexus 7 which had terrible wifi throughput. On average it would only see about 2m while all other devices in the apartment including a 2012 N7 saw my full internet speed. Google forums suggested switching the router from B/G/N to B/G. This increased my throughput but its disappointing that I can't take advantage of "N". I hope google looks into this.
  14. #14  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10 (solved)

    Quote Originally Posted by Billeeee View Post
    Solved it !

    The culprit was location services mode being in "battery saving". If I switch to either of the other two modes it runs solid as a rock. Ping drops from 40 to 15ms, speed goes from 14 to 23 Mbs, and the speed is constant over time. I tried switching back and forth several times and I can repeat the effect.

    This only started after the 4.4 upgrade so there may be a bug.

    Thanks to all who replied to my problem.
    For me the problem is only solved by switching to 'Device only' in location mode. Connection constantly drops in the other two.
  15. #15  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10 (solved)

    Below steps Fixed the issue for me.

    Go to "settings - Wi-Fi - Advanced - And uncheck Wi-Fi optimization tick.
    Thanked by 2:
    crxssitsells 
  16. #16  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10 (solved)

    I've tried everything to improve the WiFi on this device and have just learned to accept that the WiFi is just horrific. Worse I've ever experienced. Other than that I like the device, I just can't use it to stream wireless HD video from my home server reliably. I've tried multiple routers, and the WiFi at work isn't any better. Oh well. I got it cheap.
  17. #17  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    1,880 Posts
    Global Posts
    2,199 Global Posts

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10 (solved)

    I can't believe it, I was hit with the exact same problem. I was getting 0.5 Mb/s on G with the setting on and 4 Mb/s with it off. EIGHT HUNDRED PERCENT FASTER. THIS IS WHILE ON WALL POWER. Google, get your act together, this is a huge problem!

    Then I rebooted the tablet and got 17Mb/s down 8Mb/s up (hitting the max on up of my ISP). Yeesh.
    Last edited by crxssi; 02-01-2014 at 05:05 PM.
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5, Nexus 10, Evo LTE, Evo 3D, Evo 4G
  18. #18  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10

    You've got to be kidding me!!! I've been trying to find an answer to this problem (day & night) on my AT&T S4 since the 4.4.2 upgrade.

    Everybody seems to think they've got an answer to this issue, but this is the only one that worked (at least for me)! Thanks so much. My S4 now downloads at full speed again, and has much lower pings, as it had prior to the update.

    Now an editorial comment:
    WTF!!?? Why do I have to have all location features enabled in order to get my download speeds back? Shouldn't be related, should it? This wasn't necessary before, so why now? Now, in order to secure my best download speeds, I'm forced to make a decision between speed and battery. I repeat...WTF!!??

    Thanks again, though. This one was driving me crazy. I was certain that a full factory reset would do it, but not so much. This did.
  19. #19  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    1,880 Posts
    Global Posts
    2,199 Global Posts

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10

    Quote Originally Posted by jeffreyh51 View Post
    You've got to be kidding me!!! I've been trying to find an answer to this problem (day & night) on my AT&T S4 since the 4.4.2 upgrade
    Interestingly, although it bit me on the Nexus 10, it hasn't on the Nexus 5 yet.
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5, Nexus 10, Evo LTE, Evo 3D, Evo 4G
  20. #20  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10

    Quote Originally Posted by crxssi View Post
    Interestingly, although it bit me on the Nexus 10, it hasn't on the Nexus 5 yet.
    I hear ya. Hasn't surfaced on my Nexus 7 2013 either.

    Posted via Android Central App
  21. #21  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10 (solved)

    Tmobile upgrade to 4.4.2 last night for the S4. I thought I had no issues until tonight when an app was updating and it took forever. I ran ookla speed test and my speed was less than half of what it usually is. I figured a glitch, and ran it again. I have fios quantum so even half speed is good, but it's not what it was.
    I restarted the router, and same thing.
    I was ready to call Verizon when I figured I'd check with another device.
    The ipad reported normal speeds, so that ruled out Verizon.
    Then it dawned on me, I just had the upgrade, could that be it?
    I found this thread and #18 was real close.
    I changed location to highest setting and speeds returned.
    Location mode in power saving, 17 mbps down and 17 up.
    Location mode in high accuracy, 43 mbps down and 36 up.
    Thanks for the thread and that I resolved this so quickly.
    Hopefully this helps sometime else.
    I wonder how many other people aren't noticing?
    Last edited by chriskiam; 03-11-2014 at 07:30 PM. Reason: spelling
  22. #22  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10 (solved)

    I am a fairly good test subject, since I just got my Nexus 10 yesterday and did very little to it but synced with my Google account and updated in two steps to 4.4.2. I get the exact download figures with all three location services settings (High Accuracy, Power Saving, and Device Only). The wifi is coming in at 33Mbps download. I wonder if it might be an app or two causing the problem.
  23. #23  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10 (solved)

    Quote Originally Posted by wealonice View Post
    Below steps Fixed the issue for me.

    Go to "settings - Wi-Fi - Advanced - And uncheck Wi-Fi optimization tick.
    I have mine ticked "on" and still get 33 Mbps download with 4.4.2.
  24. #24  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    1,880 Posts
    Global Posts
    2,199 Global Posts

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10 (solved)

    Quote Originally Posted by Viventis View Post
    I wonder if it might be an app or two causing the problem.
    I doubt it is an app. It is more likely the type of WiFi being used (protocol, security, frequency, speed) and/or some other setting combined with it.
    Click "Thanks" and/or "Like" button on posts where someone helped you or you liked the posting. Nexus 5, Nexus 10, Evo LTE, Evo 3D, Evo 4G
  25. #25  

    Default Re: Slow WiFi after 4.4 upgrade on Nexus 10 (solved)

    I've read all the advice on these posts and tried all the suggestions. But i have still got very slow internet .ive tried all the location options and does not seem to change much. Somethings load ok while most things are either very slow or time out and wont load. It is the same as the rest of you, it has only appeared since last upgrade.
    Only had the tablet for 4 weeks and very dissapointed with this. Is there anythingthat we can do to get google to fix this.
    All advice welcome. Thanks.

Similar Threads

  1. Samsung Galaxy Tab 3 - battery seems to drain fast on tab 3 10.1
    By Toney Perineau in forum Samsung Galaxy Tab 3
    Replies: 7
    Last Post: 02-22-2014, 07:21 AM
  2. Samsung Galaxy Note 3 in Canada - One email does not work on Data
    By wylcanada in forum Samsung Galaxy Note 3 in Canada (Bell/Rogers/Telus)
    Replies: 3
    Last Post: 02-18-2014, 11:50 PM
  3. Can I use AT&T Samsung Galaxy S4 sim card in Google Nexus 5?
    By Patrick Li in forum Google Nexus 5
    Replies: 8
    Last Post: 11-23-2013, 02:18 PM
  4. Replies: 33
    Last Post: 11-23-2013, 09:40 AM
  5. Nexus 10 wont turn on
    By Jackie Han in forum Google Nexus 10 Tablet
    Replies: 2
    Last Post: 11-22-2013, 07:24 PM

Posting Permissions

B