11-17-2012 02:39 PM
  1. jordandj24's Avatar
    My phone won't connect to the internet when Wi-Fi is turned on. Anyone else having issues? I'm on T-Mobile's prepaid plan - are there any settings that I need to configure? Thanks!
    Matt Stewart1 likes this.
    11-16-2012 02:05 PM
  2. DirkBelig's Avatar
    Are you able to connect via T-Mobile's network? Check the setting listed here: Support: APN settings for data and picture messaging (MMS): Android
    11-16-2012 02:20 PM
  3. jordandj24's Avatar
    Yes, connecting through T-Mobile is no problem. Thanks for the link - I double checked and all my settings match. Not sure why Wi-Fi won't work though.
    11-16-2012 02:27 PM
  4. PhillyPhatFan's Avatar
    Mine wont connect to my home wifi keeps giving me an authentication error... when my s3 is connect and htc one x is also im not sure what that means but im selling my phone bc i need wifi i dont have unlimitied data so any one want to buy it let me know 16gb
    11-16-2012 05:01 PM
  5. Fairclough's Avatar
    Maybe its simple things, I have to tell mum this all the time. Half the time she didnt click connect.
    1) is the wifi on.'
    2) did you click connect
    3) typed the right password?
    11-16-2012 05:14 PM
  6. Andrew Martonik's Avatar
    To narrow everything down, I'd remove the SIM, reboot, force it to "forget" your Wifi network and try it over again.

    I'd also try to go to a public Wifi access point (like a coffee shop) or a friends house and try.

    If that fails, factory reset and try again. Just part of the troubleshooting process.
    jordandj24 likes this.
    11-16-2012 05:34 PM
  7. sjsmr2's Avatar
    Yes, connecting through T-Mobile is no problem. Thanks for the link - I double checked and all my settings match. Not sure why Wi-Fi won't work though.
    Did you have to manually enter the T-Mobile APN settings?
    11-16-2012 05:43 PM
  8. qnet's Avatar
    Maybe its simple things, I have to tell mum this all the time. Half the time she didnt click connect.
    1) is the wifi on.'
    2) did you click connect
    3) typed the right password?
    ^
    This.

    Also make sure your wifi passphrase is the same one you have used and hasn't changed. I've had several Nexus devices and phones. One time when I restored a device ( I believe it was my Nexus 7) I got a authentation error. I realized that I had changed my wifi passphrase and the N7 was trying to restore the previous one I was using.
    11-16-2012 06:08 PM
  9. jordandj24's Avatar
    Did you have to manually enter the T-Mobile APN settings?
    No, everything was already there. I was having issues with SMS and MMS and I ended up having to change the APN type to "default, supl, admin,dun,mms"
    sjsmr2 likes this.
    11-16-2012 09:56 PM
  10. jordandj24's Avatar
    ^
    This.

    Also make sure your wifi passphrase is the same one you have used and hasn't changed. I've had several Nexus devices and phones. One time when I restored a device ( I believe it was my Nexus 7) I got a authentation error. I realized that I had changed my wifi passphrase and the N7 was trying to restore the previous one I was using.
    I was using the guest wi-fi at my office and that was where I had the issue. It's working fine with the wi-fi at home now.
    11-16-2012 10:01 PM
  11. DirkBelig's Avatar
    Have you been able to connect to the guest wi-fi before with another phone? What's the security like on it? Is there something that needs to be accepted before you use it? Most public hotspots want you to accept their terms of use before you can do anything, so you need to open a browser to get the data flowing.
    11-16-2012 10:18 PM
  12. jordandj24's Avatar
    Have you been able to connect to the guest wi-fi before with another phone? What's the security like on it? Is there something that needs to be accepted before you use it? Most public hotspots want you to accept their terms of use before you can do anything, so you need to open a browser to get the data flowing.
    I've never had an issue connecting to the Guest wi-fi, as a matter of fact my ipod connects to it fine everyday. I'll try again on Monday but at the moment, everything seems to be working fine.
    11-16-2012 11:51 PM
  13. pedxing's Avatar
    Mine's been a little erratic as well. You may want to go to settings and then Wi-Fi and then go to the three dots options menu and then select advanced. Then uncheck the avoid poor Wi-Fi connections option and potentially the save battery while on Wi-Fi option as well. Then let us know how it goes.

    Sent from my Nexus 4 using Tapatalk 2
    11-17-2012 02:36 PM
  14. pedxing's Avatar
    I have two access points at home... Same ssid... But it kept using the weaker one for some reason and switching back and forth was confusing it in some way. My Galaxy nexus has this problem at times before I went to a custom ROM and kernel.

    Sent from my Nexus 4 using Tapatalk 2
    11-17-2012 02:39 PM

Similar Threads

  1. Wi-fi not connecting..
    By jumper809 in forum Verizon Galaxy Nexus
    Replies: 5
    Last Post: 03-13-2012, 02:11 PM
  2. Wi-Fi not conneting
    By FlyertalkerVulcan in forum Verizon Galaxy Nexus
    Replies: 0
    Last Post: 02-04-2012, 01:25 PM
  3. Wi-Fi not connecting
    By fred72matt in forum Toshiba Thrive
    Replies: 5
    Last Post: 08-26-2011, 02:53 PM
  4. Newsroom app, only refreshes on Wi-fi, not on data.
    By vespacar in forum Market Help
    Replies: 0
    Last Post: 01-18-2011, 09:11 AM
  5. Wi-Fi not working on CM 6.1.2
    By BerryChoppy in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 3
    Last Post: 01-04-2011, 10:46 PM
LINK TO POST COPIED TO CLIPBOARD