1. joshuay04's Avatar
    Has anyone else had data issues with their nexus 4? I have noticed that if connected to WiFi with no data signal, when you leave the WiFi range the data will not reconnect without enabling airplane mode. The symptoms are similar to those of the one x when it first came out. Yesterday I left work and halfway home I noticed I was still connected to my company WiFi. After turning of WiFi data reconnected and all of the missed emails and texts came in.

    AT&T hspa
    11-26-2012 07:47 PM
  2. qnet's Avatar
    I haven't noticed any issues overall but, at my job I have a little. My job is weird with cell phones. They put in repeaters to allow cell phone usage inside but, only verizon & at&t work ok for data. With T-mobile it's a strange crapshoot. It tries to access H+ but usaully falls back to no data unless I connect to my Mifi, then it goes to Edge.
    11-26-2012 08:09 PM
  3. boparunsxc's Avatar
    mine likes to connect to 3g until I use data and then switches to hspa+ (t-mo) but I havent had any issues switching between wifi and cellular networks.
    11-26-2012 09:39 PM
  4. rclifton's Avatar
    Has anyone else had data issues with their nexus 4? I have noticed that if connected to WiFi with no data signal, when you leave the WiFi range the data will not reconnect without enabling airplane mode. The symptoms are similar to those of the one x when it first came out. Yesterday I left work and halfway home I noticed I was still connected to my company WiFi. After turning of WiFi data reconnected and all of the missed emails and texts came in.

    AT&T hspa
    Are you using an AT&T MVNO by chance? If so it's a known issue, and has been going on to some extent since this past summer.
    11-26-2012 09:40 PM
  5. Tiddlekins's Avatar
    I'm having the same issue, and I'm on T-mobile.
    11-28-2012 04:25 PM
  6. lmrvrgs's Avatar
    Im also having data issues and i have tmobile too. It shows as if i have data but i cannot do anything then i have to restart my phone. Very annoying. I dont know whats up with it
    12-05-2012 09:15 AM
  7. minhaferzz's Avatar
    I'm having the same exact issue here. I'm on AT&T.
    12-05-2012 09:55 AM
  8. cpolism's Avatar
    Not that it relates to this phone, but I had these exact issues with my Nexus S. I remember getting so fed up with this.
    12-05-2012 09:58 AM
  9. N4Newbie's Avatar
    I saw the same thing with an HTC Evo 4G on Sprint/CDMA. If the phone has an active Wi-Fi connection, it will not initiate a data connection over cellular. If the Wi-Fi connection is weak, you are out of luck.

    Temporarily disable the Wi-Fi service and the problem immediately goes away.
    12-05-2012 10:29 AM
  10. Ed 115's Avatar
    having some issues too but not sure if its just tmobile. notification bar keeps switching from 3g to H, unless I start using data then it will latch on to hspa. wireless connection app shows it keeps switching to utms and hspa + (21mb/s) and the status of phone in my settings show it switching between umts, hsdpa 8 and hspa 15. im in chicago where theres supposed to be hspa+42. is this normal?

    oh and speed tests are generally as low as 3mbs to 20mbs.
    12-05-2012 01:00 PM
  11. 360Mobiles's Avatar
    I'm on AT&T and have no issues with data, voice or microcell.

    I made a video (if u like please Subscribe!)

    Nexus 4 Wifi+Cellular Performance! (Compared to Galaxy Nexus) - YouTube
    12-05-2012 05:15 PM
  12. PAC757's Avatar
    For those of you on T Mobile, I have a play store GSM Galaxy Nexus, and it appears that the sitting on 3G or E, while not using data is normal, mine always does, then when I access the internet or check my email it switches to H.
    Ed 115 likes this.
    12-05-2012 08:19 PM

Similar Threads

  1. Is anyone else having data issues with google??
    By intheb0x in forum HTC EVO 4G
    Replies: 58
    Last Post: 11-16-2010, 03:40 PM
  2. Mobile Data issues...
    By Vudumedic in forum Verizon Droid Incredible
    Replies: 0
    Last Post: 10-30-2010, 02:27 PM
  3. anyone in tristate area having data issues?
    By rjdangerous in forum Motorola Droid X
    Replies: 8
    Last Post: 07-29-2010, 07:17 PM
  4. Verizon Outage or Phone Data Issue
    By pashan in forum Verizon
    Replies: 4
    Last Post: 03-03-2010, 08:27 AM
  5. Nation wide T-Mobile data issues?
    By ILoveBlythe in forum Google / HTC Nexus One
    Replies: 13
    Last Post: 01-29-2010, 12:58 PM
LINK TO POST COPIED TO CLIPBOARD