Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 11 of 11
  1. Thread Author  Thread Author    #1  
    Lttlwing16's Avatar

    Posts
    767 Posts
    ROM
    Rooted AOSP

    Default [Problem] ST ATT GOOGLE VOICE

    Just set up our N4's with straight talk, ATT microsims. I am unable to get Google Voice setup on these. I have tried the following:

    going to google.com/voice and updating the settings, deactivating, re-activating, dialing the *004*GVNUMBER (repeated this 2 or 3 times)

    Updating the settings in Phone--Settings--Voicemail

    Wiping GV cache, data, uninstall/re-install (multiple times)

    After all this, I am wondering if call forwarding is disabled by default.

    Is anyone else using GV with ST ATT microsim, with success? If so, what am I missing?

    FYI the Straight Talk VM service is functional, but I would like to use GV : )

    Thanks in advance
    I am a product of my failures.

    It's not the law, just a suggestion..

    "Let's Flash Together" Bigjobber69.
  2. #2  

    Default Re: [Problem] ST ATT GOOGLE VOICE

    I had a difficult time setting up GV coming off an iphone 4. The instructions you get from GV or the internet about dialing *004*GVNUMBER# wouldn't work at all. After digging for a while I figured out how to do it.

    1. There's nothing to do in GV except making sure your phone number is correct.
    2. Everything you need to edit is in the phone dialer application on the Nexus 4. Go to the dialer, select settings (the three little vertical dots), then go to 'Call Forwarding Settings'

    There's three things you'll need to set. First, take note of the original number set there in case you need to revert for any reason.

    • Forward When Busy
    • Forward When Unanswered
    • Forward When Unreachable



    Set all of the above to your GV number. Presto, it should work from there! At least it did for me.
    Thanked by:
  3. Thread Author  Thread Author    #3  
    Lttlwing16's Avatar

    Posts
    767 Posts
    ROM
    Rooted AOSP

    Default Re: [Problem] ST ATT GOOGLE VOICE

    Thanks, unfortunately this didn't work. I tried replacing with my gv access number and the number given to me in the *004*NUMBER . Both result in same response ..."your call cannot be completed"

    I do have two factor auth turned on for my g-account. Wonder if that's the deal...

    Sent from my Nexus 7 using Tapatalk
    I am a product of my failures.

    It's not the law, just a suggestion..

    "Let's Flash Together" Bigjobber69.
  4. #4  

    Default Re: [Problem] ST ATT GOOGLE VOICE

    I have a Nexus 4 with a Net10 ATT micro sim and am having the same problem. This is a huge issue for me since google voice is my business number and I use the cell number for personal.
  5. #5  
    klau25's Avatar

    Posts
    473 Posts
    Global Posts
    496 Global Posts

    Default Re: [Problem] ST ATT GOOGLE VOICE

    I dialed the number too, and it didn't work for me either. What I did was instead of dialing the number to set it up, I just uninstalled the gv app, reinstalled it again, and let gv do the initial setup. everything works after.

    Sent from my Nexus 7 using Android Central Forums
  6. #6  

    Default Re: [Problem] ST ATT GOOGLE VOICE

    Works fine for me, all I did was intall the app go through the setup then mess with the settings on Google.com/voice . It usually fails to use GV to make a call unless you try twice, but that's a different issue. n
  7. #7  

    Default Re: [Problem] ST ATT GOOGLE VOICE

    Quote Originally Posted by seventeenseconds View Post
    I had a difficult time setting up GV coming off an iphone 4. The instructions you get from GV or the internet about dialing *004*GVNUMBER# wouldn't work at all. After digging for a while I figured out how to do it.

    1. There's nothing to do in GV except making sure your phone number is correct.
    2. Everything you need to edit is in the phone dialer application on the Nexus 4. Go to the dialer, select settings (the three little vertical dots), then go to 'Call Forwarding Settings'

    There's three things you'll need to set. First, take note of the original number set there in case you need to revert for any reason.

    • Forward When Busy
    • Forward When Unanswered
    • Forward When Unreachable



    Set all of the above to your GV number. Presto, it should work from there! At least it did for me.
    This worked for me on my Nexus4.

    1. In the Dialer app: I changed my Voicemail settings to Google Voice.
    2. In the Dialer app: Changed those call forwarding number settings
    3. Went to the Google voice settings web page and all of a sudden the *004*GVNUMBER# call forwarding code worked successfully.

    I had tried just entering the code and other ones as well but they all failed before i changed the call forwarding number in the dialer settings; it seems you have to do that first.
  8. #8  

    Default Re: [Problem] ST ATT GOOGLE VOICE

    Quote Originally Posted by seventeenseconds View Post
    I had a difficult time setting up GV coming off an iphone 4. The instructions you get from GV or the internet about dialing *004*GVNUMBER# wouldn't work at all. After digging for a while I figured out how to do it.

    1. There's nothing to do in GV except making sure your phone number is correct.
    2. Everything you need to edit is in the phone dialer application on the Nexus 4. Go to the dialer, select settings (the three little vertical dots), then go to 'Call Forwarding Settings'

    There's three things you'll need to set. First, take note of the original number set there in case you need to revert for any reason.

    • Forward When Busy
    • Forward When Unanswered
    • Forward When Unreachable



    Set all of the above to your GV number. Presto, it should work from there! At least it did for me.
    This also worked fine on my wife's N4. Try rebooting the phone, then go back into the Call Forwarding section of the dialer and re-enter the numbers.

    - - - Updated - - -

    Quote Originally Posted by seventeenseconds View Post
    I had a difficult time setting up GV coming off an iphone 4. The instructions you get from GV or the internet about dialing *004*GVNUMBER# wouldn't work at all. After digging for a while I figured out how to do it.

    1. There's nothing to do in GV except making sure your phone number is correct.
    2. Everything you need to edit is in the phone dialer application on the Nexus 4. Go to the dialer, select settings (the three little vertical dots), then go to 'Call Forwarding Settings'

    There's three things you'll need to set. First, take note of the original number set there in case you need to revert for any reason.

    • Forward When Busy
    • Forward When Unanswered
    • Forward When Unreachable



    Set all of the above to your GV number. Presto, it should work from there! At least it did for me.
    This also worked fine on my wife's N4. Try rebooting the phone, then go back into the Call Forwarding section of the dialer and re-enter the numbers.
    Semper Fi
    I love my Moto X 2014!
    Take better pictures with your cell phone camera...http://www.bigshotmoms.com/
  9. #9  

    Default Re: [Problem] ST ATT GOOGLE VOICE

    I use GV for just voicemail and txts. When doing a conditional call forward from your nexus you need to add an extra * at the start of your dialing. So it will look like this **004*xxxxxxxxxx# send

    xxx's are your GV phone number
    Thanked by 2:
  10. Thread Author  Thread Author    #10  
    Lttlwing16's Avatar

    Posts
    767 Posts
    ROM
    Rooted AOSP

    Default Re: [Problem] ST ATT GOOGLE VOICE

    Thank you all. Finally got it to stick. I believe the **004 did the trick.

    Sent from my Nexus 7 using Tapatalk
    I am a product of my failures.

    It's not the law, just a suggestion..

    "Let's Flash Together" Bigjobber69.
  11. #11  

    Default Re: [Problem] ST ATT GOOGLE VOICE

    I ead on XDA somewhere that after making this Conditional Call Forwarding call, you need to redo the settings in Google Voice for setting up voicemail. You might need to uninstall it & reinstall it in order to get the setup to work. Running the GV setup worked for me.

    Quote Originally Posted by thecavemankevin View Post
    I use GV for just voicemail and txts. When doing a conditional call forward from your nexus you need to add an extra * at the start of your dialing. So it will look like this **004*xxxxxxxxxx# send

    xxx's are your GV phone number
    <Insert creative signature here>

Similar Threads

  1. New Google Voice Search Problems.
    By Execute in forum Incredible Rooting, ROMs, and Hacks
    Replies: 18
    Last Post: 08-16-2010, 11:13 AM
  2. 2.2 Froyo problem with Google Voice
    By TheMan876 in forum Motorola Droid Rooting, ROMs and Hacks
    Replies: 22
    Last Post: 07-14-2010, 03:02 PM
  3. Google Voice and Voicemail notification problems
    By gmintz in forum Motorola Droid
    Replies: 2
    Last Post: 05-14-2010, 04:20 PM
  4. Google Voice Problem
    By buya97 in forum Verizon Droid Incredible
    Replies: 2
    Last Post: 05-13-2010, 08:43 PM
  5. google voice problems
    By Slewman in forum HTC Droid Eris
    Replies: 5
    Last Post: 01-25-2010, 10:28 AM

Posting Permissions