1. edodo0317's Avatar
    Just got the Nexus 4 and pop my t-mobile (cut myself) sim into the phone. It recognized and able to make call and send text message. However, it is not logging into the data network. What is it? Is it the something about the cutting of the sim? Please guide me thru this.
    12-14-2012 03:21 PM
  2. AbuYazeedUK's Avatar
    Either that or the APN settings
    edodo0317 likes this.
    12-14-2012 03:28 PM
  3. edodo0317's Avatar
    Either that or the APN settings
    I guess I will take to T-mobile. Hope they can swap out a micro sim to me.
    12-14-2012 03:39 PM
  4. twinkle3's Avatar
    Turn phone on and off a few times and it will pick up network
    edodo0317 and KitN like this.
    12-14-2012 03:42 PM
  5. edodo0317's Avatar
    Turn phone on and off a few times and it will pick up network
    Will give it a try and see if work. Thank you.
    12-14-2012 04:04 PM
  6. donec's Avatar
    Are you a new customer or did you have an account with T-mobile before you got your Nexus 4?
    12-14-2012 08:56 PM
  7. Citizen Coyote's Avatar
    Will give it a try and see if work. Thank you.
    Try resetting your APN back to default, too. Doing this fixed an issue I was having with data networks several days ago.
    12-14-2012 11:21 PM
  8. SOLGarion's Avatar
    Rain dance. Always fixes things.

    Sent from my Nexus 4 using Android Central Forums
    12-14-2012 11:22 PM
  9. GiantJay's Avatar
    If you ported your number from a different carrier that could have caused an issue.

    Sent from my Nexus 7 using Tapatalk 2
    12-15-2012 03:12 AM
  10. edodo0317's Avatar
    Thanks guys. Turn off and turn on the device do the trick. It now working with data. It could be my home also has a weak signal. One bar. But now works. Thanks again.
    12-16-2012 01:18 PM
  11. PWC Realtor's Avatar
    I found this out the hard way too. This phone unlike the GNex doesn't prompt you to restart the phone upon inserting a new SIM.

    Sent from my Nexus 4 using Android Central Forums
    12-16-2012 01:54 PM
  12. KitN's Avatar
    Turn phone on and off a few times and it will pick up network
    Yep, that's what I did: turned it off then on again and our worked like a charm.

    Sent from my Nexus 4
    12-16-2012 04:41 PM

Similar Threads

  1. I wiped everything on my NEXUS! please help
    By josequi in forum Verizon Galaxy Nexus Rooting, ROM's, and Hack's
    Replies: 14
    Last Post: 12-13-2012, 12:54 PM
  2. Help - I deleted the clock on my Nexus 4
    By p1neapples in forum General Help and How To
    Replies: 5
    Last Post: 12-07-2012, 10:27 AM
  3. Replies: 1
    Last Post: 01-16-2012, 11:19 PM
  4. Not delivered SMS on my nexus :(
    By sinister90 in forum Google / HTC Nexus One
    Replies: 3
    Last Post: 02-07-2010, 12:36 AM
  5. Need help on my rooted my touch 3g hero rom
    By VoLoDaR1 in forum HTC Hero Rooting, ROMs, and Hacks
    Replies: 1
    Last Post: 12-17-2009, 08:34 AM
LINK TO POST COPIED TO CLIPBOARD