04-19-2016 04:38 AM
45 12
tools
  1. nl0523's Avatar
    Has anyone else been experiencing the following USB connection problems with their Nexus 4?

    Whenever I connect the phone to either of my Windows 7 PCs via the supplied USB cable, one of the following things will happen:

    - Nothing happens...no "Connected as a media device" message pops up on the phone, and Windows doesn't make the usual USB-connected "double bonk" sound. The phone does not show up in "My Computer"
    - The "Connected as a media device" message will show up on the phone, Windows will make the USB-connected "double bonk" sound immediately followed by the USB-disconnected "double bonk" sound. Again, the phone does not show up in "My Computer"
    - The "Connected as a media device" message will show up on the phone, but Windows will show a "USB device not recognized" message and doesn't properly load the drivers.
    - Everything occurs as it should...all the usual USB-connected sounds and message, proper drivers, and the phone shows up in "My Computer"

    Note that in all of the above cases, the phone will always charge properly when the USB cable is plugged in, regardless of the USB connection status.

    I am using the USB cable that came with the phone, and I've tried every USB hub, port, etc that I have. All show the same flakiness.

    I am suspecting that there might be an issue with the USB cable or the USB micro-b port on the phone because I've noticed that I can get the connection to come and go away just by applying very light force and/or wiggle to the micro-b connector when it is plugged into the port on the bottom of phone.

    I've searched on many forums and haven't been able to find a single reported incident of this from anyone else with the Nexus 4, but I have read a few similar issues with other Android devices. I've tried the solutions posted (reboot phone, toggle between MTP and PTP transfer modes, etc.) but none of them make a difference in my case.

    Any feedback is greatly appreciated, even if it's just to say "I've never had any problems with USB on my phone. It's always rock solid."

    Thanks
    the_man likes this.
    12-14-2012 11:20 PM
  2. N4Newbie's Avatar
    I have not had this problem.

    Is your phone in a case? I have found that the USB port cutout in my iBlason tpu case interferes with some of my many different USB cables, making it difficult to fully seat the connector.
    12-15-2012 02:02 AM
  3. rjdrawde's Avatar
    I too am having this exact issue... Definitely strange especially considering the phone continues to charge no matter what. I was suspecting the cable to be malfunctioning too, but haven't had a chance to try a different one. And no, I don't have a case.
    12-15-2012 02:31 AM
  4. Parth Ghetia's Avatar
    I have the same issue. Charging had no problems, only USB.
    12-15-2012 09:28 AM
  5. nl0523's Avatar
    I have not had this problem.

    Is your phone in a case? I have found that the USB port cutout in my iBlason tpu case interferes with some of my many different USB cables, making it difficult to fully seat the connector.
    I have the stock Google Nexus 4 bumper, but the problem occurs both with and without the bumper.
    12-15-2012 07:20 PM
  6. kgeissler's Avatar
    I am having the exact same problem. I am running Windows 8 and have to keep unplugging the usb cable and plug it back in. Eventually it will work.

    Sent from my Nexus 4 using Tapatalk 2
    12-15-2012 07:30 PM
  7. Thorben Groth's Avatar
    Hey,

    my PC won't recognize the Nexus 4 at all. No plong sound, nothing.. But, as you reported, it charges as expected.
    It really sucks right now because I need to get access to a file on the device.. :/
    12-18-2012 11:43 AM
  8. Tervijawn's Avatar
    If you're on a desktop PC, are you using the back USB ports or the front USB ports? Front ports provide less power and may not recognize the storage device.
    12-18-2012 12:28 PM
  9. Eric1987's Avatar
    Try a different port or reinstal the drivers that it installed in the first place.
    12-18-2012 01:21 PM
  10. gone down south's Avatar
    Try a different cable?

    Sent from my Nexus 4 using Android Central Forums
    12-18-2012 03:07 PM
  11. nl0523's Avatar
    Just wanted to post an update and a solution.

    I discovered that sometimes when I thought the phone was charging it actually wasn't. The lock/home screen would say "charging", and the little lightning bolt would show up on the battery icon, but if I went into the battery settings, it would say "not charging". Also, the battery charge percentage would not increase. The only way it would reliably charge through USB was if I actually got Windows to recognize the device correctly (i.e. got it to show up in "My Computer").

    I went out and bought a new USB cable and haven't had any problems since. The device is correctly recognized on every USB port I've tried (my USB hub, front case connector, back of motherboard, and on my laptop). Funny since the Nexus 4 manual says to use only the supplied cable.

    Hope this helps others who are having this problem.
    12-21-2012 10:36 AM
  12. BillyDan's Avatar
    I'm using Windows 7. When I plug it in to any of the USB ports it shows up as the "Nexus 4" in My Computer, but when you click on it, you don't see any of the file structure. I basically can't transfer any files to it.

    It did work one time, but has not ever since. I have tried it in multiple USB ports on my computer.

    As an odd aside, I'm also having issues with wireless transfer with WINAMP. It initially recognized the device and was doing transfers, but now does not recognize it. Anyone have any thoughts? I have reconfirmed that both are operating on the same wireless network. Don't know why they are not connecting.
    12-22-2012 10:37 PM
  13. N4Newbie's Avatar
    I'm using Windows 7. When I plug it in to any of the USB ports it shows up as the "Nexus 4" in My Computer, but when you click on it, you don't see any of the file structure. I basically can't transfer any files to it.

    It did work one time, but has not ever since. I have tried it in multiple USB ports on my computer.

    As an odd aside, I'm also having issues with wireless transfer with WINAMP. It initially recognized the device and was doing transfers, but now does not recognize it. Anyone have any thoughts? I have reconfirmed that both are operating on the same wireless network. Don't know why they are not connecting.
    As I answered in your other post, you need to unlock your phone in order to see the file structure once connected via USB. Makes complete sense, if you think about it...
    12-23-2012 07:34 AM
  14. Tim Usman's Avatar
    I'm experiencing following: whatever I connect my phone to computer I can hear the sound: connected device. After half second I hear the sound: device was disconnected. Phone being in charging state. But charging picture is blinking like if you constantly connect to adapter and disconnect it right after. I suspect new version of nexus 4. Therefore I want to try to downgrade back to 4.1 and I have no idea how to do it!
    the_man likes this.
    01-06-2013 06:39 PM
  15. myakawa's Avatar
    I have the same problem. I've tried to use 3 different cables and nothing changed. PC doesn't recognize the device, there's no any sound when I connect the phone to USB-ports. Did anyone solve the problem??
    the_man likes this.
    01-25-2013 08:36 AM
  16. N4Newbie's Avatar
    Your situation may be different.

    What is your computer's operating system? Windows? MacOS? Which version?
    01-25-2013 09:27 AM
  17. myakawa's Avatar
    Win7 Ult and Win7 Prof, tried to connect N4 to PC and laptop. The same situation in both ways.
    01-25-2013 09:45 AM
  18. myakawa's Avatar
    There's a new problem. Now it's not booting and red LED lights when I charge the phone. After 1 hour of charging N4 still doesn't boot at all.
    01-26-2013 02:14 AM
  19. N4Newbie's Avatar
    Someone posted a while ago that you can break out of this cycle by holding the power button in, connecting the charger, then letting go.

    Worth a try.
    01-26-2013 05:26 AM
  20. nikolaos's Avatar
    i have the nexus gt19250 by google and i canot sync it with my pc ... i am using kies program for samsung !! i called samsung and they told me that google nexus IS NOT WORKING with kies program for samsung cz google never asked for it ... does anyone knows another software for windows7 to sync my phone ??
    01-28-2013 06:01 AM
  21. myakawa's Avatar
    It's dead. Got it to LG repair service, there is a problem with a charger scheme. The scheme burned... They said it can be repaired, but I have to wait till they buy the scheme Wait about 1 month... Problem with PC connection is the same as they said.
    I charged N4 twice before, not from original charger, but from charger that worked and works fine with all of my other devices.
    They took a photo, but I don't understand where is the problem on it. Attached it.
    Attached Thumbnails Anyone else experiencing flaky/unreliable USB connection to PC on their Nexus 4?-358794048543108.jpg  
    01-28-2013 10:55 PM
  22. pcdavid52a's Avatar
    So are there any clear signs if this so-called "charger scheme" is burned out? Currently my Nexus is unable to be recognized by the XP machines at work and Win7 Machine at home. I cannot charge it via USB connection to either PC even though it shows the battery charging icon on the phone. I also cannot manually install drivers for Nexus 4 because windows deem the drivers incompatible with the device connected (it doesn't even recognize it as a phone?).
    01-30-2013 11:35 AM
  23. Barry White's Avatar
    Mine was doing the same. I uninstalled the ADB driver from device manager and all seems ok now.

    Baz
    02-15-2013 09:40 AM
  24. omgzam's Avatar
    Since the update to 4.2.2, I noticed that my Windows 8 Pro doesn't detect my phone under My Computer. On the phone itself, it is charging through the USB but it's not detected as a device that's plugged into my PC. I've went through 3 different cables and tested on both front and back USB ports of my PC but the problem still persists.
    the_man likes this.
    02-15-2013 10:19 AM
  25. hsj7638's Avatar
    Try this!!

    To change your phone's USB connection options, touch Settings > Device > Storage > Menu > USB computer connection.
    viwack likes this.
    02-15-2013 12:08 PM
45 12

Similar Threads

  1. Unable to connect to Wifi on new Nexus 7 tablet
    By easbury6 in forum Google Nexus 7 Tablet (2012)
    Replies: 9
    Last Post: 08-08-2013, 07:57 AM
  2. Anyone else having problems getting video files to play on TF-101
    By taalibeen in forum ASUS EeePad Transformer
    Replies: 6
    Last Post: 11-26-2011, 05:53 AM
  3. Evo to PC (Connect to PC via USB) problem fix
    By Jerzyiroc in forum HTC EVO 4G
    Replies: 1
    Last Post: 07-16-2010, 08:56 PM
  4. USB connected to a corporate PC
    By intrloper in forum Motorola Droid
    Replies: 4
    Last Post: 05-11-2010, 01:23 AM
  5. Anyone else experiencing random reboots lately?
    By CavemanOOGA in forum Motorola Droid
    Replies: 13
    Last Post: 02-18-2010, 08:26 PM
LINK TO POST COPIED TO CLIPBOARD