1. hawgs911's Avatar
    Hello All,

    I recieved my ST Sim about a week ago and have been using the service ever since. The biggest issues I seem yo have is not being able to send or recieve MMS texts. I just says"sending" forever and never sends.

    I was on the phone for about an hour with ST support today and they tried everything on their end and mine they could think of and nothing seems to fix it.

    Also, Next to my signal bars there is a letter 'H." That usually always there. The ST Tech is certain that it should be saying 3G (not sure)

    I am starting to wonder if it may be a problem with my particular unit and and thinking about asking fro a replacement. Has anyone else had this issue?

    Any advice?
    12-27-2012 07:49 PM
  2. saeufer's Avatar
    Hello All,

    I recieved my ST Sim about a week ago and have been using the service ever since. The biggest issues I seem yo have is not being able to send or recieve MMS texts. I just says"sending" forever and never sends.

    I was on the phone for about an hour with ST support today and they tried everything on their end and mine they could think of and nothing seems to fix it.

    Also, Next to my signal bars there is a letter 'H." That usually always there. The ST Tech is certain that it should be saying 3G (not sure)

    I am starting to wonder if it may be a problem with my particular unit and and thinking about asking fro a replacement. Has anyone else had this issue?

    Any advice?
    The ST tech support person is wrong. It should definitely say H (which stands for HSPA), not 3G. If you can't send MMS with the built-in messaging app, most likely your APN settings are wrong. Check around on here or on ST's website for the correct APN settings, which are different depending on whether you're on AT&T or T-Mobile's network.

    If your web access works, there's nothing wrong with your phone.
    andr0idralphie likes this.
    12-27-2012 09:03 PM
  3. andr0idralphie's Avatar
    I was just reading the No DATA with Straight Talk thread. After reading some of the info there I suggest it may be a roaming data connection Straight Talk problem. I'm really not sure if you'd still see the HSPA connection's H while roaming, though.
    12-28-2012 03:54 AM
  4. hawgs911's Avatar
    So after spending couple hours trying different APNs. Ones I found on this site, ones the ST tech gave me, and others I googled. I finally found a set up that works for me. Hope it helps

    APN: att.mvno
    Proxy : wireless.cingular.com
    Port: 80
    MMSC: http://mmsc.cingular.com
    MMS Port: 80
    MCC: 310
    MMC: 410
    APN Type: default,supl,mms
    APN Protocol: IPv4
    APN Roaming: IPv4
    Ace Deuce, Byzantium and Kim Nall like this.
    12-28-2012 02:08 PM
  5. Ace Deuce's Avatar
    So after spending couple hours trying different APNs. Ones I found on this site, ones the ST tech gave me, and others I googled. I finally found a set up that works for me. Hope it helps

    APN: att.mvno
    Proxy : wireless.cingular.com
    Port: 80
    MMSC: http://mmsc.cingular.com
    MMS Port: 80
    MCC: 310
    MMC: 410
    APN Type: default,supl,mms
    APN Protocol: IPv4
    APN Roaming: IPv4

    I have tried so many different APN's, and this is the first one to work for me since I got my phone (about a month ago). I have mine setup with the two APN's, one for regular data and one for MMS. I added your info to the one for MMS, and now everything works perfectly.
    Thanks
    12-29-2012 12:59 PM
  6. Cory Tobin's Avatar
    I had the same problem on the Nexus 4. Here are my APN settings that work

    Name:
    straight talk
    APN:
    att.mvno
    Proxy:
    proxy.mvno.tracfone.com
    Port:
    80
    Username:
    not set
    Password:
    not set
    Server:
    not set
    MMSC:
    http://mmsc.cingular.com
    MMS Proxy:
    66.209.11.33
    MMS Port:
    80
    MCC:
    310
    MNC:
    410
    Authentication Type:
    PAP
    APN Type:
    default,supl,mms
    APN: protocol:
    IPv4
    APN Roaming Protocol:
    IPv4
    Bearer:
    unspecified
    rozbojnik likes this.
    12-30-2012 08:47 PM
  7. TraceguyRune's Avatar
    I am sorry for bumping this thread, but I would like to point out that after rooting my nexus 4 I lost the APN settings and spend a couple hours tonight messing around with different APN settings.

    The settings that @Cory Tobin has posted have worked 100%
    10-21-2013 10:33 PM
  8. Dan Hunt2's Avatar
    Hello All,

    I recieved my ST Sim about a week ago and have been using the service ever since. The biggest issues I seem yo have is not being able to send or recieve MMS texts. I just says"sending" forever and never sends.

    I was on the phone for about an hour with ST support today and they tried everything on their end and mine they could think of and nothing seems to fix it.

    Also, Next to my signal bars there is a letter 'H." That usually always there. The ST Tech is certain that it should be saying 3G (not sure)

    I am starting to wonder if it may be a problem with my particular unit and and thinking about asking fro a replacement. Has anyone else had this issue?

    Any advice?
    Try typing *#*#4636#*#* on your phone key pad. That will bring up a testing screen. Go to SIM Phone information. Scroll down to SMSC , If it doesn't say +13123149810, put it in there and hit update. That is the message centre number for straight talk at&t. I tried all the different apn setting, and this worked for messaging , MMS AND SMS. My internet is working with regular apn setting. Hope this helps.
    10-28-2013 08:57 PM

Similar Threads

  1. No mobile data on Straight Talk (T-Mobile) with Nexus 4
    By shawnjacobs in forum Google Nexus 4
    Replies: 30
    Last Post: 05-20-2016, 06:34 PM
  2. Mms on straight talk help
    By ecsurf321 in forum AT&T Thrill 4G
    Replies: 1
    Last Post: 05-05-2014, 01:56 AM
  3. Mms on straight talk help!
    By kcdee00 in forum Google / Samsung Galaxy Nexus
    Replies: 30
    Last Post: 01-10-2013, 07:58 AM
  4. HTC Google Nexus One no data or MMS on Straight talk
    By Cami Talboy in forum Google / HTC Nexus One
    Replies: 0
    Last Post: 11-16-2012, 06:59 PM
  5. Evo 4g on Straight Talk?
    By dougeetx in forum HTC EVO 4G
    Replies: 3
    Last Post: 12-28-2010, 05:13 AM
LINK TO POST COPIED TO CLIPBOARD