Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 23 of 23
Like Tree5Likes
  • 2 Post By Rizy7
  • 2 Post By Kamin
  • 1 Post By sandandstars
  1. Thread Author  Thread Author    #1  
    Rizy7's Avatar

    Posts
    643 Posts
    ROM
    LiquidSmooth

    Default Contact Birthdays Not Showing In Calendar

    Does anyone know how I can get my contacts birthdays to show in my calendar?
    When I go into calendar and click on calendars to be displayed, the contacts birthdays calendar is checked but does not appear in my calendar.
    The only way I am able to show the contacts birthdays is if I go to calendar and calendar storage in apps and clear the data
  2. #2  

    Default Re: Contact Birthdays Not Showing In Calendar

    I would love to know how to fix this as well.
  3. #3  

    Default Re: Contact Birthdays Not Showing In Calendar

    Quote Originally Posted by teletraan1 View Post
    I would love to know how to fix this as well.
    Open Calendar and tap menu -> Calendars to display. At the bottom of the screen, tap "Calendars to sync" button. For each calendar (if you have more than one), check the box next to "Contact's birthdays and events".

    Works for me.
    Thanked by 3:
  4. #4  

    Default Re: Contact Birthdays Not Showing In Calendar

    Quote Originally Posted by N4Newbie View Post
    Open Calendar and tap menu -> Calendars to display. At the bottom of the screen, tap "Calendars to sync" button. For each calendar (if you have more than one), check the box next to "Contact's birthdays and events".

    Works for me.
    Awesome! Couldn't find this earlier. Much appreciated!
  5. #5  
    multo's Avatar

    Posts
    89 Posts
    Global Posts
    936 Global Posts

    Default Re: Contact Birthdays Not Showing In Calendar

    Never knew this until now. Thanks as well

    Sent from my Nexus 4 using Tapatalk 2
    LG Nexus 4 E960 Occam 44.2.2 JDQ39 / Nokia Lumia 920 / Samsung Galaxy Nexus I9250 Takju 4.2.2 JDQ39 / Asus Google Nexus 7 4.2.2 JDQ39
  6. Thread Author  Thread Author    #6  
    Rizy7's Avatar

    Posts
    643 Posts
    ROM
    LiquidSmooth

    Default Re: Contact Birthdays Not Showing In Calendar

    I still cant get mine to automatically update.. Even after syncing
  7. #7  

    Default Re: Contact Birthdays Not Showing In Calendar

    I don't know what else to offer. My guess is that your People list (where, presumably, you have stored the birthdays) is not linked to the same account as your Calendar.
    Thanked by:
    Rizy7 
  8. #8  

    Default Re: Contact Birthdays Not Showing In Calendar

    Have you tried verifying all the info from your calendar and contacts from a PC? I always had issues setting it up from phone, but once i jumped on my computer and setup everything, it started syncing automatically.
    Thanked by:
    Rizy7 
  9. Thread Author  Thread Author    #9  
    Rizy7's Avatar

    Posts
    643 Posts
    ROM
    LiquidSmooth

    Default Re: Contact Birthdays Not Showing In Calendar

    Quote Originally Posted by Seabass7857 View Post
    Have you tried verifying all the info from your calendar and contacts from a PC? I always had issues setting it up from phone, but once i jumped on my computer and setup everything, it started syncing automatically.
    Yep.. Everything is synced and fine when I check it on the computer. Just refuses to update on my actual calendar.. Unless my calendar app is interfering somehow?
  10. #10  

    Default Re: Contact Birthdays Not Showing In Calendar

    Hi, I have the same issue.

    Tried every approach above (sync in phone, set up in computer Google account) still my calendar in phone not sync the birthday. Pulling my hair at the moment...

    (LG Nexus 4)
  11. Thread Author  Thread Author    #11  
    Rizy7's Avatar

    Posts
    643 Posts
    ROM
    LiquidSmooth

    Default Re: Contact Birthdays Not Showing In Calendar

    Make sure both contacts and calendar are synced when you go into settings, accounts and Google Account.

    Then go to settings, all apps, find calendar and calendar storage. Clear the data on both and then everything should be working fine.
    Thanked by 2:
    JZ002 and Chris Birkett like this.
  12. #12  

    Default Re: Contact Birthdays Not Showing In Calendar

    None of the above worked for me. But the following is what did.

    1) On a PC, login to the Google calendar account you have synced on your device.
    2) Settings> Calendars> Browse interesting calendars> More
    3) Click "Subscribe" to Contacts' birthdays and events
    4) On your device, open Calendar app
    5) Menu> Calendars to display> Calendars to sync> Contacts' birthdays and events.

    ^^ That's the process that worked for me.
    Thanked by 7:
    neocarla and Garconis like this.
  13. #13  

    Default Re: Contact Birthdays Not Showing In Calendar

    And it worked for me, thanks ! I learned how to use my google account calendar !

    But we can improve the tuto for those who wants events facebook but not birthday !!!

    1) On a PC, login to the Google calendar account you have synced on your device.
    2) Settings> Calendars> Browse interesting calendars> More
    3) Click "Subscribe" to Contacts' birthdays and events Click on Add by URL
    4) Go on facebook
    1 > In Facebook, go to your EVENTS page.
    2 >At the top of that page click EXPORT EVENTS
    3 > You'll get a pop up window with a URL, copy it. (example : 'webcal://www.facebook.com/ical/u.php?...')
    5) Go back to google calendar and put the URL
    6) Synchronise your phone with Google (settings in your phone)
    6) On your device, open Calendar app
    5) Settings > Calendars > Tick Facebook Event in Google Account

    Done !!! You don't anymore facebook birthday !!
    Thanked by 2:
    Kaminquarkes 
  14. #14  

    Default Re: Contact Birthdays Not Showing In Calendar

    Ok, I had the same problems.

    Already tried everything mentioned above, but nothing helped.
    In the end I simply "removed" the google calendar from my phone, then re-installed it, applied updates, and magically the birthday appeared
  15. #15  

    Default Re: Contact Birthdays Not Showing In Calendar

    I installed aCalendar. It works nicley and shows birthdays ok.
    Kaliaila likes this.
  16. #16  

    Default Re: Contact Birthdays Not Showing In Calendar

    This was happening to me also, I looked in what calendars were visible and I had "My Calendar" unchecked. Once I checked this box all of my "Contact" birthdays showed up.

    So unless all of the birthdays are stored in your Google calendar and synced to your phone's calendar you will have to have "My Calendar" sync to get these to show.

    "Contacts' birthdays" at the bottom of the menu was greyed out until I checked the box next to "My Calendar", then it was available to put a check in the box.

    Hope this helps.
  17. #17  

    Default Re: Contact Birthdays Not Showing In Calendar

    My problem with the calendar is that it does not show my contact's birthdays, but the anniversary I also added to my contact. How to can I fix this?
  18. #18  

    Default Re: Contact Birthdays Not Showing In Calendar

    In Google Calendar on PC go to Settings > Sync to mobile device then follow the steps
  19. #19  

    Default Re: Contact Birthdays Not Showing In Calendar

    If u tried many ways but all dont solve the problem, please try this...
    - The fastest way is sign in to your Google Acc => Gmail => Contacts
    - In each Group, select all contacts and choose to add them to "My contacts" by checking on Group tab
    - Now, pick up ur phone n go to System settings\Accounts\Google, uncheck n recheck People details, Contacts n Calendar to re-sync them
    - Go to Calendar app n choose Calendars to sync n Calendars to display
    That's all! U can see ur contacts's birthday showed? ^^
  20. #20  

    Default Re: Contact Birthdays Not Showing In Calendar

    ok guys, after doing a LOT of search and research and after following ALL your indications and instructions, I performed this:
    I tried to search manually for a contact that I knew I had imported his birthday on (in my calendar - menu button --> search IN the calendar not in contacts)
    the entry was there, it was just there TWICE!
    I realized I had duplicate conflicting entries!
    I decided to delete the contact entirely and recreate it to see what happens
    before recreating the contact I searched again in my calendar with the name of the contact and the birthday was still there
    re-creating the contact did NOT resolve my problem.
    I figured out that it might either be the Google Calendar Sync Cache or the actual calendar cache (S Planner for Samsung)
    Unfortunately, I didn't find a way deleting the cache of the Google Calendar Sync and I'm still trying to find a way and a solution.
    I know for fact that removing google account and re-inserting it, will solve this (already tried it) BUT
    ALL images I have on contacts will be lost! (at least the actual resolution and size)
    ALL connected apps I have with my google account will be lost
    My 2-step verification account will create me too many problems
    not to mention all other problems I will be facing during the re-insertion of my account.
    I will continue again tonight trying to figure out what exactly is going on but my first impression is the wrong insertion of the contacts in my google account when first imported from my very old device (even if this is very remote). I'll keep you posted of my findings
    Last edited by Taz Man; 12-06-2013 at 12:10 AM.
  21. #21  

    Default Re: Contact Birthdays Not Showing In Calendar

    ok guys, finally found out what was wrong!
    First I want to make sure we are all on the same page here:
    1. When inserting a birthday on a contact, you can see the entry in Google Calendar (https://www.google.com/calendar/render) but you cannot see the entry on S Planner!
    2. The entry exists on contact level both in the contacts of the device and in the contacts of GMail Contacts
    IF this is the case then the solution to the problem is the following:
    Go to System Settings --> Application Manager -->ALL
    Find Application "Calendar Storage"
    Open it and Clear Data
    Open S-Planner and Re-sync your Calendar (Menu --> Sync)
    All birthdays should appear correctly now

    I realized that the calendar either gets a max value and does not update or there must be a kind of bug in there cause, the entry is there (since opening Google Calendar online you can see the entry) and after deleting and re-creating the contact does not fix the problem.

    Please post back results
  22. #22  
    Kaliaila's Avatar

    Posts
    7 Posts
    Global Posts
    11 Global Posts

    Default Re: Contact Birthdays Not Showing In Calendar

    The issue with most of this is that almost all of the solutions people have given all require that you have your contacts saved to Google, if you do not then it doesn't work.
    The aCalendar app does use the phone contacts instead of the google ones.
    Last edited by Kaliaila; 12-29-2013 at 06:42 PM.
  23. #23  

    Default Re: Contact Birthdays Not Showing In Calendar

    Thanks!

Similar Threads

  1. Contacts do not show in car bluetooth pairing
    By 8cats in forum Droid RAZR MAXX
    Replies: 53
    Last Post: 09-20-2014, 09:45 AM
  2. Birthdays Not Showing Up in Calendar
    By matt3166 in forum Sprint Galaxy S II Epic 4G Touch
    Replies: 3
    Last Post: 10-03-2012, 09:34 AM
  3. Birthdays not showing up in Calendar widget?
    By TerryMasters in forum Verizon Galaxy Nexus
    Replies: 6
    Last Post: 01-31-2012, 11:14 AM
  4. Replies: 4
    Last Post: 11-03-2010, 10:04 AM
  5. Replies: 1
    Last Post: 07-12-2010, 08:55 PM

Posting Permissions