1. itslikeimsayin's Avatar
    I'm not sure if this is a 4.3 problem, a universal issue or an isolated incident. For the last few days (I've only had my Nexus 4 a week or so), when I set an alarm through the clock app, it sets fine and the next screen displays the correct day and time. However, the digital clock widget on my home page won't update and is stuck on a previous time I had set the alarm for.

    For instance, last night I set my alarm for 4:45 am this morning. The home page widget continued to display "MON 5:45 AM" underneath the current time. As of right now, it still says that, although it should have switched to TUES because the Monday time has passed. The lock screen and alarm settings page both display the correct alarm time, but the home screen does not.

    Anyone else have this issue? Got a fix? Thanks.
    07-29-2013 01:41 PM
  2. Lili217's Avatar
    I have the same issue! I noticed it started happening after I updated to 4.3. The widget alarm time doesn't change and the alarm randomly works for me. Very frustrating.
    08-02-2013 04:30 AM
  3. Fairclough's Avatar
    Widgets often update on a time base e.g hourly so it doesn't drain your battery that could be the issue. If your worried it won't go off just draw down press the top right button and see if next alarm is the correct one.

    Posted via Android Central App
    08-02-2013 04:48 AM
  4. frenziedfemale's Avatar
    Try uninstalling the widget, rebooting the phone, then reinstalling the widget
    08-02-2013 05:02 AM
  5. Ron Peled's Avatar
    ...
    08-05-2013 04:01 PM
  6. Ron Peled's Avatar
    Hi Guys, I have the same issue since I got my nexus 4 - two month ago, so its not a new 4.3 issue.
    If I throw the digital clock to the trash can, and select it again from the widget menu it resolves the old alarm clock display, couldnt quite find out what causes it to enter this state though.
    08-05-2013 04:09 PM
  7. foxandog's Avatar
    Same issue here
    08-21-2013 08:49 AM
  8. Leart369's Avatar
    i have the same issue, it is really annoying..
    08-21-2013 11:56 AM
  9. cydu's Avatar
    Same issue... all my clocks are showing yesterday's date, the time is fine. It happened a short while after i updated to the second build of 4.3.
    Tried disabling, force stopping and cleared data and cache.
    Nothing goes
    08-28-2013 02:00 AM
  10. Karrott9's Avatar
    This started happening to me well before 4.3. So annoying.

    Posted via Android Central App
    08-29-2013 08:20 AM
  11. Karrott9's Avatar
    I'm now having the problem of the clock force closing when my alarm is to go off. Resulting in no alarm sounding at all...

    Posted via Android Central App
    08-29-2013 08:52 AM
  12. bahamut zero's Avatar
    I have the exact same issue on nexus 4 running 4.3. I hope google fixes it
    09-28-2013 02:42 AM
  13. Krolt's Avatar
    same here, deleting the widget then putting it back seems to work for me
    09-28-2013 03:37 AM
  14. itic's Avatar
    try using google voice to set alarms instead of the widget.
    09-28-2013 12:43 PM
  15. copypaiste's Avatar
    The same issue on Nexus 4, running 4.3. :\
    It helps to resize the widget, then the alarm time redraws.
    10-02-2013 05:04 PM

Similar Threads

  1. Nexus 7 (2013) NFC Not Working
    By c3ringer in forum Google Nexus 7 Tablet (2013)
    Replies: 8
    Last Post: 08-13-2013, 03:33 PM
  2. Is it me, or is the Nexus 4 just a HOT looking phone?
    By Not Quite Right in forum Google Nexus 4
    Replies: 16
    Last Post: 08-06-2013, 05:17 PM
  3. Bluetooth range & other potentially consistent issues
    By o2bnclemson in forum Samsung Galaxy S4
    Replies: 3
    Last Post: 08-04-2013, 12:18 PM
  4. Weird Hotspot issue
    By Danny2tek in forum Samsung Galaxy S4
    Replies: 1
    Last Post: 08-01-2013, 10:03 AM
  5. Storage Issues Post 4.3
    By EnigmaticPsychotic in forum Google Nexus 4
    Replies: 3
    Last Post: 07-31-2013, 03:29 PM
LINK TO POST COPIED TO CLIPBOARD