Results 1 to 18 of 18
  1. Thread Author  Thread Author    #1  
    damo's Avatar
    #teamandroid

    Posts
    174 Posts
    Global Posts
    177 Global Posts

    Default 4.3 WiFi issues

    Hi folks, since upgrading to 4.3 I'm having WiFi issues. If I leave the house then come back in I cannot connect to my WiFi. If I try and manually connect it says it can't.
    If I turn the phone off and back on, I've then got to manually switch on WiFi and then it will connect.
    The only other way to connect is to turn on mode then turn it off again and the phone will then connect to my WiFi.

    Anyone here have a solution to this?
    Thanks ☺

    Posted via Android Central App
  2. #2  

    Default Re: 4.3 WiFi issues

    You might try installing Wifi Fixer from the Play Store. It's for the 4.2 glitch, but may prove useful in your own circumstance. I've had one wifi hiccup at home that required a phone reboot. No problem since (and I have wifi fixer already installed).
  3. #3  

    Default Re: 4.3 WiFi issues

    I had serious Wi-Fi issues after the update myself. For me I considered the new Baseband/Radio because it was flawless before the update (but afterward it would choke and then data would choke through albeit displaying full Wi-Fi bars!), I searched and noticed an update available for my router. ...applied, restarted router, all buttery smooth again... actually noticeably smoother! The YouTube app barely buffers and Play flies open.
    WHITE 32GB NEXUS 5
  4. #4  

    Default Re: 4.3 WiFi issues

    Haha It's a new 4.3 issue? Is it not a Nexus 4 problem? My Torch 9800, Lumia 920, my brother's S4, S3, Galaxy Nexus auto connects to home Wi-Fi with no problem. My Nexus4 never once auto connect. I have to manually connect and wait at least a minute each time.

    Posted from my Nexus 4 via Android Central App
  5. #5  

    Default Re: 4.3 WiFi issues

    Quote Originally Posted by artlu629 View Post
    Haha It's a new 4.3 issue? Is it not a Nexus 4 problem? My Torch 9800, Lumia 920, my brother's S4, S3, Galaxy Nexus auto connects to home Wi-Fi with no problem. My Nexus4 never once auto connect. I have to manually connect and wait at least a minute each time.

    Posted from my Nexus 4 via Android Central App
    I would suggest you make sure you have the latest router firmware and you may wish to 'Forget' the Wi-Fi connection in your settings and add it again... my Nexus 4 begins to connect to my router from outside of my building--my router is in the middle of my apartment. ASUS RT-N66U
  6. #6  

    Default Re: 4.3 WiFi issues

    My N4 auto connects to my router when pull up outside on the street. It did this running 4.2.2 and is no different on 4.3.

    Sent from my Nexus 4 using Tapatalk 4 Beta
  7. #7  

    Default Re: 4.3 WiFi issues

    Quote Originally Posted by artlu629 View Post
    Haha It's a new 4.3 issue? Is it not a Nexus 4 problem? My Torch 9800, Lumia 920, my brother's S4, S3, Galaxy Nexus auto connects to home Wi-Fi with no problem. My Nexus4 never once auto connect. I have to manually connect and wait at least a minute each time.

    Posted from my Nexus 4 via Android Central App
    Excluding the Nexus 4, what do all those devices listed have in common with each other?

    They don't have Android 4.3. Logic would then indicate it's more likely a Android 4.3 issue, would it not?

    My N4 has never had an issue auto connecting to WiFi, regardless of the version of Android.
  8. #8  

    Default Re: 4.3 WiFi issues

    I was having that problem pre 4.3. No one ever come to my house complaining about Wi-Fi issues. I have two coworkers with nexus 4 who has the same issues as me. They all tell me it didn't happen to their other phones.

    Posted from my Nexus 4 via Android Central App
  9. #9  

    Default Re: 4.3 WiFi issues

    Quote Originally Posted by TheLibertarian View Post
    Excluding the Nexus 4, what do all those devices listed have in common with each other?

    They don't have Android 4.3. Logic would then indicate it's more likely a Android 4.3 issue, would it not?

    My N4 has never had an issue auto connecting to WiFi, regardless of the version of Android.
    Those phones has one thing in common. They can connect to my home Wi-Fi no issues. Some are pretty old phones too.

    Posted from my Nexus 4 via Android Central App
  10. #10  

    Default Re: 4.3 WiFi issues

    Quote Originally Posted by artlu629 View Post
    Those phones has one thing in common. They can connect to my home Wi-Fi no issues. Some are pretty old phones too.

    Posted from my Nexus 4 via Android Central App
    Yes, they all connect to your WiFi, and none of them have Android 4.3... except for the Nexus which, oddly enough, cannot connect to your WiFi.

    Hmm. Sounds like a 4.3 issue.
  11. #11  

    Default Re: 4.3 WiFi issues

    I have five different phones in my home and they all connect to my router without issues, including my Nexus, so it is possible. If it is not working for you, then something us wrong with your setup. I have a Netgear N router that is about a year and a half old that is configured to run at 5ghz. I have read some posts where some older routers are not compatible with the N4. I'm doubtful of that, but it is possible if it involves some security protocols. Bottom line, instead of wasting time whining, spend time doing some research and fix it. If you can't accomplish that, get an iPhone.

    Sent from my Nexus 4 using Tapatalk 4
  12. Thread Author  Thread Author    #12  
    damo's Avatar
    #teamandroid

    Posts
    174 Posts
    Global Posts
    177 Global Posts

    Default Re: 4.3 WiFi issues

    As I said before, mine worked fine for the last 8 months and as soon as I upgraded to 4.3 I'm having problems. So frustrating!

    Posted via Android Central App
  13. #13  

    Default Re: 4.3 WiFi issues

    Quote Originally Posted by damo View Post
    As I said before, mine worked fine for the last 8 months and as soon as I upgraded to 4.3 I'm having problems. So frustrating!
    Can you try rebooting your Nexus 4 into safe mode? Hold the power button down, then press and hold down the Power off option until you see a message about safe mode. Then press OK to go into safe mode.

    Safe mode will disable 3rd party apps. You can then test your wifi connection again. If it works, then you know one of your apps is causing a problem with your wifi. If it still doesn't, then something may be wrong with your Nexus 4.

    Also, is your bluetooth on when you connect to your wifi? If so, perhaps you should turn off bluetooth and try the wifi connection again.

    BTW, does your router use the 5 GHz band? If so, you may want to check out this post that may be related to your problem: Fix For Nexus 4 4.3 5ghz Wi-Fi issue
  14. #14  

    Default Re: 4.3 WiFi issues

    Quote Originally Posted by damo View Post
    As I said before, mine worked fine for the last 8 months and as soon as I upgraded to 4.3 I'm having problems. So frustrating!

    Posted via Android Central App
    When is the last time you upgraded the firmware for your router? Router manufacturers provide firmware upgrades for their routers for compatibility with newer devices and software. Also, consider doing a little manual configuration. It is hard for manufacturers to design auto configuration to work with every single device that might connect to it, especially when software/firmware for those devices gets upgraded. Others are reporting success with trying different channels. Give that a shot.

    Sent from my Nexus 4 using Tapatalk 4
  15. #15  

    Default Re: 4.3 WiFi issues

    I am having similar issues after upgrading to version 4.3 in my Samsung Galaxy S3. With 4.2.1, the WiFi priority worked well when moving from 3G/4G to a local known network. The WiFi indicator bars would light up indicating a connection to the local network. Also, my WiFi apps on the phone worked as well. Now, I have to put the phone in Airplane mode, then turn WiFi back on in order for the WiFi apps to work!
    As previous posts have said...VERY frustrating since I use those apps ALL THE TIME!!!! I setup home automation systems, networks, wired and wireless. This was not a problem until 4.3 was installed.
  16. #16  
    pb46's Avatar

    Posts
    4 Posts

    Default Re: 4.3 WiFi issues

    Easy answer ...Use 4.4.2 ??
  17. #17  

    Default Re: 4.3 WiFi issues

    GREAT!...where do I find/get that? AT&T will not be offering it for a while I assume as 4.3 was only recently available.
  18. #18  
    pb46's Avatar

    Posts
    4 Posts

    Default Re: 4.3 WiFi issues

    Do like all the rest in this forum (i.e. Nexus 4 Forum). We've had 4.4.2 for a few months already. Other than getting a nexus 5 ( nexus 4 is no longer available) I would suggest you go to the Galaxy S3 forum. They might have work-arounds for you. (root, flash etc.) Have you not tried there already?

    I don't understand why someone would come to a wrong "Branded Device" forum for help for another brand.

Similar Threads

  1. Android 4.3 Bluetooth Audio Issue
    By specter0710 in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 11
    Last Post: 01-16-2014, 01:13 PM
  2. Sim card issues...still?!
    By cmslota in forum Verizon Droid DNA
    Replies: 36
    Last Post: 09-04-2013, 02:35 PM
  3. Downloaded/saved photos issue.
    By m alexander in forum Samsung Galaxy S4 Google Edition
    Replies: 3
    Last Post: 08-07-2013, 05:35 PM
  4. Weather issue
    By BitchImFatJesus in forum HTC One
    Replies: 1
    Last Post: 08-01-2013, 05:02 PM
  5. Android Central app Forums issue
    By FitzAusTex in forum Google Nexus 7 Tablet (2013)
    Replies: 2
    Last Post: 08-01-2013, 10:59 AM

Posting Permissions

B