1. accesschristopher's Avatar
    OK , is it just me or does the YouTube app always stop on nexus 4. It really has always sucked on this phone even with my super high speed home WiFi.. Anyone else? what to do.. Gone through the app settings 1000 times.. Any suggestions ?
    08-08-2013 05:37 PM
  2. dragonsamus's Avatar
    Have you tried closing the app or rebooting your phone? I don't have any issues with it on my phone but the facebook app is awful. Never loads.

    Sent from my HTC One using AC Forums mobile app
    08-08-2013 05:55 PM
  3. CoMoNexus's Avatar
    I rarely use the YouTube app, but I frequently watch YouTube on my PCs, and the buffering problem has gotten out of hand over the past few months. My cable service is 25 Mbps down, with sub-30 ms latency, so it's not my connection. Plus a lot of other people with different broadband providers have reported the same problem. It could be related to peering. It could be that YT's servers are overloaded. But I don't think it's the app.
    08-08-2013 06:10 PM
  4. accesschristopher's Avatar
    I rarely use the YouTube app, but I frequently watch YouTube on my PCs, and the buffering problem has gotten out of hand over the past few months. My cable service is 25 Mbps down, with sub-30 ms latency, so it's not my connection. Plus a lot of other people with different broadband providers have reported the same problem. It could be related to peering. It could be that YT's servers are overloaded. But I don't think it's the app.
    My sis has the 4s no issues with YouTube.. Unreal
    08-08-2013 06:24 PM
  5. daryllh's Avatar
    OK , is it just me or does the YouTube app always stop on nexus 4. It really has always sucked on this phone even with my super high speed home WiFi.. Anyone else? what to do.. Gone through the app settings 1000 times.. Any suggestions ?
    Yes. I have experienced this. I thought it was because of my crack flashing the last week but I flashed back to CM nightly and it still buffers.

    Sent from my Nexus 4 using Tapatalk 2
    08-08-2013 09:27 PM
  6. bruceleer0y's Avatar
    OK , is it just me or does the YouTube app always stop on nexus 4. It really has always sucked on this phone even with my super high speed home WiFi.. Anyone else? what to do.. Gone through the app settings 1000 times.. Any suggestions ?
    I've experienced this issue with other phones as well. I think its the youtube app on wifi,because when i open up youtube in the browser it works just fine.
    08-08-2013 09:35 PM
  7. jc0187's Avatar
    Yup. I've got the same issue with YouTube. A 5 minute video over WiFi or data can sometimes take 10 minutes to watch.
    08-08-2013 10:45 PM
  8. yfan's Avatar
    Try changing your router or modem settings to allow the use of open DNS servers. Since I did that, the buffering problem has almost gone away.

    Posted via Android Central App
    08-08-2013 11:04 PM
  9. CoMoNexus's Avatar
    Try changing your router or modem settings to allow the use of open DNS servers.
    Are there any drawbacks to that?
    08-09-2013 08:03 AM
  10. Reciprocal's Avatar
    I've seen this issue on PC, phones, and tablets. It's a YouTube thing at this point. Not even the app, but the whole service.
    08-09-2013 08:06 AM
  11. wx27's Avatar
    Are there any drawbacks to that?
    In theory, the open DNS servers may direct you to youtube servers that are geographically farther from you than what your ISP's DNS servers would give you, but on the flip side perhaps those more distant servers will send data via network hops that aren't as congested, thus minimizing buffering issues.

    Higher initial latency, but more consistent throughput, is what I suspect using open DNS may provide in certain cases.

    Peering contracts are likely the cause of performance issues, much like NetFlix has with some ISPs.
    Video services such as NetFlix and Youtube send way more data in one direction than another and some ISPs don't care to upgrade their switches to handle the flood of data without getting paid.
    CoMoNexus and yfan like this.
    08-09-2013 09:19 AM
  12. jose3456's Avatar
    This started to happen to me recently before this started to happen it worked perfectly but I think its the app
    08-09-2013 10:52 AM
  13. yfan's Avatar
    In theory, the open DNS servers may direct you to youtube servers that are geographically farther from you than what your ISP's DNS servers would give you, but on the flip side perhaps those more distant servers will send data via network hops that aren't as congested, thus minimizing buffering issues.

    Higher initial latency, but more consistent throughput, is what I suspect using open DNS may provide in certain cases.
    That's exactly it. I get a little buffering in the beginning sometimes, but the playback is smooth after that.
    08-09-2013 08:16 PM
  14. MONDINGO's Avatar
    Go into apps under settings. Select YouTube. Scroll down to clear cache, and then force stop it. Do not clear data though. This has always helped me out a lot.

    Sent from my HTC One using AC Forums mobile app
    Ganesh Kumar Kumar likes this.
    08-09-2013 08:20 PM
  15. Billy Bob Jimmy Joe's Avatar
    I feel for you. YouTube app never allowed me to play a video without freezing. I just use the mobile site now but the quality is not so good.

    Posted from my Nexus 4 via Android Central App
    08-10-2013 12:01 AM
  16. Ganesh Kumar Kumar's Avatar
    Getting into settings and clearing off the Cache and stopping forcefully has solved my problem in Google Nexus 4.
    01-01-2014 05:51 PM
  17. Ganesh Kumar Kumar's Avatar
    Thanks, this worked for me.
    01-01-2014 05:52 PM
  18. jc0187's Avatar
    I switched to an S4 about six months ago. But before I switched, I had this issue with YouTube as well. Well, I rid myself, thank God, of the horrid S4 and am now back on my N4 and I have yet to experience the buffer issues I had six months previously. I am hoping that with 4.4 update, the issue was resolved. Only time will tell.
    01-04-2014 08:03 AM

Similar Threads

  1. Not Worth The Money.. Nexus 7 2013 out.. HiSense Sero 7 Pro Now Only $129.00 In..
    By RaiderWill in forum Google Nexus 7 Tablet (2013)
    Replies: 98
    Last Post: 10-29-2013, 09:17 PM
  2. Being The Newbie Is Never Cool
    By Wil Jennings in forum Introductions
    Replies: 7
    Last Post: 08-17-2013, 11:33 AM
  3. Get the Moto X features on your Nexus 4
    By TechZOnline in forum Google Nexus 4
    Replies: 43
    Last Post: 08-16-2013, 01:47 PM
  4. Where's the A1000 update gone?
    By rsp8 in forum Lenovo Android Tablet Discussion
    Replies: 2
    Last Post: 08-15-2013, 08:56 AM
  5. S4 screen doesn't immediately come on for incoming call
    By Bamagrl2010 in forum AT&T Samsung Galaxy S4
    Replies: 2
    Last Post: 08-13-2013, 04:22 PM
LINK TO POST COPIED TO CLIPBOARD