01-22-2017 04:08 AM
51 123
tools
  1. Niloofar6's Avatar
    I can't connect my Nexus 4 to my laptop as a media device anymore! But I still can connect it as camera device.It happened after changing windows.The device driver was installed for the camera mode when connected for the first time,but not for media device mode! It just says "connected as media device" but I can't see anything in my computer! Do I need to install drivers manually? How?
    09-30-2013 11:49 AM
  2. N4Newbie's Avatar
    Did you recently change the security settings on the phone? You are aware, that if your phone has a PIN lock, for example, you will not be able to browse the phone from Windows Explorer until you enter the PIN code, correct?

    [edit]

    We are talking Windows, yes? What version?
    Niloofar6 likes this.
    09-30-2013 11:57 AM
  3. Niloofar6's Avatar
    Did you recently change the security settings on the phone? You are aware, that if your phone has a PIN lock, for example, you will not be able to browse the phone from Windows Explorer until you enter the PIN code, correct?

    [edit]

    We are talking Windows, yes? What version?
    Windows 7 64 bit.Like it used to be. And no,I haven't changed security settings on my phone.No PIN! And I can connect it as camera device without any problem! Just doesn't connect as media device;which means I only have access to my images!
    djroop likes this.
    09-30-2013 12:03 PM
  4. badbrad17's Avatar
    Windows 7 64 bit.Like it used to be. And no,I haven't changed security settings on my phone.No PIN! And I can connect it as camera device without any problem! Just doesn't connect as media device;which means I only have access to my images!
    You should be able to get the same results with camera mode do you not? I had a similar issue when I upgraded to 4.3 but never had a issue connecting it via camera mode.

    You can also consider using the AirDroid app which connects to your device via your browser wirelessly. Quite handy.
    Niloofar6 likes this.
    09-30-2013 08:38 PM
  5. Niloofar6's Avatar
    You should be able to get the same results with camera mode do you not? I had a similar issue when I upgraded to 4.3 but never had a issue connecting it via camera mode.

    You can also consider using the AirDroid app which connects to your device via your browser wirelessly. Quite handy.
    I can only see my images in camera mode.Yes I've been using AirDroid but It takes time (just a little bit maybe) and is not always available.I really need USB connection!

    Sent from my Nexus 4 using AC Forums mobile app
    09-30-2013 09:00 PM
  6. Niloofar6's Avatar
    Don't yo think I should install drivers?! Is there a website I can find it? Seems like 4.3 problem then.

    Sent from my Nexus 4 using AC Forums mobile app
    09-30-2013 09:14 PM
  7. badbrad17's Avatar
    You shouldn't need to. They should install when you plug it in. Have you tried a different computer?

    Sent from my Nexus 4 using AC Forums mobile app
    10-03-2013 01:47 AM
  8. Jerry Hildenbrand's Avatar
    Common Windows 7 issue that has nothing to do with Android (this time)

    Plug your phone in.
    Find it in the device manager (look for the yellow triangle)
    Right click, and choose "Update Driver Software ..."
    Choose "Browse my computer for driver software"
    Choose "Let me pick from a list of device drivers on my computer"
    Scroll down and pick "portable devices", click Next
    Choose Standard MTP Device > MTP USB Device
    When it warns you that things may go tits up, click yes anyway.
    10-03-2013 02:44 AM
  9. badbrad17's Avatar
    Don't yo think I should install drivers?! Is there a website I can find it? Seems like 4.3 problem then.

    Sent from my Nexus 4 using AC Forums mobile app
    I found that if I have usb debugging off it won't work. I switched that on in my settings and it works.

    Sent from my Nexus 4 using AC Forums mobile app
    Niloofar6 likes this.
    10-03-2013 01:12 PM
  10. Niloofar6's Avatar
    You shouldn't need to. They should install when you plug it in. Have you tried a different computer?

    Sent from my Nexus 4 using AC Forums mobile app
    That's the problem. It's not installed automatically

    Sent from my Nexus 4 using AC Forums mobile app
    badbrad17 likes this.
    10-03-2013 11:47 PM
  11. Niloofar6's Avatar
    Common Windows 7 issue that has nothing to do with Android (this time)

    Plug your phone in.
    Find it in the device manager (look for the yellow triangle)
    Right click, and choose "Update Driver Software ..."
    Choose "Browse my computer for driver software"
    Choose "Let me pick from a list of device drivers on my computer"
    Scroll down and pick "portable devices", click Next
    Choose Standard MTP Device > MTP USB Device
    When it warns you that things may go tits up, click yes anyway.
    Done! It's fixed now! Thank you

    Sent from my Nexus 4 using AC Forums mobile app
    10-03-2013 11:48 PM
  12. Scapponess's Avatar
    FINALLY someone who had the answer to this! Thank you so much ^_^!
    11-14-2013 07:41 AM
  13. sorydolimi's Avatar
    Thank you so much!!
    12-01-2013 07:24 PM
  14. Sendil R's Avatar
    Settings → Storage → ⋮ → USB-connection to computer → MTP media device
    12-11-2013 10:10 PM
  15. Suneel Perumalla's Avatar
    Thanks boss i am almost saved.. I have been searching for this simple thing since 4 hours
    01-01-2014 06:51 AM
  16. Edukator99's Avatar
    Stupid question here. I have windows 8 so maybe this is the problem but...

    Plug phone into what? The computer?

    And where are you finding device manager? On the computer or on the phone? I have it on neither that I can see.
    01-04-2014 08:08 PM
  17. badbrad17's Avatar
    Stupid question here. I have windows 8 so maybe this is the problem but...

    Plug phone into what? The computer?

    And where are you finding device manager? On the computer or on the phone? I have it on neither that I can see.
    It's not Windows 8.

    Plug it into your computer via USB.

    Device manager is in your control panel on your computer.

    Sent from my Nexus 4 using AC Forums mobile app
    01-10-2014 09:25 AM
  18. master1147's Avatar
    @Sendil R
    Thank you very much.i've been looking for this for weeks.thanks for the advice.
    01-10-2014 12:44 PM
  19. Pop Sebi's Avatar
    I did the same think but it replyes: "This device can not start.(Code 10)"
    01-19-2014 08:54 AM
  20. Taxisi's Avatar
    The same thing happened to me, just follow instructions from Sendil R

    On your device, go to:
    Settings → Storage → ⋮ → USB-connection to computer → MTP media device

    Don't miss the step to click the 3 dots in top right corner. Unplug and replug device.
    SpirrowRose likes this.
    01-22-2014 03:59 AM
  21. waldolc's Avatar
    Click image for larger version. 

Name:	USB Comp Conn.png 
Views:	17 
Size:	96.8 KB 
ID:	102476

    It's hidden in the STORAGE Menu
    01-28-2014 01:10 PM
  22. poonam21's Avatar
    Hi, I have the same problem and followed your instructions. At the final step, Windows tells me:

    'Windows foundd river software for your device but encountered an error while attempting to install it.'

    Any suggestions on what to do next?

    - - - Updated - - -

    Done! It's fixed now! Thank you

    Sent from my Nexus 4 using AC Forums mobile app
    05-28-2014 05:27 AM
  23. poonam21's Avatar
    Common Windows 7 issue that has nothing to do with Android (this time)

    Plug your phone in.
    Find it in the device manager (look for the yellow triangle)
    Right click, and choose "Update Driver Software ..."
    Choose "Browse my computer for driver software"
    Choose "Let me pick from a list of device drivers on my computer"
    Scroll down and pick "portable devices", click Next
    Choose Standard MTP Device > MTP USB Device
    When it warns you that things may go tits up, click yes anyway.

    Hi, I have the same problem and followed your instructions. At the final step, Windows tells me:

    'Windows found driver software for your device but encountered an error while attempting to install it.'

    Any suggestions on what to do next?
    porcupinedroppings likes this.
    05-28-2014 05:32 AM
  24. porcupinedroppings's Avatar
    I'be been struggling with the same problem for weeks. Thank you so much for posting the solution!!!
    06-18-2014 09:24 AM
  25. kaboomberg's Avatar
    +1 big thanks for the sharing. fixed my issue after 5 hours of attempts. You rock!
    07-29-2014 03:05 AM
51 123

Similar Threads

  1. Battery Slow to Charge and Quick to Lose Power
    By scottgoodhill in forum Samsung Galaxy S4
    Replies: 5
    Last Post: 10-31-2014, 11:56 AM
  2. Save Google Maps offline for travel?
    By jolphil in forum Google Nexus 7 Tablet (2013)
    Replies: 10
    Last Post: 10-13-2013, 04:10 PM
  3. Any way to stop these apps
    By Ductman1 in forum Moto X (2013)
    Replies: 3
    Last Post: 09-30-2013, 06:25 PM
  4. WiFi connection
    By Pam Fowler in forum General Help and How To
    Replies: 2
    Last Post: 09-30-2013, 11:17 AM
  5. EMail to text
    By Artis HInson in forum Droid RAZR M
    Replies: 1
    Last Post: 09-30-2013, 09:36 AM
LINK TO POST COPIED TO CLIPBOARD