Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 9 of 9
Like Tree1Likes
  • 1 Post By Explicit
  1. Thread Author  Thread Author    #1  
    Explicit's Avatar

    Posts
    275 Posts
    Global Posts
    305 Global Posts
    ROM
    AOKP KK | FrancoKernel

    Default [SOLVED] Nexus 4 4.4 Update Stuck on Boot Animation

    This is my fiancee's moms phone and USB debugging is not enabled. She was promoted the update and this is the end result. I've tried reflashing the image files through adb with no end result. I've tried wugs toolkit which is useless because USB debugging is not enabled. I'm at wits end with this phone. Any ideas on what I can do? Also when in recover mode the language is not in english. Did Google botch the update that was sent to her phone?

    The Android recovery system <3e> is KRT16S
  2. Thread Author  Thread Author    #2  
    Explicit's Avatar

    Posts
    275 Posts
    Global Posts
    305 Global Posts
    ROM
    AOKP KK | FrancoKernel

    Default Re: Nexus 4 4.4 Update Stuck on Boot Animation

    I followed this

    I was in the same situation and ran into that issue as well. What I did was download the 4.3 factory image from here: https://developers.google.com/androi...s/images?hl=vi

    Make sure you get the correct one for your device. I have a 2013 wifi so I chose: Android 4.3 (JSS15R)

    Inside that downloaded file, you'll find image-razor-jss15r.zip. It's a couple of levels down. Unzip the files from there to your SDK folder (should be boot.img, recovery.img, system.img, userdata.img, and cache.img).

    Boot your Nexus 7 to the bootloader (volume down + power) and connect to your PC with USB cable. Do NOT go into Recovery mode yet.

    From the command prompt, make sure you can see your device: fastboot devices

    Then, run the following commands:

    fastboot flash boot boot.img
    fastboot flash recovery recovery.img
    fastboot erase system
    fastboot flash system system.img

    At this point you have a clean install of 4.3 JSS15R.

    Now go to Recovery mode and sideload the 4.4 OTA as you originally tried and it should work this time.

    I followed these steps and was able to update to 4.4 without losing any data. YMMV
    It took away the random foreign language stating "No Command", but I'm still stuck in the boot animation. I really thought it was going to work and while I feel I took a step forward, it is no where that i'd like to be at. Any ideas on what I can do next?
  3. #3  

    Default Re: Nexus 4 4.4 Update Stuck on Boot Animation

    I assume your mom phone bootloader was unlocked before you did the steps you mentioned to save her datas.

    There is some changes in your /data partition that cause it. I fixed it by factory reseting. However, if you reset using stock recovery it will wipe the entire /data partition, which means not only your apps data, but also everything in your internal storage.

    Factory reseting with a custom recovery will wipe the /data partition, but not /data/media, leaving internal storage alone.

    You don't have to install custom recovery, but just boot into it one time using: fastboot boot recovery.img

    You can get TWRP recovery for N4 here: Techerrata Downloads - Browsing mako

    Boot into it and create a backup image of your device Then you can do a factory reset, the phone should boot then. You'll just have to accept to lose your apps data.

    You could backup your apps data using the command: adb pull /data/data C:\backup\appsdata.

    But it's not going to be too useful because it could be a pain to restore since you have to fix the file permissions for the files after restoring them.
  4. Thread Author  Thread Author    #4  
    Explicit's Avatar

    Posts
    275 Posts
    Global Posts
    305 Global Posts
    ROM
    AOKP KK | FrancoKernel

    Default Re: Nexus 4 4.4 Update Stuck on Boot Animation

    Followed this and it finally worked. What a 4 hour ordeal smh

    Quote Originally Posted by DaVoodoo View Post
    I also managed to fix my Nexus 7 2012 Wifi using Wug's Nexus Toolkit. ( I assume this toolkit will work with Nexus 4,7 and 10 as it is a unified toolkit.) NB: As you will flash stock you will loose all your apps and settings. At least it is better than being stuck with the "No Command" screen.

    1. Download and install Nexus Root Toolkit v1.7.8: Nexus Root Toolkit v1.7.8 | WugFresh
    2.. Connect to PC and Boot in Fastboot Mode: VOL DOWN + POWER ON
    3. In the toolkit, under "Back to stock" tick "Soft-Bricked/Bootloop"
    4. Click "Flash Stock + Unroot"
    5. When done you will have a working Nexus again. I thought I was going back to stock and would have to install 4.4. But ended up with 4.4. .

    I hope this helps someone else.
    Nexus 7 (2012) stuck in "no command" bootloop
    Thanked by 2:
    kennethz3 likes this.
  5. #5  

    Default Re: Nexus 4 4.4 Update Stuck on Boot Animation

    If you had followed my advice you wouldn't have to lose all your datas.
  6. Thread Author  Thread Author    #6  
    Explicit's Avatar

    Posts
    275 Posts
    Global Posts
    305 Global Posts
    ROM
    AOKP KK | FrancoKernel

    Default Re: Nexus 4 4.4 Update Stuck on Boot Animation

    Quote Originally Posted by someguy01234 View Post
    If you had followed my advice you wouldn't have to lose all your datas.
    Actually the bootloader wasn't unlocked. It was as stock as stock can be. I attempted to save anything on the phone, but I couldn't even get the phone to be recognized as a MTP device. Seemed like the OTA was screwed up and essentially wiped her phone when the phone first failed. Without USB debugging enabled, it seemed like losing everything was bound to happen. Sucks, but at this point the fact that I got the phone back into working state is good for me. I have made sure the USB Debugging is now enabled incase this starts to go to hell again. I know my fiancee's mom has lost all trust in Google products. Nothing I can do about that sadly.
  7. #7  
    O12
    O12 is offline
    O12's Avatar

    Posts
    1 Posts

    Default Re: Nexus 4 4.4 Update Stuck on Boot Animation

    Explicit: I just want to say thank you because this method worked perfectly on my girlfriend's Nexus 4. Now, it's running Android 4.4. Google Support was useless. The representative said that rooting may have caused it but I argued that there are locked bootloader, unrooted N4 owners out there that are having the same issue after applying the update OTA so it is clearly something wrong on Google's side. The rep also doesn't seem to be that knowledgeable about Android anyway, she probably read and pasted answers from a FAQ. Once again, WugFresh's toolkit relieved my anxiety because my girlfriend was going to be mad at me for soft-bricking her phone I bought for her, haha. Cheers!
  8. #8  

    Default Re: [SOLVED] Nexus 4 4.4 Update Stuck on Boot Animation

    Hi,

    I've got my Nexus 4 stuck in a boot loop as well after I tried to update to 4.4.3 OTA. I was just wondering how did you manage to use the toolkit without USB debugging being enabled?

    Thanks
  9. #9  

    Default Re: [SOLVED] Nexus 4 4.4 Update Stuck on Boot Animation

    Hi all,
    I'm aware I'm reviving an old post.
    The same thing happened to me with my dad's Nexus 4 a few hours ago.
    I tried doing exactly as you described (don't care if our stuff would be deleted or not, I just need the phone to work).

    I've ran the ToolKit and got a message that nothing happened and that I should run with "Full Force" in the options.
    Ran with Full Force and still nothing happened - got a message that a locked phone can't be written to by the Tool Kit.

    Any advice anyone?
    Please!

    Thank you,
    Shalgi

Similar Threads

  1. Verizon Galaxy Note 2 - Music player deleting songs in playlist?
    By Reinburglar in forum Verizon Galaxy Note 2
    Replies: 3
    Last Post: 12-01-2013, 08:20 PM
  2. Phones you've owned in your lifetime
    By Jonathan Rosenthal in forum General News & Discussion
    Replies: 15
    Last Post: 11-28-2013, 07:00 PM
  3. LTE in my hometown Finally!
    By Bradski9 in forum HTC One
    Replies: 5
    Last Post: 11-26-2013, 11:38 PM
  4. X vs Nexus 5 vs 5s
    By jebba in forum Moto X (2013)
    Replies: 7
    Last Post: 11-26-2013, 10:54 AM

Posting Permissions