1. audibink's Avatar
    I know this question has been asked and answered several times but I swear I have tried everything and still no luck.

    I have a nexus 4 and I just moved to straight talk and ordered an activation kit directory though them. I am up and running but cannot receive MMS.

    Thanks for your suggestions and help!
    Jordan
    01-28-2014 02:06 PM
  2. ph37rd's Avatar
    I know this question has been asked and answered several times but I swear I have tried everything and still no luck.

    I have a nexus 4 and I just moved to straight talk and ordered an activation kit directory though them. I am up and running but cannot receive MMS.

    Thanks for your suggestions and help!
    Jordan
    Check your APN. Something is not complete or set properly.

    Sent from my Nexus 4 using Tapatalk
    01-28-2014 03:07 PM
  3. audibink's Avatar
    could you please post what you have or what is correct so I could verify what is on my phone. Thank you
    01-28-2014 03:37 PM
  4. audibink's Avatar
    Anyone?
    01-28-2014 09:42 PM
  5. kmcochran's Avatar
    Which carrier do you have? AT&T or T-Mobile?
    01-29-2014 03:47 PM
  6. audibink's Avatar
    At&t. Signed up with byop with simple talk.
    01-29-2014 08:25 PM
  7. jasongeiger's Avatar
    01-29-2014 08:28 PM
  8. audibink's Avatar
    Yep tried that. Everything works but MMS.
    Bobthahog likes this.
    01-30-2014 04:16 AM
  9. Elkad's Avatar
    That's not what I'm using on my ATT straight talk (nexus 4). Haven't changed my settings in over a year.

    My text settings are...

    MMSC: http://mmsc.cingular.com
    MMS Proxy: 66.209.11.33
    MMS Port: 80
    02-01-2014 08:23 PM
  10. audibink's Avatar
    Can you send me a PM with all your other settings? I'd like to to a stare and compare.
    02-02-2014 08:46 AM
  11. kmcochran's Avatar
    Here are screenshots of my settings. I will say that for some reason my mms would not work when I had the Google voice app on my phone. Once I uninstalled it, MMS worked fine.

    Sent from my Nexus 4 using AC Forums mobile app
    Attached Thumbnails Nexus 4: Straight Talk sim APN settings... MMS issues-1391391844256.jpg   Nexus 4: Straight Talk sim APN settings... MMS issues-1391391870317.jpg   Nexus 4: Straight Talk sim APN settings... MMS issues-1391391883618.jpg  
    02-02-2014 07:45 PM
  12. audibink's Avatar
    Still got nothing with those settings. Do you have a ST or ST&T sim?
    02-03-2014 12:32 PM
  13. audibink's Avatar
    Anyone?
    02-04-2014 04:42 AM
  14. syrikk's Avatar
    I'm in the same boat. I just activated last Thursday, and I've tried every combination of settings that anyone here has posted, and in many other forums as well. I can send MMS, but not receive them regardless of what they are set at. Settings that work for some, don't for others. I'd love a solution, also. I'm soon headed up to AT&T to drop Straight Talk on its face and sign up for a Go Phone. It is a little bit more money, but at least it will work.
    02-04-2014 03:03 PM
  15. kmcochran's Avatar
    Still got nothing with those settings. Do you have a ST or ST&T sim?
    I have the ST-AT&T sim card. I have had no problems with MMS messages once I removed the google voice app. I still use GV for voicemail, but I just don't use the app.
    02-04-2014 06:09 PM
  16. audibink's Avatar
    I have the ST-AT&T sim card. I have had no problems with MMS messages once I removed the google voice app. I still use GV for voicemail, but I just don't use the app.
    I have no VM programs installed. I just got done completely wiping the phone. Still no go!! ughh!
    02-06-2014 08:24 AM
  17. kmcochran's Avatar
    Bummer. The only thing I can think of is maybe you have a faulty sim card. Has the card been used in a previous phone? If so, did mms work? You also may want to do a search on MMS in this forum. There may be more info on that other Android forum, where all the developers are, and I can't think of the name of it right now (have a bad head cold, so brain is not functioning properly )
    02-06-2014 08:54 AM
  18. audibink's Avatar
    Bummer. The only thing I can think of is maybe you have a faulty sim card. Has the card been used in a previous phone? If so, did mms work? You also may want to do a search on MMS in this forum. There may be more info on that other Android forum, where all the developers are, and I can't think of the name of it right now (have a bad head cold, so brain is not functioning properly )
    I tried it in a friends nexus 5 and could not get it to work either. It was a brand new sim card. ST refuses to give me another card and said that is not the problem. The tech support is awful.
    02-06-2014 09:09 AM
  19. kmcochran's Avatar
    So, your friend's Nexus 5 gets MMS with their sim card, but not with your card? I would call back and ask for a supervisor. Definitely sounds like a bad sim card. Oh, and did you get the micro sim card or did you cut it down yourself? If you got their micro sim, then it's most likely defective. If you cut it down, then maybe you damaged it somehow.
    02-06-2014 06:51 PM

Similar Threads

  1. Replies: 22
    Last Post: 01-21-2016, 10:35 PM
  2. sim card registration fails
    By satishRebel in forum Samsung Galaxy S3 in Canada (Bell/Telus/Rogers)
    Replies: 3
    Last Post: 01-30-2014, 06:39 PM
  3. Dead pixels? Camera issue.
    By pikarlychu in forum Samsung Galaxy S3
    Replies: 2
    Last Post: 01-30-2014, 03:56 PM
  4. Receiving MMS issues
    By RECav21#AC in forum Android 4.1 / 4.2 / 4.3 Jelly Bean
    Replies: 0
    Last Post: 01-28-2014, 01:59 PM
  5. SMS not sending through stock app - GV issue
    By jjz777 in forum Verizon Galaxy Nexus
    Replies: 0
    Last Post: 01-28-2014, 11:49 AM
LINK TO POST COPIED TO CLIPBOARD