1. ehendraw's Avatar
    Hi all,

    I have a weird problem with my Nexus 4. This happened starting this morning... my mobile data is on and I can access Facebook (app). However, this is the only app/internet access that works. Other apps such as Twitter, Gmail, NHL, whatsapp and Google Chrome can't connect online - it keeps saying you do not have internet access.

    I've tried restarting the phone and made sure that my wifi is off. On a side note wifi works perfectly fine - when I connect via wifi all the app connected to the internet just fine.

    Let me know if someone have an idea on how to fix this! Would be very much appreciated. Thanks!
    05-28-2014 04:16 PM
  2. JohnBB101's Avatar
    Hello

    It sounds like a very specific problem, but try this (I'm running a custom ROM so the steps may be slightly different);
    1. Open Settings
    2. Hit "More..." under Data Usage
    3. Open "Mobile networks" then "Access Point Names"
    4. There should be more than one APN, so select one that hasn't been selected
    5. Try and see if it works now


    Good luck!
    YeonChulie likes this.
    05-29-2014 10:15 AM
  3. vishwa nara's Avatar
    Oh Dude ,
    thank you so much I had same problems. except my opera everything was not connecting on 3G. Now everything is working fine. thanks a lot friend!!
    04-20-2015 03:20 AM
  4. BCSugar's Avatar
    I tried your suggestion, as I also have been having issues connecting via my data network, however when I check the APNs, there is only one listed. Any other recommendations that I might try? I've been having trouble connecting via data for a couple or so months now...
    10-10-2015 09:40 PM
  5. Kasun Sirimanna's Avatar
    Hi, I'm having a Xperia L and had the same issue. I did everything you guys have mentioned but nothing happened. So I went to my network provider and changed the Sim. They gave a new one. It solved the problem. Thanks guys.
    belodion likes this.
    11-20-2015 06:26 AM
  6. San dro's Avatar
    Hello

    It sounds like a very specific problem, but try this (I'm running a custom ROM so the steps may be slightly different);
    1. Open Settings
    2. Hit "More..." under Data Usage
    3. Open "Mobile networks" then "Access Point Names"
    4. There should be more than one APN, so select one that hasn't been selected
    5. Try and see if it works now


    Good luck!
    Just wanted to say thank you. Worked for me, such a frustration to have a so called smartphone without internet ...
    02-03-2016 06:24 PM
  7. AndroidUserOA's Avatar
    thank you so much. now i can play pokomon go haha
    07-17-2016 09:27 AM
  8. morgan lund's Avatar
    What if there is only the one APN?
    07-19-2016 04:22 PM
  9. cgebert's Avatar
    JohnBB101 you are my hero! Tried your suggestion to ehendraw and now my phone works like it should without wifi. WooHoo!

    Thank you so much!
    10-01-2016 08:47 PM
  10. Saurabh Mishra4's Avatar
    Thanks Bro... you saved me from another reinstall of rom
    11-01-2016 03:33 AM
  11. YeonChulie's Avatar
    thank you. helps me a lot.
    11-23-2016 01:19 AM
  12. YeonChulie's Avatar
    Hello

    It sounds like a very specific problem, but try this (I'm running a custom ROM so the steps may be slightly different);
    1. Open Settings
    2. Hit "More..." under Data Usage
    3. Open "Mobile networks" then "Access Point Names"
    4. There should be more than one APN, so select one that hasn't been selected
    5. Try and see if it works now


    Good luck!
    thanks for this. helps me a lot.
    11-23-2016 01:19 AM
  13. cbwb's Avatar
    It claims that device provision is not working how do i fix this problem
    12-13-2016 09:01 PM
  14. B. Diddy's Avatar
    It claims that device provision is not working how do i fix this problem
    See response in your other thread: phone will not connect to google server
    12-15-2016 12:26 AM
  15. Ysobel Sandoval's Avatar
    thank you so much! mine's working now
    01-10-2017 12:35 AM
  16. Kabir R's Avatar
    Hey thanks a lot...solves my pblm...I followed the instructions as mention above in my Sony Xperia z2 phone n at last did restore default and my Facebook started working using mobile data Internet.
    02-21-2017 10:28 AM

Similar Threads

  1. Google Play Can No longer See My Phone (Galaxy S3/Verizon)
    By Mr. Chicken in forum Samsung Galaxy S3 Rooting, ROMs, & Hacks
    Replies: 2
    Last Post: 08-18-2016, 09:36 PM
  2. Log Screen-comes on randomly
    By Sammuel1973 in forum Samsung Galaxy S5
    Replies: 5
    Last Post: 05-31-2014, 07:46 AM
  3. Replies: 4
    Last Post: 05-29-2014, 07:11 AM
  4. How can I transfer game save data from a broken device?
    By Kirbologist in forum General Android Device Chat
    Replies: 0
    Last Post: 05-28-2014, 03:56 PM
  5. Replies: 0
    Last Post: 05-28-2014, 02:27 PM
LINK TO POST COPIED TO CLIPBOARD