Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 2 of 2
  1. Thread Author  Thread Author    #1  

    Unhappy Data is on, but can't access the internet

    Hi all,

    I have a weird problem with my Nexus 4. This happened starting this morning... my mobile data is on and I can access Facebook (app). However, this is the only app/internet access that works. Other apps such as Twitter, Gmail, NHL, whatsapp and Google Chrome can't connect online - it keeps saying you do not have internet access.

    I've tried restarting the phone and made sure that my wifi is off. On a side note wifi works perfectly fine - when I connect via wifi all the app connected to the internet just fine.

    Let me know if someone have an idea on how to fix this! Would be very much appreciated. Thanks!
  2. #2  

    Default Re: Data is on, but can't access the internet

    Hello

    It sounds like a very specific problem, but try this (I'm running a custom ROM so the steps may be slightly different);
    1. Open Settings
    2. Hit "More..." under Data Usage
    3. Open "Mobile networks" then "Access Point Names"
    4. There should be more than one APN, so select one that hasn't been selected
    5. Try and see if it works now


    Good luck!

Similar Threads

  1. Log Screen-comes on randomly
    By Sammuel1973 in forum Samsung Galaxy S5
    Replies: 5
    Last Post: 05-31-2014, 08:46 AM
  2. Replies: 4
    Last Post: 05-29-2014, 08:11 AM
  3. Google Play Can No longer See My Phone (Galaxy S3/Verizon)
    By Mr. Chicken in forum Samsung Galaxy S3 Rooting, ROMs, & Hacks
    Replies: 1
    Last Post: 05-28-2014, 05:00 PM
  4. How can I transfer game save data from a broken device?
    By Kirbologist in forum General Android Device Chat
    Replies: 0
    Last Post: 05-28-2014, 04:56 PM
  5. Replies: 0
    Last Post: 05-28-2014, 03:27 PM

Posting Permissions