Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 17 of 17
  1. Thread Author  Thread Author    #1  

    Default Phone Contacts not syncing with Google Account Contacts

    Yesterday, I added a contact to my People app on my Nexus 5. According to the settings for that app, Auto-sync is on and includes my Google account. The phone claims that Contacts has been synced for my Google account. Yet, sitting here at my computer and looking at Redirecting..., that contact is not present. Is there something else I'm supposed to do to get these things to sync? Does syncing only work down and not up?

    EDIT: I just checked my contacts on outlook.com (which I also have set to sync with the phone's People app), and the contact IS there. My Google phone is syncing better with Microsoft than with Google, itself?
  2. #2  
    jdk2's Avatar

    Posts
    288 Posts
    Global Posts
    860 Global Posts

    Default Re: Phone Contacts not syncing with Google Account Contacts

    Quote Originally Posted by David Lessnau View Post
    Yesterday, I added a contact to my People app on my Nexus 5. According to the settings for that app, Auto-sync is on and includes my Google account. The phone claims that Contacts has been synced for my Google account. Yet, sitting here at my computer and looking at Redirecting..., that contact is not present. Is there something else I'm supposed to do to get these things to sync? Does syncing only work down and not up?

    EDIT: I just checked my contacts on outlook.com (which I also have set to sync with the phone's People app), and the contact IS there. My Google phone is syncing better with Microsoft than with Google, itself?
    I don't have multiple accounts on my phone, but when you added the contact, did you specify in which account you wanted to contact to be placed? Since it's showing up in Outlook, it sounds like that's where it ended up. If memory serves me, there should be a drop down at the top of the contact in the People app where you can change this.
    Thanked by:
  3. #3  
    srkmagnus's Avatar

    Posts
    8,715 Posts
    Global Posts
    8,718 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default Re: Phone Contacts not syncing with Google Account Contacts

    Open System Settings > Accounts > Google and make sure you check the box next to "Contacts" to sync.
  4. Thread Author  Thread Author    #4  

    Default Re: Phone Contacts not syncing with Google Account Contacts

    System Settings | Accounts | Google shows Contacts being synced. But, it looks like jdk2's suggestion is where the problem is. Editing the specific contact in People shows my outlook.com account at the top. Unfortunately, there doesn't appear to be any way to edit this. So, I might have to re-create the contact with the proper syncing account.

    It's odd that it's syncing with outlook.com because I don't recall setting that field at all. If I start a new contact, I'm given the option to choose where it syncs and the default is my Google account. I'm going to have to go through all my contacts on the phone and see where they're being synced. Up until now, I had been assuming they were being synced to ALL the accounts I told it to sync to. Not just one. Thanks.
  5. #5  

    Default Re: Phone Contacts not syncing with Google Account Contacts

    I get a similar problem with my Motorola Moto G phone (android 4.4.2). The 'People' app shows contacts from all the accounts I've created on the phone: Google, Skype, Facebook and Outlook.com and if I remove the Google account from the phone the 'People' app tells me there is no suitable account to sync contacts with. Nb there doesnt seem to be a way to pick a different account to sync my contacts with, its Google or nothing; the contacts on my phone are never synced to the other accounts.

    However, the contacts do not get synced to Google. On gmail I can only see my Google contacts. Nb if I create a new contact on the phone it gets created as a Google contact and gets synced to Google, if I create a new contact on Google it gets synced to the phone as a Google contact.

    Motorola support told me to contact the app developer as it clearly was not a problem with the phone.
  6. #6  

    Default Re: Phone Contacts not syncing with Google Account Contacts

    I re-enabled some built in apps and got my sync back. I had disabled the built in Contacts and Email and Google Search and some others.
    Update: I take it back. Immediate response on the phone was to show that it was synced. Now it says "Sync is currently experiencing problems. it will be back shortly."
    It has been saying that for months.
  7. #7  

    Default Re: Phone Contacts not syncing with Google Account Contacts

  8. #8  

    Default Re: Phone Contacts not syncing with Google Account Contacts

    Resolved...One Way Sync Google contacts

    I determined that when you create a contact on your phone you must link it to your gmail account first .... otherwise the contact is default stored on your phone and will not sync to Google. See the drop down menu to select.

    There is no way to edit and change the link after you have created the contact. There is no issue with Google sync.

    You can verify by looking at an existing phone contact that was created on your PC and compare that with a contact created using your phone.

    Now create all new contacts linked to your Google account on your phone and they will sync online in in ~5 seconds.

    FatLipp
  9. #9  

    Default Re: Phone Contacts not syncing with Google Account Contacts

    Quote Originally Posted by TheFront40 View Post
    Resolved...One Way Sync Google contacts

    I determined that when you create a contact on your phone you must link it to your gmail account first .... otherwise the contact is default stored on your phone and will not sync to Google. See the drop down menu to select.

    There is no way to edit and change the link after you have created the contact. There is no issue with Google sync.

    You can verify by looking at an existing phone contact that was created on your PC and compare that with a contact created using your phone.

    Now create all new contacts linked to your Google account on your phone and they will sync online in in ~5 seconds.

    FatLipp
    This is how mine works too. Contacts that came from Exchange do not sync with Google. Not sure if by design. But wish they did.

    Posted via the Android Central App
  10. #10  

    Default Re: Phone Contacts not syncing with Google Account Contacts

    Hi.
    No thats not it for me at least.
    Always get the question which Google acount to add in.
    Tried both Go contacts and teh built in.
    I have to use Contacts Sync fix every time I add a contact.
    Been that way for over a year with different phones and Roms.

    More suggestions?
  11. #11  

    Default Re: Phone Contacts not syncing with Google Account Contacts

    I have just formatted my phone as the device was heating up like a thermal nuclear missile and burning my hand. Then the phone was slow down to a grind and or just slowly take its time to do anything like a tortoise.
    So I synched all my contacts in Gmail, LinkedIN, Whatsup, Viber, etc etc
    To make life easier I thought I would be smart and install cyanogeonmod, this worked successfully. Then sintalled Gapps.
    However I have a BIG problem. My contacts have not synched. My last synch was in mid september and I installed cyanogeon last week 23rd september and no contacts have pulled through.

    I have checked my Gmail from a desktop, then checked in linkedin and hotmail and none of my contacts have synched. The labels section has been checked.

    Any ideas and helps, would there be any contacts stored on my phone somewhere as all the data is on he phone still?

    HELP Please. thanks
  12. #12  

    Default Re: Phone Contacts not syncing with Google Account Contacts

    PROBLEM SOLVed.......



    Go into contacts
    Go into settings
    Select merge contacts
  13. #13  

    Default Re: Phone Contacts not syncing with Google Account Contacts

    Quote Originally Posted by Ahmad Noble View Post
    PROBLEM SOLVed.......



    Go into contacts
    Go into settings
    Select merge contacts
    Huh? No. This has nothing to do with this issue.

    Posted via the Android Central App
  14. #14  

    Default Re: Phone Contacts not syncing with Google Account Contacts

    I had the same problem with my Galaxy S5

    My solution was to use the pull-down menu at the top of the phone's add contact screen, and select "Google", then go ahead and add the contact. This is not mentioned in the User Manual, or anywhere else I can find...I found it by trial & error.

    The pull-down menu at the top of the screen defaults to "Device" on new phones. Once you select "Google" it will continue to default to that setting.

    Another surprise: when you look at a contact, it has a section headed "Connected via". If that section shows a phone icon, the contact is not linked to Google Contacts: if it has a stylized "g", it is linked to Google Contacts and will be synced.

    If you have added contacts to "Device" (which you certainly have or you would not be reading this), I know of no way of editing that setting: the only solution I have found is to delete the contact, and add it with the "Connected via" set to Google.
  15. #15  

    Default Re: Phone Contacts not syncing with Google Account Contacts

    Bottom line is you can't sync contacts to both your Google account and an Outlook/EAS account.

    Posted via the Android Central App
  16. #16  

    Default Re: Phone Contacts not syncing with Google Account Contacts

    Quote Originally Posted by Ahmad Noble View Post
    PROBLEM SOLVed.......



    Go into contacts
    Go into settings
    Select merge contacts
    this solved my problem. Thanks...
    Problem was that i saved contact on galaxy s5 as device contact. i did merge and contacts were available on gmail contacts.
  17. #17  
    ozmo1911's Avatar

    Posts
    5 Posts
    Global Posts
    22 Global Posts

    Default Re: Phone Contacts not syncing with Google Account Contacts

    I had a slightly different problem with my Nexus 5, noting it here in case someone has the same issue: Some Gmail contacts were not syncing to the phone, as they didn't appear in the phone's 'People' app.

    Specifically, a contact I added via the 'invite to chat' function in Hangouts/Gchat showed up in my contacts, but didn't appear in the stock People app. I found that the People app only seems to sync contacts that've been added to My Contacts, or to one of the user-defined contact groups. The contact I added via Hangouts wasn't in any group at all, but appeared on the phone after I hit "Add to My Contacts". Adding the person to one of your user-defined groups will automatically add them to My Contacts, as well.

    Some third-party apps (notably, the one from Samsung) seem to allow to option of including contacts outside of the My Contacts group. The way People does it makes sense - you don't want all the people in the 'Other Contacts' list (like newsletters, order status emails, spammers and other non-humans) to show up on your phone. Ideally, anyone you add as a chat contact in Hangouts should automatically get added to My Contacts, but this is fine for now.

Similar Threads

  1. Google Play Services - cant force stop
    By Lubna Kably in forum Android Apps
    Replies: 6
    Last Post: 07-18-2014, 04:53 AM
  2. Google play music shuffle
    By Shocktribe in forum Google Nexus 5
    Replies: 2
    Last Post: 01-03-2014, 05:48 PM
  3. Galaxy S4 Power Bank Not Charging
    By Neo_Calibur in forum Samsung Galaxy S4 Accessories
    Replies: 1
    Last Post: 01-03-2014, 12:16 PM
  4. Volume suddenly goes to zero, then have to restart phone
    By vamsikatta in forum Nexus 4 Accessories
    Replies: 1
    Last Post: 01-03-2014, 11:25 AM

Posting Permissions