Page 1 of 2 12 LastLast
Results 1 to 25 of 30
Like Tree3Likes
  1. Thread Author  Thread Author    #1  

    Default Nexus 5: Ok Google not working?

    I'm not sure if I had accidentally uninstalled its app or what, but Ok Google is not working for me anymore.

    Got my new nexus 5 yesterday. Google play automatically installed a lot of old applications from my old device.
    I didn't want that, so I deleted a bunch of apps. So I'm not sure if I had accidentally deleted it. Does anyone know the app name?

    if it's not an app, then any possible solution for my problem?
    Thank you.
    Sorry if this thread has been repeated.
    Last edited by NotJustAPhone; 03-08-2014 at 02:05 PM.
  2. #2  

    Default Re: Ok Google not working?

    Quote Originally Posted by HamsapLou View Post
    I'm not sure if I had accidentally uninstalled its app or what, but Ok Google is not working for me anymore.

    Got my new nexus 5 yesterday. Google play automatically installed a lot of old applications from my old device.
    I didn't want that, so I deleted a bunch of apps. So I'm not sure if I had accidentally deleted it. Does anyone know the app name?

    if it's not an app, then any possible solution for my problem?
    Thank you.
    Sorry if this thread has been repeated.
    You're having the same issue I'm having. I did 3 factory resets and still don't understand the what the problem is. Hope someone has a solution
  3. #3  

    Default Re: Ok Google not working?

    Welcome to Android Central! Go to Google Settings>Search>Voice, and make sure "Hotword detection" is checked on. If that doesn't work, try rebooting the device.

    If none of that works, try a cache partition wipe. You won't lose any personal data or settings. Be aware that it might take a few minutes to complete.
  4. #4  
    srkmagnus's Avatar

    Posts
    6,751 Posts
    Global Posts
    6,754 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default Re: Ok Google not working?

    What exactly is the issue?

    Go to Google Now and scroll down to open the Menu (three-dots). Open the Voice setting and make sure Hotword Detection is enabled (box checked).

    If you are getting a "can't connect with Google Server error" then that's an issue with the network and should be reconnected soon after.
  5. #5  

    Default Re: Ok Google not working?

    Quote Originally Posted by srkmagnus View Post
    What exactly is the issue?

    Go to Google Now and scroll down to open the Menu (three-dots). Open the Voice setting and make sure Hotword Detection is enabled (box checked).

    If you are getting a "can't connect with Google Server error" then that's an issue with the network and should be reconnected soon after.
    I have the same issue as the OP and yes my hotword is selected. When I go to help I get a message that says my google now has been disabled by the domain administrator. I never got a message like that before. Did 3 factory resets and still same issue. My galaxy nexus and GS4 work just fine though. I researched the internet and found many others having the same issue.
  6. #6  
    srkmagnus's Avatar

    Posts
    6,751 Posts
    Global Posts
    6,754 Global Posts
    ROM
    Stock 4.4 (KitKat)

    Default Re: Ok Google not working?

    Quote Originally Posted by craigrn16 View Post
    I have the same issue as the OP and yes my hotword is selected. When I go to help I get a message that says my google now has been disabled by the domain administrator. I never got a message like that before. Did 3 factory resets and still same issue. My galaxy nexus and GS4 work just fine though. I researched the internet and found many others having the same issue.
    I would guess it's a server issue on Google's side. Give it a while and see if it is fixed.
  7. Thread Author  Thread Author    #7  

    Default Re: Ok Google not working?

    Quote Originally Posted by B. Diddy View Post
    Welcome to Android Central! Go to Google Settings>Search>Voice, and make sure "Hotword detection" is checked on. If that doesn't work, try rebooting the device.

    If none of that works, try a cache partition wipe. You won't lose any personal data or settings. Be aware that it might take a few minutes to complete.
    Thank you for the welcome
    Quote Originally Posted by srkmagnus View Post
    What exactly is the issue?

    Go to Google Now and scroll down to open the Menu (three-dots). Open the Voice setting and make sure Hotword Detection is enabled (box checked).

    If you are getting a "can't connect with Google Server error" then that's an issue with the network and should be reconnected soon after.
    Hotword detection was always on.
    i think you're correct cause it seems to be working now.
    Newb question, how would you get the can't connect google server error. Just curious, for future reference.
  8. #8  

    Default Re: Ok Google not working?

    Could always be a problem on the server side.
    srkmagnus likes this.
  9. #9  

    Default Re: Ok Google not working?

    I just turned it off as it seems to be a battery drain.

    Long press on a blank part of the home screen select settings under voice toggle the Hotword detection on or off as you desire.
  10. #10  

    Default Re: Ok Google not working?

    Is your mic on the home screen filled in white? If not then hotword is not on. I think it needs a data connection...

    From mah shiny new Nexus 5
  11. #11  

    Default Re: Ok Google not working?

    I noticed on my nexus 5 the voice command sometimes works then other times it won't even with hotword on.

    I often wind up looking stupid yelling "OK Google" at my phone homescreen multiple times in front of others lol.

    Seems to be happening both on the homescreen then the mic input in Google now itself seems to be affected as well. If you try that instead it wont accept the input. Basicly the round mic button doesnt do anything during those times its acting up. The only way around it when it happens that I've found is by going into hangouts and hiting the keyboard mic button during a text input or rebooting the phone itself.

    It definitely seems like there are software issues to be worked out with Google now.
  12. #12  
    blanco112's Avatar

    Posts
    9 Posts
    Global Posts
    14 Global Posts

    Default Re: Ok Google not working?

    This has started happening to me lately. When I boot up, it works. But after about an hour or so the microphone icon becomes hollow and hotword stops working. This is on both my Nexus 7 running Omnirom and my Galaxy S4 running stock. I've check to make sure that the languages are installed and that hotword detection is on.
  13. #13  
    blanco112's Avatar

    Posts
    9 Posts
    Global Posts
    14 Global Posts

    Default Re: Ok Google not working?

    Someone posted the following link in another thread which may help.



    Posted via Android Central App
  14. #14  

    Default Re: Ok Google not working?

    Do you have chrome beta installed by any chance? The latest update by google for chrome beta makes the mic inaccessible.
  15. #15  

    Default Re: Ok Google not working!

    Definitely it's not working and re-installing it doesn't help at all. It just went away.

    Same problem with Google Keep over the past two weeks. I lost tons of documents in Keep and going to the forum didn't help at all, nor did sending out a message via Twitter . They're just simply ignoring these problems because there's too many of them.

    I think in the main Google really doesn't care whether or not the stuff they put out functions. It's gotten out of control with the amount of product they've created and now keeping it all going is no longer feasible. I do believe the worst is still to come because they're juggling and have too many balls in the air!

    Dreading the day when I no longer see Google Search on my screen. Maybe it's time to go and make friends with Mr. Bing?

    BTW: I use the Google Chromebook (no Bing on this machine!)
    Last edited by Zorka Kovacevich; 01-26-2014 at 10:48 PM.
  16. #16  

    Default Re: Ok Google not working!

    Welcome to Android Central! That sounds very frustrating. What exactly happened? You just went to Keep one day and everything was gone? It wasn't even there when you went on the web to drive.google.com/keep? Did you try going to this website() and clicking on the Contact Us button at the upper right?

    For what it's worth, I know some of the engineers at Google, and I can tell you that the overall work ethic there is certainly one of caring about the user experience. It's true that they have a lot of products and projects, but they're also a gigantic company, so it's not like they just have a team of 10 people working on a major component. Historically, Google has not had a great customer feedback mechanism (the Google Product Forums always seem to be full of unanswered questions), but I think that has changed in recent years. I have been able to speak to live people after starting with the Contact Us option on their support pages, so give that a try.
  17. #17  

    Default Re: Ok Google not working?

    Quote Originally Posted by HamsapLou View Post
    Thank you for the welcome


    Hotword detection was always on.
    i think you're correct cause it seems to be working now.
    Newb question, how would you get the can't connect google server error. Just curious, for future reference.
    I constantly say things to Google search and ALWAYS get the "can't connect to Google". Very frustrating as my phone (GNex) has the offline recognition option checked and it doesn't work. It even happens when I have a perfect signal and just trying to do a phone call not even look something up online. I've never seen anyone have to ask Siri anything more than once. It always seems to work perfectly whereas Google Now voice works once in a blue moon.

    Sent from my Nexus 7 using AC Forums mobile app
  18. #18  

    Default Re: Ok Google not working?

    The GNex is a pretty old device, though. Google Now never worked that well on my RAZR Maxx, but it's totally smooth on my Nexus 5 and 7. How is it on your N7?

    Posted via Android Central App
  19. #19  

    Default Re: Ok Google not working?

    Hi there! I think I may have found a fix to your problem.
    As it turns out, the "Google" hotword is only available if you have English (US) set as your preferred language in Google Now.
    1. Click on "options" (three dotted button) at the end of the Google Now screen
    2. Go to "Voice"
    3. Go to "Language"
    4. Click on "English..." and select "English (US)"
    Go back to the Google Now screen and you should be able to see the 'Search, or say "Google"' text in the search box.
    I had the same issue and I figured this could work, seeing as to how a lot of such features are region/language specific.
    Hope this works for you.

    Posted via Android Central App
    B. Diddy likes this.
  20. #20  
    kgeissler's Avatar

    Posts
    59 Posts
    Global Posts
    71 Global Posts
    ROM
    Stock Rooted 4.2.1

    Default Re: Ok Google not working?

    Mine stopped working and someone on XDA said there was a conflict with Chrome Beta and its mic permission. I. uninstalled it and haven't had a problem since. You actually don't have to uninstall, but as soon as you launch Chrome Beta it will stop working.

    Sent from my Nexus 5 using Tapatalk
  21. #21  

    Default Re: Ok Google not working!

    Thanks B. Diddy:

    Yes, it is frustrating that suddenly Google Keep simply does not work. Ditto for Ok Google. 99% of everything I had stored in Keep disappeared into thin air. And everything in Archives disappeared altogether. Yes, I tried everything to contact Google directly without any results. Also tried using Keep directly via Web instead of through the App. Nothing. In fact, I just checked both access points and nothing has changed. The version on the Web is even worse, it shows only one of my Notes.

    Forgive me for venting about Google. I assure you that I'm a huge fan and appreciate all they've built and given to Internet users. Still, when this type of breakdown happens not once in a span of less than two weeks, but twice I can't help but feel they're overwhelmed and maybe have grown too big to manage their tech properly.

    And, you're right Google's record in the past with customer communications used to be pretty poor, but seems in recent times that response has been exceptionally timely to all my issues so in a way I've forgotten that getting attention from them may be actually a hit or miss thing.

    Oh well... we move on. Thanks again for trying to help. Zorka
    B. Diddy likes this.
  22. #22  

    Default Re: Ok Google not working?

    Thanks liv4speed.aniket. Checked it and verified it was setup as always to US English language. Actually, come to think of it, if it hadn't been it would have affected my usage and I only work in the English language.
    It was nice to have while it lasted. Zorka
  23. #23  

    Default Re: Ok Google not working?

    I do not have Chrome Beta installed and never have to my knowledge (who knows what Google does when we are asleep?) and my language has always been set to English US. But still, OK Google no longer works on my new Nexus 5. I do not plan to root administer, bootcamp or any other complex network admin's tricks to get my smart phone to work as intended. Nor can I find an app called "Google Now" or "OK Google" or any settings that refer to a hotword; Any other ideas?
  24. #24  

    Default Re: Ok Google not working?

    OK Google is kind of working again. Noticed that the mic icon was back next to search box. It still doesn't respond to "OK Google", but if I click on the mic I can use voice search. So that's not too bad. Google should actually leave it this way because having too say "OK Google" sort felt like to much to have to say.

    I do want to mention that I didn't really realize that this was still in beta... so it makes sense why there would be a disruption in service.
  25. #25  

    Default

    Google voice search just stopped working on my N5. When I say OK Google or tap the mic it makes an odd sound and does not recognize my input. It is working on my Nexus 7.

    Posted via Android Central App
Page 1 of 2 12 LastLast

Similar Threads

  1. Mobile data seems to be connected but doesn't work
    By stelios85 in forum Android 2.3 Gingerbread
    Replies: 3
    Last Post: 01-19-2014, 11:11 AM
  2. Does anyone know the number for Google tech support?
    By craigrn16 in forum Google Nexus 5
    Replies: 4
    Last Post: 01-11-2014, 12:18 PM
  3. Samsung Galaxy Note 10.1 2014 / Samsung (not so)Smart TV question
    By dianehelen in forum Samsung Galaxy Note 10.1 (2014)
    Replies: 2
    Last Post: 01-11-2014, 11:37 AM

Posting Permissions

B