1. VoltaicShock's Avatar
    I was looking at my Data Usage (I am on the T-Mobile Prepaid 70/Month plan).

    My phone is reporting 10.11GB of data usage.
    T-Mobile is saying I have only used 5.6GB of data usage.

    I have been watching Netflix for my commute to work and home. The data usage on netflix is only reporting Foreground 22.38MB and 315KB background.

    Can someone explain to me how this can be?
    01-16-2014 09:29 AM
  2. ajpri's Avatar
    Never trust the data meter on your phone. It's just not accurate, even for me. I'd suggest you use My Data Manager (even includes a handy persistent notification)! I'd say its accurate within about 5-10%. If that isn't great for you, make sure #932# (T-Mobiles data usage code) is in your contacts and add it as a direct dial shortcut. It's 100% accurate! Thank you for reading this if you got here, sorry for the length.

    Posted via Android Central App on my Nexus 5 (4.4.2)
    01-16-2014 09:58 AM
  3. UJ95x's Avatar
    I was looking at my Data Usage (I am on the T-Mobile Prepaid 70/Month plan).

    My phone is reporting 10.11GB of data usage.
    T-Mobile is saying I have only used 5.6GB of data usage.

    I have been watching Netflix for my commute to work and home. The data usage on netflix is only reporting Foreground 22.38MB and 315KB background.

    Can someone explain to me how this can be?
    That is weird, my data meter always works fine.
    I don't imagine you've done any resets lately?

    Posted via Android Central App
    01-16-2014 10:14 AM
  4. Almeuit's Avatar
    Never trust the data meter on your phone. It's just not accurate, even for me. I'd suggest you use My Data Manager (even includes a handy persistent notification)! I'd say its accurate within about 5-10%. If that isn't great for you, make sure #932# (T-Mobiles data usage code) is in your contacts and add it as a direct dial shortcut. It's 100% accurate! Thank you for reading this if you got here, sorry for the length.

    Posted via Android Central App on my Nexus 5 (4.4.2)
    Mine is accurate (has been on all my phones) .. Not 100% but a good 90% just by setting up the billing cycle.

    Sent from my T-Mobile Note 3 using AC Forums.
    01-16-2014 11:31 AM
  5. Almeuit's Avatar
    Example below. The T-Mobile site hasn't updated yet with today's usage (the data displayed was the same yesterday evening).

    Sent from my T-Mobile Note 3 using AC Forums.
    Attached Thumbnails Nexus 5 KitKat Data Usage Bug?-1389893697456.jpg   Nexus 5 KitKat Data Usage Bug?-1389893709367.jpg  
    01-16-2014 11:35 AM
  6. Gwaron's Avatar
    My N5 data usage versus AT&T reported usage has always been spot on. At present, my N5 reports 225 MB, and AT&T reports 226 MB. That's within 0.4%.
    01-16-2014 11:53 AM
  7. N4Newbie's Avatar
    I was looking at my Data Usage (I am on the T-Mobile Prepaid 70/Month plan).

    My phone is reporting 10.11GB of data usage.
    T-Mobile is saying I have only used 5.6GB of data usage.

    I have been watching Netflix for my commute to work and home. The data usage on netflix is only reporting Foreground 22.38MB and 315KB background.

    Can someone explain to me how this can be?
    Go to Settings -> Data usage. Ensure that the "Data usage cycle" is set correctly. If not, the phone's numbers will never agree with the carrier's.
    UJ95x and Gwaron like this.
    01-16-2014 12:17 PM
  8. Chex313's Avatar
    And another bug...as long as ice cream sandwich when the Data use was added . My start date bar on the graph moves after a couple weeks into my month. I have to drag it back each time I check it. I thought they would have fixed this by now.

    Posted via Serenity
    01-16-2014 04:40 PM
  9. patruns's Avatar
    I was looking at my Data Usage (I am on the T-Mobile Prepaid 70/Month plan).

    My phone is reporting 10.11GB of data usage.
    T-Mobile is saying I have only used 5.6GB of data usage.

    I have been watching Netflix for my commute to work and home. The data usage on netflix is only reporting Foreground 22.38MB and 315KB background.

    Can someone explain to me how this can be?
    I am on the same plan and noticed the same thing initially. Then I realized that I forgot to change the data date cycle when I switched phone. As soon as I corrected it both were pretty close.
    01-17-2014 09:49 AM

Similar Threads

  1. KitKat 4.4.2 Network Work Mode Disabled....GRRR!!!
    By Sizzers in forum Moto G (2013)
    Replies: 12
    Last Post: 09-30-2014, 11:03 AM
  2. Tether Nexus 7 tablet to android phone
    By spthomas in forum Google Nexus 7 Tablet (2012)
    Replies: 4
    Last Post: 03-04-2014, 06:54 PM
  3. Headphones aren't working after KitKat update.
    By Stungun4111 in forum Google Nexus 4
    Replies: 6
    Last Post: 01-22-2014, 03:11 AM
  4. Nexus 5 photo auto backup question
    By Kevin Oates in forum Google Nexus 5
    Replies: 2
    Last Post: 01-16-2014, 09:34 AM
  5. Headphones aren't working after KitKat update.
    By Stungun4111 in forum Android 4.4 KitKat
    Replies: 0
    Last Post: 01-16-2014, 02:15 AM
LINK TO POST COPIED TO CLIPBOARD
";