Results 1 to 5 of 5
  1. Thread Author  Thread Author    #1  
    luke31's Avatar

    Posts
    540 Posts
    Global Posts
    632 Global Posts
    ROM
    All Stock (for now)

    Default Urgent: Need Help from T-Mobile Users

    Hey guys. So I started a thread earlier about my phone having signal issues on T-Mobile. Today is essentially the last day I have to return the phone to the store. I am trying to diagnose something, and seem to be having difficulties. When I select the preferred network as "2G," my phone never connects to a network. It seems to lack the ability to connect to a 2G network. I've never seen it connect to anything else except H and LTE. The problem is, I have low signal in my building. The two other phones on our family plan (Nokia Lumias) have solid 2G signal. I, however, cannot acquire any 2G signal.

    So, to my fellow T-Mobile users, if you switch to "2G" as preferred network type, so you get any signal? What does it say? H? 2G? E? Thanks so much!
    Sony Xperia Z1s
    Nexus 7 2012 (16GB)
  2. #2  

    Default Re: Urgent: Need Help from T-Mobile Users

    Mine shows "E" and works fine. I'm in Denver. Wonder if it's some kind of radio band issue with the phone, maybe it's a weird kHz band in your area this phone can't pick up. No idea but good luck!

    Posted via Android Central App
  3. #3  

    Default Re: Urgent: Need Help from T-Mobile Users

    Mine works fine as well on 2G and it says E with full bars and I am inside a building in Manhattan. I wouldn't expect to stream music, but I can make a call. I also get this in bad signal areas during my commute automatically. You don't need to change the setting.
    Pat
    Nook Color - CM10.1 ( Jelly Bean 4.2.2) on eMMC
    Google Galaxy Nexus - stock Jelly Bean 4.3
    Galaxy Nexus 10 - stock KitKat 4.4.2
    Galaxy Nexus 7 (2nd Generation) - stock KitKat 4.4.2
    Chromecast
    Nexus 5 - stock KitKat 4.4.2
  4. Thread Author  Thread Author    #4  
    luke31's Avatar

    Posts
    540 Posts
    Global Posts
    632 Global Posts
    ROM
    All Stock (for now)

    Default Re: Urgent: Need Help from T-Mobile Users

    Quote Originally Posted by patruns View Post
    Mine works fine as well on 2G and it says E with full bars and I am inside a building in Manhattan. I wouldn't expect to stream music, but I can make a call. I also get this in bad signal areas during my commute automatically. You don't need to change the setting.
    I never get E on my phone.

    Posted via Android Central App
    Sony Xperia Z1s
    Nexus 7 2012 (16GB)
  5. #5  

    Default Re: Urgent: Need Help from T-Mobile Users

    Yeah, the E refers to T-Mobile's Edge service. Not really great for data stuff, but fine for texting/calling.

    Posted via Android Central App

Similar Threads

  1. T-Mobile: $30 "walmart" plan question
    By wessock in forum T-Mobile
    Replies: 17
    Last Post: 02-21-2014, 05:11 PM
  2. Want to try T-Mobile for a month
    By slik6996 in forum Google Nexus 5
    Replies: 14
    Last Post: 01-28-2014, 12:43 PM
  3. Replies: 14
    Last Post: 01-25-2014, 11:33 PM
  4. Does the Moto G work well on T-Mobile?
    By supert1020 in forum Moto G
    Replies: 2
    Last Post: 01-24-2014, 12:27 PM
  5. Why can't I disable "email" from the battery option? It drains 25%.
    By Elysium82 in forum General News & Discussion
    Replies: 2
    Last Post: 01-24-2014, 12:08 PM

Posting Permissions

B