1. MrToneBoneZ's Avatar
    Greetings. My issue is that I recently went from a gs3 to 32gb nexus 5 on sprint and more often then not my phone is not receiving calls. People have said they called me 4 times in a row and the phone rang but on my end the phone didn't ring and I would just receive a voicemail notification. I live in an area with LTE as well. Has anyone experienced this issue ? Should I leave the phone on global, LTE or 3g, my main concern is I sing want to miss anymore phone calls. Thanks!

    Posted via Android Central App
    03-02-2014 01:48 PM
  2. krifor03's Avatar
    This issue has been experienced before. I believe the short term fix is keeping your phone in 3G, not 4G.

    Nexus 5 4.4.2
    Got sideload?
    03-02-2014 05:34 PM
  3. Jaramie10's Avatar
    I have experienced this in Nc. Turn your phone to LTE or 3g, we had to turn our phones to 3g to make a call. We are heading to T-Mobile, I'm done with this crap...

    Posted via Android Central App
    03-02-2014 05:49 PM
  4. MrToneBoneZ's Avatar
    Ok so I'm not the only one experiencing this. OK thanks for the advice I'll give 3g a shot. I wonder if this bug will be addressed via update or it is a hardware issue.

    Posted via Android Central App
    03-03-2014 07:06 AM
  5. bjrosen's Avatar
    Did you buy your phone from Sprint or from Google? If you bought from Google then switch to AT&T, much better coverage and LTE speed. I'm on AT&T and I'm not having any problems liek you describe except when I inadvertently silence the ringer (which is pretty easy to do with this phone).
    Jaramie10 likes this.
    03-03-2014 08:56 AM
  6. Jaramie10's Avatar
    What's funny is that I decided to try a pretty paid account with T-Mobile and all the issues with the phone went away. I now have voicemail notifications, better battery life, crystal clear voice quality, and blazing speeds.

    Posted via Android Central App
    03-03-2014 09:08 AM
  7. IAmSixNine's Avatar
    I left Sprint a little over a year ago when i started to have the same issue with my GS3 and then my EVO LTE.
    It wasnt a phone issue but rather their Vision Network upgrades that was causing it. Ive also read on other device forums that its happening to other Sprint customers. Missing calls seems to be on the rise. Hope they get it fixed.
    03-03-2014 03:42 PM

Similar Threads

  1. LG G Flex: What case do you use?
    By Topgonzo in forum LG G Flex
    Replies: 20
    Last Post: 05-27-2014, 11:31 AM
  2. Can I use UK firmware on a phone bought from UAE
    By Maged Samuel in forum LG G2
    Replies: 1
    Last Post: 03-10-2014, 11:08 AM
  3. Replies: 11
    Last Post: 03-07-2014, 09:05 AM
  4. Getting IR blaster to work via Facebook or Web Sites?
    By cristianocr7 in forum HTC One M7
    Replies: 2
    Last Post: 03-05-2014, 09:00 AM
  5. Should I root or not?
    By Baugherb in forum AT&T Samsung Galaxy Note 3
    Replies: 8
    Last Post: 03-02-2014, 08:10 PM
LINK TO POST COPIED TO CLIPBOARD