1. Closingracer's Avatar
    I went from 100% to 30% in 3 hours and noticed YouTube app was most of the reason

    Sent from my Nexus 5 using Tapatalk
    Jigger Lives likes this.
    03-24-2014 10:33 PM
  2. Closingracer's Avatar


    Sent from my Nexus 5 using Tapatalk
    03-24-2014 10:34 PM
  3. bulletmark's Avatar
    I had this exact problem yesterday also with youtube. Never seen it before.

    I am hanging out for the 4.4.3+ updates because hopefully Google are fixing these odd battery sucking issues.
    tonyr6 likes this.
    03-24-2014 11:08 PM
  4. Closingracer's Avatar
    Had to charge my phone 3 times today and was wondering why

    Sent from my Nexus 5 using Tapatalk
    Jigger Lives likes this.
    03-24-2014 11:09 PM
  5. UJ95x's Avatar
    How long was the screen on? I've had YT in the top spot, even though I had normal battery drain

    Sent from my Galaxy S4 running SlimKat 4.4.2
    03-24-2014 11:14 PM
  6. Closingracer's Avatar
    Err not much

    Sent from my Nexus 5 using Tapatalk
    03-24-2014 11:15 PM
  7. UJ95x's Avatar
    Err not much

    Sent from my Nexus 5 using Tapatalk
    Weird. And you weren't using YouTube at all? This seems like a wakelock issue, so a reboot should fix it

    Sent from my Galaxy S4 running SlimKat 4.4.2
    03-24-2014 11:38 PM
  8. Closingracer's Avatar
    I used the app for like 2 minutes and then backed out of it and closed it

    Sent from my Nexus 5 using Tapatalk
    03-24-2014 11:39 PM
  9. bulletmark's Avatar
    I used the app for like 2 minutes and then backed out of it and closed it.
    Same. When it happened to me yesterday I could not even remember using the youtube app. Maybe I had, but it would have been very brief.
    03-24-2014 11:42 PM
  10. UJ95x's Avatar
    I used the app for like 2 minutes and then backed out of it and closed it

    Sent from my Nexus 5 using Tapatalk
    Definitely a wake lock issue then. For whatever reason the YouTube app kept the phone awake causing the battery to drain faster

    Sent from my Galaxy S4 running SlimKat 4.4.2
    03-24-2014 11:55 PM
  11. B. Diddy's Avatar
    I saw that Closingracer was also using the Glove app. What about you, bulletmark? Just wondering if there might be some odd interaction between that app and YouTube. From what I read about Glove, it sounds like it constantly runs for 3 days, keeping tabs on when you use your phone for network access--maybe it's somehow triggering other apps like YouTube to run constantly as well?
    03-25-2014 12:48 AM
  12. Closingracer's Avatar
    I saw that Closingracer was also using the Glove app. What about you, bulletmark? Just wondering if there might be some odd interaction between that app and YouTube. From what I read about Glove, it sounds like it constantly runs for 3 days, keeping tabs on when you use your phone for network access--maybe it's somehow triggering other apps like YouTube to run constantly as well?
    I ran it before and never had my battery drain like that before. Rebooted it helped so far

    Sent from my Nexus 5 using Tapatalk
    03-25-2014 10:33 AM
  13. Closingracer's Avatar



    I just put it back on the charger and 4 hours down to 80% is the norm even without glove running
    Sent from my Nexus 5 using Tapatalk
    03-25-2014 10:34 AM
  14. bulletmark's Avatar
    I saw that Closingracer was also using the Glove app. What about you, bulletmark?
    I have never installed that app, not even heard of it.
    03-25-2014 05:59 PM
  15. xstinkyx's Avatar
    Count me in as well.

    Today after less then three hours on battery I noticed battery was low.
    YouTube accounted for 49% of it! I've never seen that before either.
    (I think I used YT to check my Uploads page in the morning, but didn't watch anything.)

    I did a Force Stop but I guess that doesn't help with whatever's happening.
    YouTube now accounts for 62% of the battery usage.

    Reboot time....
    03-26-2014 02:08 AM
  16. daman123's Avatar
    I've had this problem on my phone last week. To fix it, restart your phone right when you see YouTube is draining your battery.

    Posted via Android Central App
    03-26-2014 06:01 AM
  17. yfan's Avatar
    Definitely a wake lock issue then. For whatever reason the YouTube app kept the phone awake causing the battery to drain faster
    Yup, it' a wakelock issue alright. This has happened to me twice now. Once on Dalvik, and today on ART.

    I've had this problem on my phone last week. To fix it, restart your phone right when you see YouTube is draining your battery.
    But isn't there a chance it'd eventually come back when you use YouTube again? The couple of times it's happened to me, I force stopped YouTube and that helped - but then again, it just stopped YouTube from running. It should happen without user interaction.
    04-06-2014 10:08 PM
  18. alfaro21's Avatar
    Just had the same issue last night. Went to bed with 40+ of battery and the phone didn't survive the night. After recharging youtube had the number 1 battery use...
    04-23-2014 11:41 AM
  19. lahoof's Avatar
    I used YouTube for less than a minute tofay.. battery has drained much faster than usual.. YouTube accounts for 30% of battery used.

    Xperia Z Ultra running stock 4.4.2
    04-24-2014 05:48 PM
  20. Jigger Lives's Avatar
    When I start my tablet charging I always check task manager, no apps running. After several hours of charge time I should be back to 90-100%, but no it will be 50-60%, I check task manager and there it is, Youtube app running draining the battery as fast as it charges. I have tried restart several times, has not helped. I very seldom even use youtube. Any suggestions? Thks.
    11-02-2015 05:00 AM

Similar Threads

  1. Autofill in Yahoo Mail App not working - 4.4
    By SHIVA77 in forum Android 4.4 KitKat
    Replies: 1
    Last Post: 03-26-2014, 09:15 PM
  2. Privacy app question ?
    By wolfhead in forum General Help and How To
    Replies: 5
    Last Post: 03-25-2014, 11:53 PM
  3. Does rooting kill battery?
    By 1210saad in forum Google Nexus 4
    Replies: 6
    Last Post: 03-25-2014, 12:04 AM
  4. S 3 mini battery problem
    By Steve Hall1 in forum Samsung Galaxy S3 Mini
    Replies: 1
    Last Post: 03-24-2014, 11:09 PM
  5. Replies: 2
    Last Post: 03-24-2014, 10:45 PM
LINK TO POST COPIED TO CLIPBOARD