1. okaybn's Avatar
    Hi, hoping someone can help.

    When I tap the google search bar on my nexus 5 homescreen I get a large white drop down with all my recent searches. Is there a way to clear this history? I have already logged into google.com/history and cleared all history on that site, but it still shows on that drop down.

    The ONLY way I am able to get rid of them is by manually holding down EACH result and tapping "remove from search history".
    Is there a clear all option somewhere?

    Pls help.
    04-25-2014 09:19 PM
  2. B. Diddy's Avatar
    I think you can do it by logging into your Google account on a browser. Go to history.google.com, click the gear icon at the upper right and then Settings, then click on "delete all" past Google search activity.
    04-25-2014 09:39 PM
  3. okaybn's Avatar
    Thank you for your response.

    But as my post states, I already did that and its STILL showing.

    Posted via Android Central App
    04-25-2014 09:44 PM
  4. B. Diddy's Avatar
    WHOOPS. Sorry about that. Not sure how I missed it!

    Ok, try this. Go to Settings>Apps>All, select Google Search, and Clear Cache and Data.
    04-25-2014 09:56 PM

Similar Threads

  1. Galaxy S4: New Icon on Notification Bar
    By HiddenPuppy in forum Verizon Samsung Galaxy S4
    Replies: 6
    Last Post: 04-27-2014, 01:12 PM
  2. Replies: 4
    Last Post: 04-26-2014, 04:55 PM
  3. Can't activate
    By dgravo in forum Google Nexus 7 Tablet (2013)
    Replies: 5
    Last Post: 04-26-2014, 12:15 PM
  4. Replies: 5
    Last Post: 04-25-2014, 08:17 PM
  5. Verizon.. Will kitkat google dialer work with weak sauce
    By 1stryker in forum HTC One Rooting, ROMs & Hacks
    Replies: 0
    Last Post: 04-25-2014, 07:16 PM
LINK TO POST COPIED TO CLIPBOARD