1. jplehmann's Avatar
    I got my Nexus 5 back in Dec '13. When 4.4.2 came out, I did NOT upgrade because I saw all of the problems people were having with battery life, which are hopefully about to be addressed in 4.4.3 this month. My battery life has been great. I'm not a heavy user of the phone, and it normally lasts the entire day with wifi on too.

    BUT starting about a week or two ago, things changed. All of a sudden, my battery is draining down fast, and I can't tell what's the problem from the battery screen (see screenshot). I also turned off wifi, and this doesn't make a notable difference (and somehow it's still using battery). Screen, is set to "auto", and that has always been the case.

    What in the world could have changed? And from the battery monitor it doesn't look like anything unusual is sucking battery -- but look how sharp the drain is (amid periods of recharging). I would say it's gone from lasting 12+ hours to about 4-6 hours.

    Thanks!
    Attached Thumbnails Nexus 5 Battery Life okay until last week!? (4.4 holdout)-screenshot_2014-05-03-10-20-03.jpg  
    05-03-2014 10:32 AM
  2. Penguwin's Avatar
    Have you added any apps recently? How often does that weather app in your notification bar update? Sadly, we are just going to have to troubleshoot this one .

    This is just my guess, but I suspect something is updating in the background as the culprit.... Odd it doesn't show on the battery screen tho.

    Also, when you have tried it with WiFi off... What shows on its place... it's 13% ?

    Personally, I updated to 4.4.2 as soon as I got the OTA and my battery life is about the same.

    Sent from my Nexus 5 using Tapatalk
    05-03-2014 12:32 PM
  3. maverick7526's Avatar
    I got my Nexus 5 back in Dec '13. When 4.4.2 came out, I did NOT upgrade because I saw all of the problems people were having with battery life, which are hopefully about to be addressed in 4.4.3 this month. My battery life has been great. I'm not a heavy user of the phone, and it normally lasts the entire day with wifi on too.

    BUT starting about a week or two ago, things changed. All of a sudden, my battery is draining down fast, and I can't tell what's the problem from the battery screen (see screenshot). I also turned off wifi, and this doesn't make a notable difference (and somehow it's still using battery). Screen, is set to "auto", and that has always been the case.

    What in the world could have changed? And from the battery monitor it doesn't look like anything unusual is sucking battery -- but look how sharp the drain is (amid periods of recharging). I would say it's gone from lasting 12+ hours to about 4-6 hours.

    Thanks!
    Try a reboot. I don't see any in the battery graph. Sometimes my battery gets weird like that and it isn't visible on the graph. I then usually reboot, or run the battery flat. That seems to fix it.

    Posted via NSA Spy Van 37...... Free candy??
    05-03-2014 01:08 PM
  4. B. Diddy's Avatar
    If the reboot doesn't help, try clearing the system cache partition: [GUIDE] Nexus 5 Recovery

    Posted via Android Central App.
    Please excuse any typos or autocorrect derps.
    05-03-2014 06:36 PM
  5. crxssi's Avatar
    Try a reboot. I don't see any in the battery graph. Sometimes my battery gets weird like that and it isn't visible on the graph. I then usually reboot, or run the battery flat. That seems to fix it.
    Yep. The few times I have noticed something sucking the battery and can't tell what, I just reboot and it seems to go back to normal again. I rarely reboot- maybe once a month. Like Diddy said- if a reboot doesn't fix it, clear the cache partition. Haven't needed to [clear the cache partition] on the Nexus 5 (I don't think so, anyway)... but I have to do that every few weeks on the Nexus 10 for some reason, because on that machine, performance starts to get hideous for no apparent reason. And by hideous, I mean REALLY bad- tons of lag, half a minute to launch apps, etc.
    B. Diddy likes this.
    05-03-2014 06:55 PM
  6. Dperks17's Avatar
    Mine for the past 3 days I can't get 10 hours off the charger. I found out that Google play services was sucking the life out of my battery. Fixed it today and so far so good.

    Posted via Android Central App
    05-03-2014 08:47 PM
  7. jplehmann's Avatar
    Guys -- thanks for all the feedback. The reboot indeed fixed it! I rebooted about 4 days ago and am back to normal battery life. I am attaching an "after" screenshot to show the difference (ie what is "normal"). Note the slope of the line is much flatter.

    Click image for larger version. 

Name:	Screenshot_2014-05-03-20-56-11.jpg 
Views:	11 
Size:	125.2 KB 
ID:	116861
    B. Diddy and crxssi like this.
    05-07-2014 09:52 AM

Similar Threads

  1. Does battery saving apps really work?
    By Omer San Gabriel in forum Samsung Galaxy S4
    Replies: 25
    Last Post: 07-29-2016, 04:22 AM
  2. Battery Icon now White
    By utahbronco in forum Verizon Samsung Galaxy S4
    Replies: 10
    Last Post: 04-01-2015, 08:02 AM
  3. Question about how to proceed in order to try Cyanogenmod on the Nexus 4
    By Crisdean in forum Nexus 4 Rooting, ROMs, & Hacks
    Replies: 3
    Last Post: 05-05-2014, 09:27 AM
  4. IMAP / Nexus 5 email app - sync works, but doesn't refresh...
    By pablobaluba in forum General Help and How To
    Replies: 1
    Last Post: 05-04-2014, 01:32 PM
  5. Battery
    By jhenneco in forum Samsung Galaxy Tab Pro 10.1
    Replies: 3
    Last Post: 05-03-2014, 02:27 PM
LINK TO POST COPIED TO CLIPBOARD
";