1. drache713's Avatar
    Quick easy question - those of you using a Nexus 5 on AT&T, to make sure your account was correctly provisioned for LTE and the proper data speeds were you able to just have them provision your account with the actual IMEI from your Nexus 5, or did you have to give them a faux IMEI from an actual AT&T branded device? Do their systems properly recognize the Nexus 5 IMEI for LTE speeds and provisioning?
    05-03-2014 02:50 PM
  2. GlennTX's Avatar
    All I did was take my N5 into the AT&T store. They scanned the number on the back of the phone and I was out of the store in 5 mins.
    05-03-2014 05:42 PM
  3. rhea's Avatar
    Actual IMEI on gophone. LTE worked immediately. This was in November.

    Sent from my Nexus 7 using Tapatalk
    05-03-2014 05:43 PM
  4. Kage_'s Avatar
    I called att and they provisioned my phone without an issue. I had to take our other phone into att cause the Sim card was to old to provision correctly. They put a new card in and updated the account for it with no problems.

    Sent from my Nexus 5 using AC Forums mobile app
    05-03-2014 09:21 PM
  5. ChuckG73's Avatar
    Same thing I did, and worked without a hitch.
    05-04-2014 07:09 AM
  6. dan1431's Avatar
    5 minute visit to a store, employee took the IMEI off the back of the box and entered it into the compute.

    She then had me reboot my phone and presto LTE.

    Completely painless.

    Dan

    Posted via Android Central App
    05-04-2014 09:02 AM
  7. maxburn's Avatar
    I also started a GoPhone account with the actual IMEI and I am kinda wondering what happens when I get a new phone.

    I had originally asked them about APN info but they said it doesn't matter as they have the IMEI.
    05-05-2014 12:09 PM
  8. vividrich's Avatar
    No issues here either, I knew I was going to have to visit the store as my old phone had a different size sim.

    Posted from my Nexus 7 2013 via Android Central App
    05-05-2014 07:14 PM
  9. Samuel Thayer's Avatar
    I got my phone from the Play Store last year, put my at&t micro sim in and received LTE without a trip to the store. Maybe I'm special?!

    Posted via Android Central App
    05-07-2014 10:12 PM
  10. lattemaker's Avatar
    I just got my Nexus 5 today and put the sim card from my S5 into the Nexus 5 and everything has worked perfectly.

    Sent from my Nexus 7 using AC Forums mobile app
    05-08-2014 12:48 AM
  11. beanboy89's Avatar
    My Nexus 5 isn't picking up AT&T LTE. I don't think my account is provisioned to get LTE, because I was previously on a Lumia 520 (HSPA+ only) before moving to the Nexus 5. I think they have my Lumia 520 IMEI on file and don't recognize the Nexus 5 as a LTE device.
    05-08-2014 11:28 PM
  12. dan1431's Avatar
    My Nexus 5 isn't picking up AT&T LTE. I don't think my account is provisioned to get LTE, because I was previously on a Lumia 520 (HSPA+ only) before moving to the Nexus 5. I think they have my Lumia 520 IMEI on file and don't recognize the Nexus 5 as a LTE device.
    Actually I think it is more of a left brain, right brain kind of thing.

    at&t Mobility knows the IMEI of any device on their network (right brain), but that info for whatever reason does not transfer to their provisioning systems (left brain).

    You have to have at&t provision your account for LTE and you should be good to go.

    Dan

    Posted via Android Central App
    05-09-2014 10:52 AM

Similar Threads

  1. Accuweather on the home screen
    By w7sg in forum Samsung Galaxy Note 3
    Replies: 13
    Last Post: 12-01-2014, 06:42 AM
  2. Replies: 14
    Last Post: 05-14-2014, 07:08 PM
  3. Storing Music on SD Card?
    By Caleb10E in forum HTC One M8
    Replies: 13
    Last Post: 05-09-2014, 03:19 PM
  4. Can't get DashClock to work on GS5 lockscreen...
    By akutch34 in forum Samsung Galaxy S5
    Replies: 2
    Last Post: 05-03-2014, 04:05 PM
  5. photosphere on the Z2
    By robsawalker in forum Sony Xperia Z2
    Replies: 0
    Last Post: 05-03-2014, 02:00 PM
LINK TO POST COPIED TO CLIPBOARD