Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 23 of 23
  1. Thread Author  Thread Author    #1  

    Default 4.4.3 with ART runtime?

    Has anyone gotten the update or used the update with ART yet? Just wondering if there are any issues and if I should switch back before the update.

    Thanks.
  2. #2  

    Default Re: 4.4.3 with ART runtime?

    No problems for me!

    Posted via Android Central App.
    Please excuse any typos or autocorrect derps.
  3. #3  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    2,671 Posts
    Global Posts
    2,990 Global Posts

    Default Re: 4.4.3 with ART runtime?

    Mine was set to ART before the update, and still is after the update (first thing I checked). Works fine so far.... although I haven't used the phone for more than a moment so far.
  4. Thread Author  Thread Author    #4  

    Default Re: 4.4.3 with ART runtime?

    Thanks to both of you.
  5. #5  
    kd0h's Avatar

    Posts
    190 Posts
    Global Posts
    192 Global Posts

    Default Re: 4.4.3 with ART runtime?

    ART is working great for me!
  6. #6  

    Default Re: 4.4.3 with ART runtime?

    Weird. Mine reverted back to dalvik after the update. Going to switch back to art now.

    Posted via Android Central App
  7. #7  

    Default Re: 4.4.3 with ART runtime?

    I sideloaded the OTA while on ART with no issues. It remained the same after the update.
  8. #8  

    Default Re: 4.4.3 with ART runtime?

    Quote Originally Posted by ianhanson85 View Post
    Weird. Mine reverted back to dalvik after the update. Going to switch back to art now.

    Posted via Android Central App
    Mine reverted as well. It depends on how you update.

    Sent from my Nexus 5 using Tapatalk
  9. #9  
    kd0h's Avatar

    Posts
    190 Posts
    Global Posts
    192 Global Posts

    Default Re: 4.4.3 with ART runtime?

    Quote Originally Posted by ianhanson85 View Post
    Weird. Mine reverted back to dalvik after the update. Going to switch back to art now.

    Posted via Android Central App
    Did you do the OTA or flash the factory image?

    Posted via Android Central App
  10. #10  
    kd0h's Avatar

    Posts
    190 Posts
    Global Posts
    192 Global Posts

    Default Re: 4.4.3 with ART runtime?

    Quote Originally Posted by gidgiddonihah View Post
    Mine reverted as well. It depends on how you update.

    Sent from my Nexus 5 using Tapatalk
    Agreed, I flashed the factory image so it reverted back, because dalvik is still the system default.

    Posted via Android Central App
  11. #11  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    2,671 Posts
    Global Posts
    2,990 Global Posts

    Default Re: 4.4.3 with ART runtime?

    Quote Originally Posted by gidgiddonihah View Post
    Mine reverted as well. It depends on how you update.
    I was OTA update. It didn't revert back to Dalvick.
  12. #12  

    Default Re: 4.4.3 with ART runtime?

    Funny you should ask that because I'm asking if the update uses ART by default, when I was updating to 4.4.3 I noticed the last thing it did was convert my app's to ART... I've always left Android on Dalvik due to ART not ready for Android to officially use as default rt, but since it choose ART for me I figured that either it was ready for use *& could be the reason to the battery enduring 50% longer* our that all my apps are runtime capable? Idk, what I do want to know is if anyone else has had their runtime changed by Android.
  13. #13  
    Crisdean's Avatar

    Posts
    70 Posts
    Global Posts
    765 Global Posts

    Default Re: 4.4.3 with ART runtime?

    I haven't exowri need any issues and ever since Line got updated to work under ART the device is switched over and working fine.
  14. #14  

    Default Re: 4.4.3 with ART runtime?

    I posted a comment about how my N5 turned everything to ART on its own, but it was backwards I forgot that I was using ART before the 4.3 update & it turned everything back to Dalvik *thinking it was turning ART@ the time* but I just looked at my settings & it's using Dalvik... I wanted to know if you have already tried to use art? Because I've been trying & all I get is my phone restarting with Dalvik still running. I'm rooted twrp recovery with super SU for root access. I'd use to be able to switch to art without a problem but now I can't is this isolated or do you or anyone else have this problem, our better yet a solution?
    Mark Sentesy likes this.
  15. #15  

    Default Re: 4.4.3 with ART runtime?

    Quote Originally Posted by kd0h View Post
    Did you do the OTA or flash the factory image?

    Posted via Android Central App
    OTA

    Posted via Android Central App
  16. #16  

    Default Re: 4.4.3 with ART runtime?

    I tried ART and had a couple minor issues. I'm sticking with Dalvik for now. The speed difference isn't game changing.
  17. #17  

    Default Re: 4.4.3 with ART runtime?

    I personally don't understand the hype of ART. I find when running on ART, my device is a bit buggier. And sometimes, apps take a long time to open. It'll be highlighted, but the app won't actually launch for a few seconds. It just hangs there.

    Am I the only one experiencing this under ART? I've never noticed it under Davlik.
  18. #18  
    crxssi's Avatar
    Linux: The power beneath

    Posts
    2,671 Posts
    Global Posts
    2,990 Global Posts

    Default Re: 4.4.3 with ART runtime?

    Quote Originally Posted by onthecouchagain View Post
    I personally don't understand the hype of ART. I find when running on ART, my device is a bit buggier. And sometimes, apps take a long time to open. It'll be highlighted, but the app won't actually launch for a few seconds. It just hangs there.

    Am I the only one experiencing this under ART? I've never noticed it under Davlik.
    I have not had that experience.

    But I do agree that using ART is not much of a big whoop. The phone does seem a tiny bit faster and it did seem to add some to the idle/standby battery time. But I also have not found any app that doesn't work or bugs I could attribute to using ART.
  19. #19  

    Default Re: 4.4.3 with ART runtime?

    The only app that refuses to work is MLB At Bat. It crashes anytime I try to load a baseball game. What's odd is it plays replays and whatnot but can't play a game. Other than that I haven't run across any real bugs. The minor speed boost feels like it finally makes Android totally smooth. Even things like the multitasking button is much quicker.

    Sent from my Nexus 5 using Tapatalk
  20. #20  
    JeffDenver's Avatar
    Banned

    Posts
    2,924 Posts
    Global Posts
    2,945 Global Posts
    Carrier
    Perma-rooted and unlocked

    Default Re: 4.4.3 with ART runtime?

    Quote Originally Posted by Thor20003 View Post
    Has anyone gotten the update or used the update with ART yet? Just wondering if there are any issues and if I should switch back before the update. .
    No problems here. I installed it with ART active and it retained ART after the install. The only side effect is that the update will take longer with ART, because of the way ART works.
  21. #21  

    Default Re: 4.4.3 with ART runtime?

    Just started running ART myself using CyanogenMod. Will have more to add tomorrow, but currently seems to be ba bit faster than Dalvik. Not sure how that can be as this appears to be cache related, but what do I know. Time will tell.

    All my apps seem to run just fine though, time will tell.
  22. #22  

    Default Re: 4.4.3 with ART runtime?

    I have Jayq330's problem as well: I select ART, say yes, it reboots... straight back into Dalvik. No app conversion or anything.

    Nexus 4 with towelroot and SuperSU, no custom ROM or even custom recovery... (its my first time without!).
  23. #23  
    p3ntyne's Avatar

    Posts
    265 Posts
    Global Posts
    270 Global Posts

    Default Re: 4.4.3 with ART runtime?

    Quote Originally Posted by Mark Sentesy View Post
    I have Jayq330's problem as well: I select ART, say yes, it reboots... straight back into Dalvik. No app conversion or anything.

    Nexus 4 with towelroot and SuperSU, no custom ROM or even custom recovery... (its my first time without!).
    Do you use the Xposed Framework?

Similar Threads

  1. issues with kit kat staying at jellybean 4.3
    By mlbyanks11 in forum AT&T Samsung Galaxy Note 3
    Replies: 3
    Last Post: 06-11-2014, 02:33 PM
  2. What's new with 4.4.2?
    By chuckr01 in forum Samsung Galaxy Note 8.0
    Replies: 8
    Last Post: 06-08-2014, 11:43 PM
  3. I just about doubled my battery life with an app
    By dad2noah in forum Samsung Galaxy S5
    Replies: 38
    Last Post: 06-08-2014, 06:19 AM
  4. Having Hell with M8 Keyboard
    By HTC_Newbie14 in forum HTC One M8
    Replies: 14
    Last Post: 06-05-2014, 12:52 PM
  5. Replies: 0
    Last Post: 06-04-2014, 08:15 PM

Posting Permissions