1. AC Question's Avatar
    Yesterday the screen on my Nexus 5 stopped working (same thing happened to my wife's right after the 5.1.1 update) and the only solution was to do a factory reset. I've got all my apps updated now, and I want to see the pictures I had taken before the reset. I had auto-backup enabled in Photos, but now when I run it it wants me to sign in (as I would expect), so I hit Sign In and it says Checking info for a few seconds before I get a screen saying "Add your account." I type in my email address and hit NEXT, but it says "This account already exists on your device."
    06-03-2015 11:15 AM
  2. B. Diddy's Avatar
    Welcome to Android Central! What does the Add Your Account screen look like? Does it look like part of the Photos app, or part of the system (i.e., is it taking you to the Settings>Accounts>Add Account menu)? Can you show us a few screenshots of that process? http://forums.androidcentral.com/amb...d-central.html

    In the meantime, go to Settings>Accounts-Google>[your Google account], and make sure Google Photos is checked on.
  3. B. Diddy's Avatar
    Welcome to Android Central! What does the Add Your Account screen look like? Does it look like part of the Photos app, or part of the system (i.e., is it taking you to the Settings>Accounts>Add Account menu)? Can you show us a few screenshots of that process? http://forums.androidcentral.com/amb...d-central.html

    In the meantime, go to Settings>Accounts-Google>[your Google account], and make sure Google Photos is checked on.
    06-03-2015 12:23 PM
  4. timousine's Avatar
    The forum wouldn't let me upload my pictures, said I can't post links because I have fewer than ten posts. I've tried everything I can think of but it won't let me post my screenshots.
    06-03-2015 04:44 PM
  5. timousine's Avatar
    It's different from the Settings -> Accounts -> Add Account screen. I go to the Photos app and see this:

    http://www.timousine.com/screenshots/1.png

    I hit GET STARTED and get this:

    http://www.timousine.com/screenshots/2.png

    So I hit SIGN IN. It does this for a couple seconds:

    http://www.timousine.com/screenshots/3.png

    Then goes to this screen:

    http://www.timousine.com/screenshots/4.png

    I enter my email address and hit NEXT but I get this:

    [redacted by Mod]

    Settings -> Accounts -> Google -> [email removed] doesn't have Google Photos as an option to check.

    Thanks for your help!
    06-03-2015 04:49 PM
  6. B. Diddy's Avatar
    FYI, I redacted that last image link, since that image contained your actual email address. For others looking at this thread, it showed the OP's Gmail address entered into the sign-in account field, and a message underneath it saying "This account already exists on your device."

    Go to Settings>Apps>All, select Photos, and Clear Cache/Clear Data, then Force Stop. Now try again.

    I know you just recently did a factory reset, but if the above doesn't work, then go to Settings>Accounts, and remove your Google account. Now add it back again, and try Google Photos again.
    BMukherjee91 likes this.
    06-03-2015 05:45 PM
  7. timousine's Avatar
    That fixed it, thank you so much!
    B. Diddy likes this.
    06-03-2015 06:09 PM
  8. B. Diddy's Avatar
    Great! Which suggestion was the one that fixed it?
    06-03-2015 09:37 PM
  9. bulletmark's Avatar
    I had this problem on my daughter's Nexus 4. It had 2 "Photos" apps on it. I cleared the cache on both, forced stop, disabled 1 app, then restarted. Then enabled app again then did play store update of the new Photos app, then it worked.
    06-04-2015 07:54 AM
  10. BMukherjee91's Avatar
    Great! Which suggestion was the one that fixed it?
    B - I had the same issue after upgrading the Photos app. Guess, if you were using the older version, you have to clear cache once, before it can synch. up your active Google ID. Thanks.
    B. Diddy likes this.
    06-04-2015 08:48 PM
  11. bulletmark's Avatar
    Actually, further to my post above. I also later experienced this on my wife's Nexus 5. I just stopped both Photo apps, cleared the cache (of the one that offered this option), and then entered the Photo app again and the problem was fixed. Seems like this is a very generic bug.
    06-04-2015 10:21 PM
  12. GoBosSox's Avatar
    I'm still having this same problem after upgrading to Android Lollipop on my Droid Turbo. I've disabled and restarted both the Photo apps, tried reinstalling google photo from the App Store, and I've deleted and reinstalled my google account on my phone. I've also tired "Settings -> Accounts -> Google ->[My account]" but there isn't Google Photos as an option to check.
    07-08-2015 01:17 PM
  13. Rassilon7's Avatar
    I have the same problem, tried these solutions but it did not work for me. LG G4
    07-08-2015 08:53 PM
  14. Jason Molter's Avatar
    Same problem. Just got a new Galaxy S6 and trying to open Photos which I've used all along, getting "this account already exists on your device" after going through the Sign In step and entering my email. I've tried uninstalling/reinstalling. Have tried removing my Google account on the device. Have even tried factory reset. Making matters worse, I went back to my Galaxy S4 where the app was still working, and uninstalled and tried reinstall, and now same problem on that device. This is maddening! I need access to my Photos (thousands and thousands there!) - yes, I can still get them through web browser, but app won't work, and usually only have my phone.
    07-08-2015 09:28 PM
  15. William Lester's Avatar
    Let me in my google photos an deleted photos
    04-16-2017 01:20 PM

Similar Threads

  1. Replies: 1
    Last Post: 01-08-2016, 12:01 AM
  2. Replies: 1
    Last Post: 06-03-2015, 11:30 AM
  3. How can I get rid of the Jack icon in status bar (not headphone icon)?
    By AC Question in forum General Help and How To
    Replies: 1
    Last Post: 06-03-2015, 11:20 AM
  4. Do I need to extract files for superuser.zip onto my Android phone?
    By AC Question in forum General Help and How To
    Replies: 0
    Last Post: 06-03-2015, 10:59 AM
  5. How to obtain permission to remove apps from a play tab
    By AC Question in forum Ask a Question
    Replies: 1
    Last Post: 06-03-2015, 10:50 AM
LINK TO POST COPIED TO CLIPBOARD