Hi there,

I'm not new to rooting and flashing devices, but something went wrong during my last root. I was using CWM to root the most recent paranoid android rom, a 4.4 rom, and after I rebooted, the device started normal and works fine. However, it's completely lost root AND has no recovery. Just the little opened up android guy with his red triangle.

I've tried using the toolkit, but the ADB drivers just are not being recognized. I've tried all of the driver options, and it says that it worked, but when I run the driver test it says failed. When I connect the device as MTP, it shows up as having recognized the device, but I can't actually access the device from the computer. When I try fastboot, nothing happens. The device just goes black and sits like that until I hold the power button down for awhile.

So, the toolkit can't get me back to stock, at least not any way I've tried. And since I can't install a recovery, I can't flash a new rom or stock.

I guess it could be worse, as the device does still work, but I want it fully functional.

Does anyone have any solutions?

Hopefully this is the right place to ask this question.

Thanks in advanced!