12-19-2014 06:40 PM
123 ... 345
tools
  1. Theo Stylianou's Avatar
    the nexus7 back is not replaceable
    01-05-2013 04:11 PM
  2. russbrad's Avatar
    My nexus locked up presses the on switch as suggested and it came back on after 20 seconds or so and now works fine,did notice before it locked up it had got a bit warm whilst charging let it cool down and reset. Had a kindle with the same problem once and used same procedure
    01-10-2013 08:09 PM
  3. Miguel Monroy's Avatar
    God bless you!!!
    01-15-2013 11:21 AM
  4. Chrisnewton's Avatar
    Didn't read up till know that many were having the same issue but seems like whenever I charge up my N7 it will not boot up but with only a 30 sec hold on the power button. Can't remember if its each and every time as its still relatively new with only a few charges done but think I've done it for the most part after each charge.
    Exactly the same as mine, only fully charged it 3 times but after every full charge I have to hold power down for 20 odd seconds, did yours fix itself?

    Sent from my Nexus 7 using Tapatalk HD
    01-15-2013 12:48 PM
  5. Starashes's Avatar
    Thank you for the info!!! I just bought my daughter the nexus 7 2 weeks ago and it just stopped working a few days ago. I popped the back off with my finger nails and lo and behold the battery cable was loose! I pushed it back on and it started right up and is charging while on! YAY and thank you!!!!
    Alida
    01-19-2013 04:27 PM
  6. makweb's Avatar
    George than you thank you thank you
    01-26-2013 12:23 PM
  7. Gemma Smith1's Avatar
    I've only had my Nexus 7 for a couple of weeks and could have cried my eyes out when it suddenly went dead and would not turn on again. Luckily, I sought help from this forum which solved the problem.
    Knowing that I had enough battery life before my nexus turned off, I tried several different combinations with the power key, power and volume up, volume down etc..... but nothing worked. I then read the entry about removing the back cover and disconnecting, then reconnecting the battery. I was a little worried about doing this but through pure frustration I took the advice. I popped off the rear case which was easy, I even managed it with just my nails, no tools required. Then I did nothing because I had no idea what was what inside so I popped the case back on, pressed the on / off button again and my nexus turned on as normal as if nothing was wrong. Only data which appears to be missing is my calendar but I'd backed it up via cloud so it can easily be retrieved.

    I hope this helps and prevents anyone else from nearly having a heart-attack and melt down as I did.
    01-30-2013 03:33 AM
  8. LBickford's Avatar
    This just happened to me this morning. I've plugged it into 3 different chargers, and several outlets. The chargers get warm, but no light of any type on the tablet, and will not power on. It was fine when I used it last night, and I have had no other issues.

    Any suggestions? I've only had it one month.

    Thank you.
    01-30-2013 09:20 AM
  9. LBickford's Avatar
    I did just see the messages about popping the back off. HOW???? I can't find a place to even try to slide a piece of paper, let alone get a fingernail in there!!!!
    01-30-2013 09:24 AM
  10. mr_nobody's Avatar
    I did just see the messages about popping the back off. HOW???? I can't find a place to even try to slide a piece of paper, let alone get a fingernail in there!!!!
    Between the silver part and the back. Instead of fingernails you can use a plastic separation tool, a guitar pick or if you don't care about your warranty, a screwdriver...
    01-30-2013 10:48 AM
  11. mzdinks's Avatar
    The solution is actually very simple,
    just hold the power button for about 30 seconds.... and it will boot.
    TRY IT BEFORE CALLING GOOGLE


    Thanks so much for this simple fix George. I've only had my tablet for a couple of months and being more tech friendly than tech comfy I was about to wail and moan and tear my heart out.
    02-03-2013 01:23 PM
  12. Mrs R's Avatar
    Can someone please help, my daughters nexus has suddenly stopped. Was working fine this morning, now wont even switch on. We have tried the hold button down for 20secs. Doesn't work.. Tried charging it still doesn't work.. Any ideas. Daughter is gutted
    02-09-2013 02:19 PM
  13. ms cc's Avatar
    Thanks everyone..held the button down for thirty min and it rebooted..awesome
    02-12-2013 10:29 PM
  14. abbie456's Avatar
    hi!
    the problem is that tablets are super easy to get virused so you must get a software to protect it.that is why apple IPADs are very expensive. they have the software already on it. It is now practiccly worthless so you should bring it back to where ever you got it. if they didnt tell you of the software you are allowed to do so. stick with shops like PC world and such as they would have the software on sale. the same thing happenend to me but i got a refund and a new tablet

    quoting a person from PC world

    hope that helps
    03-24-2013 04:47 AM
  15. david bass1's Avatar
    hello your answer was correct and the best solution. it worked for me .
    06-12-2013 12:47 PM
  16. Remus65's Avatar
    Many thanks! It works indeed!
    The solution is actually very simple,
    just hold the power button for about 30 seconds.... and it will boot.
    TRY IT BEFORE CALLING GOOGLE
    07-30-2013 02:12 AM
  17. k9destroyer's Avatar
    thanks man, i forgot about hard reboot, i was almost in teers because id had my nexus 4 for about 4 days and i was trying to root it and it froze so i unplugged it and it wouldnt turn on so i went on the internet to see iof i could fix it and here i am, your amazing
    08-17-2013 02:12 PM
  18. michymonroe's Avatar
    lastnight my phone was on the charger and out of NOWHERE it just randomly shut off...let me give you the back story
    in june my phone stopped working so i took it t sprint, i only had it for a year and a half and they took apart my phone and told me the insides were shot, i got a refurbished phone about 3 weeks later, then 2 weeks after i got it something was wrong and it wasnt charging, sprint told me that the phone they gave me broke but i bought a new charger for it and it worked fine, now just last night it was charging, and i was videochatting a friend when the screen went to the battery sigh with " ! " that in the middle......i pressed the poewe button and the volume button, i took out the battery and everything!!!! i let it sit overnight and now nothing!!!!! what should i do!
    08-25-2013 09:06 AM
  19. lisa sinclair's Avatar
    can any 1 help me pls my tablet is fully charged but wont turn i tryed every thing but nothing works can any 1 help me
    09-06-2013 09:19 AM
  20. codiac06's Avatar
    Thank you George, this worked for me too and brightened my Saturday morning up.
    09-28-2013 11:17 AM
  21. Humberto Barreto's Avatar
    George Davis for Prez! Loving the 30 second fix. Almost about to pry the back off when I saw that helpful tip.
    12-17-2013 03:20 PM
  22. Raza Abbas's Avatar
    i am having a same issue and i tried everything pressing power button for 60sec , holding power button + vol don or power button + vol + but it's not opening i carge my mobile but it just showing google for 2-3 seconds :/
    02-24-2014 06:28 AM
  23. cupcake_99's Avatar
    I Do Not Know What To Do , Because My Samsung Galaxy Nexus Wont Turn On At All.. HELP
    12-19-2014 06:40 PM
123 ... 345
LINK TO POST COPIED TO CLIPBOARD