03-23-2016 01:49 PM
34 12
tools
  1. Susan Marley's Avatar
    This worked great on my Nexus 10. Thank you
    05-26-2014 07:48 AM
  2. Tra Tal's Avatar
    did you ever find a solution to your problem?
    11-26-2014 02:52 PM
  3. Derica Thomas's Avatar
    Had to perform the battery disconnect on my unit. 20 second button hold would produce some screen flickers but the unit would never boot up.
    How did you get the back off the tablet
    12-23-2014 11:30 AM
  4. XaRz's Avatar
    I've the same problem as fjag2000

    I've replaced the screen on my nexus 2012 and now I can't get the screen starting up,only a black screen, but I hear the notifications sounds and all the stuff. The weird thing is that the old native screen doesn't work either and all the connectors all well placed and in good conditions.

    Seems like pluging in another screen, has trigged a state or something in the nexus... Any sugestions?

    PS:I've tried all posted here, thanks in advance.
    01-04-2015 06:26 AM
  5. d.k2's Avatar
    Its totally battery connector issue just open it and detached the battery connector and wash it with petrol or thinner and attach again properly.
    I hope your problem will be solved.
    01-07-2015 12:50 PM
  6. Marc Bennett's Avatar
    Wow! This ^ a thousand times! Thank you, Don Steve Evergreen. So, on occasion I've had trouble with red borders and seemingly fugitive layers of color (always red), which I've fixed several times on my Nexus 7 Wifi by disabling "strict mode" in developer options. Several times because I've flashed a few times for various reasons. This latest instance, however, it happened shortly after having installed (by coincidence alone) Cyanogenmod (which was laggy), but after I couldn't figure out what was going on with my screen and endless searching I reinstalled (after many problems) stock kitkat 4.4.4. The screen was still a mess and disabling strict mode still didn't work. Finally I found you comment, and it was exactly what my tablet needed. I don't know why I had such a one track mind, but these are indeed physical machines. So, I followed your advice and popped off the back, made sure everything was connected properly, tightened some screws, and it's perfect again. Thank you!
    02-08-2015 12:57 AM
  7. chandhini syed's Avatar
    yo!!!!!!! its damn so easy

    put it in charge and count to 20
    04-11-2015 03:15 AM
  8. taug13's Avatar
    my N7 2013 work 100% OK but the screen is always black and i cant get it to turn on and i dont know id the screen is brocken or it just wont respond to a button press but i know the tablet still works just fine because my alarm goes off evry morning and i still get noifications

    and i cant get the screen to turn on
    03-23-2016 01:28 PM
  9. taug13's Avatar
    nevermid i figured it out

    i removed the back cover and the cable that connected power to the screen was unplugged from being dropped

    and i just snapped it back into place and NOW IT WORKS !!!
    03-23-2016 01:49 PM
34 12

Similar Threads

  1. [FIX]Black screen with custom recovery and custom roms
    By bigsupersquid in forum Optimus V Rooting, ROMs, and Hacks
    Replies: 265
    Last Post: 02-02-2017, 06:54 AM
  2. Black screen on clockworkmod bootup
    By Arkaneus in forum Virgin Mobile Optimus V
    Replies: 8
    Last Post: 03-17-2012, 09:11 PM
  3. rom manager and recently built optimus v, black screen on boot
    By bigsupersquid in forum Optimus V Rooting, ROMs, and Hacks
    Replies: 12
    Last Post: 11-19-2011, 02:57 PM
  4. Adding or removing home screens on Nexus
    By lamimada in forum T-Mobile Nexus S
    Replies: 1
    Last Post: 10-21-2011, 08:38 AM
  5. Black screen on home screen
    By dbmorris99 in forum Motorola Droid 2
    Replies: 0
    Last Post: 09-14-2011, 11:42 PM
LINK TO POST COPIED TO CLIPBOARD