1. Sauceboy25's Avatar
    I posted awhile back about the lag problems I've had with the Nexus 7 16GB- original batch from pre-order.

    In a nutshell, the device starts to lag horribly - taking 10 seconds+ to render a webpage, 20+ seconds to start up Facebook. These problems were "fixed" by doing a factory reset, which obviously requires re-installing all the apps and losing app data such as saved games, etc. But the lag would be fixed, at least for a few weeks.

    Now, it seems, it turns out that I'm not the only one - the lag appears to be linked to the NAND memory and usage past a certain point - usually about 3GB free or less and you run into it. That said, others have had it appear with more memory available, as well as on both stock and custom ROM configs. The upshot appears to be some kind of problem with JB 4.1.1 that doesn't handle memory well, at least this particular memory chip. The only bright side is that Google appears to be aware of the problem and is looking into it.

    More below at XDA - they have an extensive discussion of the problem. Some progress has been made but it requires considerable hacking (at least to a noob like me).

    the LAG thread --__-- - xda-developers
    09-24-2012 09:38 AM
  2. 1812dave's Avatar
    mine lagged really badly too, and a reset fixed it so that it's once again blisteringly fast.
    09-24-2012 10:27 AM
  3. striders's Avatar
    mine lagged really badly too, and a reset fixed it so that it's once again blisteringly fast.
    I have done this, but 1-2 weeks later, the lag happened. So this is not a good solution.

    This issue is widely discussed on the Internet and I have tried everything that was suggested:
    - Disable Google Current
    - Maintain more than 5GB of available space
    - Hard reset, unroot, clear dalvik, etc..etc..
    10-04-2012 01:34 PM
  4. Eduardo06sp's Avatar
    I am running stock OS and clearing memory before it gets close to zero is helpful. Also, tried turning off the animations, it works (from developer settings). One other thing, please find and turn off all of Google Location Services.

    Sent from my Nexus 7 using Android Central Forums
    10-05-2012 01:04 AM
  5. striders's Avatar
    I am running stock OS and clearing memory before it gets close to zero is helpful. Also, tried turning off the animations, it works (from developer settings). One other thing, please find and turn off all of Google Location Services.

    Sent from my Nexus 7 using Android Central Forums
    You mean the Windows Animation? I got that turned off.

    For Google Location Service, I can't turn that off because that'll kill Google Now.
    Eduardo06sp likes this.
    10-05-2012 02:37 AM
  6. Eduardo06sp's Avatar
    You mean the Windows Animation? I got that turned off.

    For Google Location Service, I can't turn that off because that'll kill Google Now.
    Yes, windows animations. Fortunately, I turned Google services off before I fell in love with Google Now. You can also try clearing the cache of your apps you use the most.

    Sent from my Nexus 7 using Android Central Forums
    10-05-2012 07:17 PM
  7. 1812dave's Avatar
    Animations and location services don't impact speed on either of my n7s

    Sent from my Nexus 7 using Android Central Forums
    10-05-2012 07:44 PM

Similar Threads

  1. Nexus 7 lag problems
    By Sauceboy25 in forum Google Nexus 7 Tablet (2012)
    Replies: 6
    Last Post: 08-18-2012, 12:57 PM
  2. Zero Lag native to ICS not Galaxy Nexus?
    By geronimo51 in forum General Help and How To
    Replies: 5
    Last Post: 11-01-2011, 10:12 PM
  3. Sprint HTC Hero Ring Lag
    By ReproOne in forum HTC Hero
    Replies: 12
    Last Post: 01-17-2010, 04:59 PM
  4. Nexus One: T-Mobile Partners with Google
    By ERDude in forum Google / HTC Nexus One
    Replies: 9
    Last Post: 12-20-2009, 01:35 PM
  5. "Ring Lag" and what to do about it
    By Fabrian in forum HTC Hero
    Replies: 7
    Last Post: 11-19-2009, 05:12 PM
LINK TO POST COPIED TO CLIPBOARD