Results 1 to 11 of 11
  1. Thread Author  Thread Author    #1  

    Default how do i manually update to 4.2 and use ADB fastboot on windows 8

    I have used ADB in the past and it has worked just fine. however, I am now using windows 8 so things are a little different. I was using the ADB fastboot/manual update method and steps found on Android police. The problem is, some steps are impossible to finish because windows 8 looks a little different. The part I got stuck on was:



    The part I get stuck on is where it says to select "path" under Environmental Variables. This option no longer exists in windows 8. It is simply not there. When I choose Environmental Variables there is no "path" to choose from like I see in the screen shot in the guide. This left me kind of stumped. I really want to install Android 4.2 on my Nexus 7 manually. Reason I prefer not to wait, 4.1.2 hit my Nexus device OTA twenty two days after it first began rolling out. I was even clearing the Google Services Framework a few times a day to get it to force update to no avail. I don't want to wait again, I am a junky. So that having been said, does anyone know of or have a step by step guide to getting ADB Fastboot working on Windows 8 using the Android SDK? Let me know if you have any information. Thanks.
  2. #2  
    MowDownJoe's Avatar
    Regular lawnmower man...

    Posts
    440 Posts
    ROM
    Stock

    Default Re: how do i manually update to 4.2 and use ADB fastboot on windows 8

    I was under the impression that there were no ADB drivers for Windows 8 yet.
  3. Thread Author  Thread Author    #3  

    Default Re: how do i manually update to 4.2 and use ADB fastboot on windows 8

    Oh is that the case? Crap. Okay I will have to find another computer to use I suppose.
  4. #4  

    Default Re: how do i manually update to 4.2 and use ADB fastboot on windows 8

    Boot from a Fedora Core liveCD or live-usb, download SDK, run adb. Solved. adb seems to run much better and easier under Linux anyway.

    /me sideloading the update as I type....
    Sent by accident, not using the Android Central app
    Nexus 4 (Mako), Amaze 4G on T-Mobile. Nexus 7 16GB. Google Chromebook (2012 Samsung 16gb). Next stop, a Google flush toilet.
    Did I solve your problem? Hit the Thanks button. Was I just a nuisance? Sorry, can't bat .400 every day.
  5. #5  

    Default Re: how do i manually update to 4.2 and use ADB fastboot on windows 8

    I went to Androidpolice.com and followed the directions. I have a faux start button on my Windows 8 called "classic shell". I was able to get to Environmental Variables. What I got stuck on is that the driver for my Nexus would read as installed. I would test it with ADB, and then the driver wouldn't work any more. I could never get to the update part without the Nexus not being read. Very frustrating. I would go back to the device manager to try and update the driver and it would say not installed. I would go back to the file to install it and it would not work. Windows 8 is the devil.
  6. #6  
    AidenSurvival's Avatar

    Posts
    51 Posts
    Global Posts
    379 Global Posts
    ROM
    Jelly Bean

    Default Re: how do i manually update to 4.2 and use ADB fastboot on windows 8

    Quote Originally Posted by MowDownJoe View Post
    I was under the impression that there were no ADB drivers for Windows 8 yet.
    I'm pretty sure to use was in a compatible with Windows 7, it. should work in Windows 8

    This is from experiencing as I already tried using adb and fast boot commands in W8.

    Edit: Google Voice does not transcribe my message very well.

    What I meant to say is adb should work in Windows 8
    Sent from my Nexus 7 using Android Central Forums.
  7. #7  

    Default Re: how do i manually update to 4.2 and use ADB fastboot on windows 8

    I also have windows 8 and in adb the device is not found. 8 doesn't seem to want to let me install drivers.
  8. #8  
    wvcadle's Avatar

    Posts
    47 Posts
    ROM
    GB 2.3.5

    Default Re: how do i manually update to 4.2 and use ADB fastboot on windows 8

    Hello. I have followed QBK77's videos on installing the sbk tools, downloading the 4.2 zip etc. I'm pretty familiar with android/rooting/etc., but I'm stuck on something.

    After rebooting into recovery (via cmd prompt opened in folder of zip, and typing 'adb reboot recovery'), I hit the vol up key and power, and get to the screen where i can send the package, but upon typing in adb sideload 'filename.zip', I get the following: error: device not found. I have verified that it recognizes my device via the cmd prompt (adb devices), and it displays my nexus 7, but as soon as I press vol up and power, i can hear the device manager in win7 losing the driver.

    What am I doing wrong here? I have stock 4.1.2 rooted.

    Thanks.
    Nexus 4 - JB 4.2.1
    Nexus 7 - JB 4.2.1
    Android enthusiast
  9. #9  

    Default Re: how do i manually update to 4.2 and use ADB fastboot on windows 8

    OK, I got it. Bear with me

    So if you have the Android SDK downloaded and in the correct place, do this.

    CMD prompt
    adb devices (do this to make sure it recognizes it)
    adb reboot recovery
    Go to the option for update with ADB or whatever it was.

    At this point, ADB may not recognize device any more. Open device manager, find Nexus 7, open up, and update driver. Choose to browse computer, and select the bottom option on that screen (I think it's "Select from pre loaded drivers.
    Select Android phone, and the ADB option and install. Windows will say something to the effect of it doesn't recommend you doing this, but flip it the bird and do it anyway.

    Once you have done that, go back to CMD and type adb devices. You should be recognized now.

    I figured this out with the help of Qbk77 video. Amazing helpful reference

    Sorry for the poor explanation. I am doing from memory.
  10. #10  

    Default Re: how do i manually update to 4.2 and use ADB fastboot on windows 8

    ok it recognizes the nexus 7 but now "adb sideload 094f6629314a.signed-nakasi-JOP40C-from-JZO54K.094f6629.zip" still doesn't work. I get a list of all the commands that can be used with adb but sideload isn't one of the commands.
  11. #11  

    Default Re: how do i manually update to 4.2 and use ADB fastboot on windows 8

    worked perfectly on my nexus 4. thanks for the info. v4.2.2

Similar Threads

  1. HOWTO Manual update to 4.0.2 using factory imgs, w/o wiping phone
    By Alex Dobie in forum Google / Samsung Galaxy Nexus
    Replies: 18
    Last Post: 12-09-2012, 11:33 AM
  2. Replies: 2
    Last Post: 09-29-2011, 06:55 PM
  3. Do I have to do a manual update, then root? Or root, then update?
    By The Miz in forum Sprint Nexus S 4G Rooting, ROMs, and Hacks
    Replies: 20
    Last Post: 08-01-2011, 03:35 AM
  4. Replies: 2
    Last Post: 04-26-2011, 01:08 PM
  5. How to manual update to stock 3.29.651.5
    By sveilien in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 3
    Last Post: 10-06-2010, 12:15 PM

Posting Permissions

B