1. aarora610's Avatar
    Hi gang,

    Having an issue. On my 32GB nexus 7, I am running 4.1.1. When I check for an update, it says I have the latest version. I followed the advice re: force stopping the google framework (or something like that).... it then says that 4.1.2 is available for installation. When it reboots during the install, I get the



    It doesn't go forward from there. I then have to hold the power and restart and then it brings me back to 4.1.1.


    Not sure what to do...
    Matthias Lang likes this.
    11-20-2012 04:25 PM
  2. carracerz14's Avatar
    Sounds to me that 4.1.2 wasn't fully downloaded. I had the same issue on my droid x I had to go in a re download it

    Sent from my RAZR MAXXIMUS
    11-20-2012 04:46 PM
  3. wagonis's Avatar
    Have you done ANY custom work to your N7? Edited anything? Changed anything from stock?
    11-20-2012 04:48 PM
  4. aarora610's Avatar
    Nothing at all. And I tried to update twice. Was bought brand new from the store.
    11-20-2012 04:53 PM
  5. carracerz14's Avatar
    Meh. I would just download the update and flash it yourself

    Sent from my RAZR MAXXIMUS
    11-20-2012 05:12 PM
  6. aarora610's Avatar
    Meh. I would just download the update and flash it yourself

    Sent from my RAZR MAXXIMUS
    How do I do that.
    11-20-2012 05:22 PM
  7. B. Diddy's Avatar
    When it gets to the Android with the red exclamation point, try pressing and holding the power button and then tapping the volume up button once. That should bring up options for the recovery menu. Not sure if there is an option then to install.
    11-20-2012 06:03 PM
  8. carracerz14's Avatar
    It should install automatically it shouldn't go to the recovery. Some things not right. It's strange you haven't gotten the 4.1.2 update yet

    Sent from my RAZR MAXXIMUS
    11-20-2012 06:08 PM
  9. B. Diddy's Avatar
    Might have to do a factory reset.
    11-20-2012 06:11 PM
  10. carracerz14's Avatar
    Yeah. As soon as I first powered up my tablet I got the Window telling me it was ready to update

    Sent from my RAZR MAXXIMUS
    11-20-2012 06:15 PM
  11. aarora610's Avatar
    Driving me nuts.. did a factory reset and still doesn't check for 4.2
    11-20-2012 07:48 PM
  12. B. Diddy's Avatar
    Ok, here's another silly sounding trick that worked for my old Droid Incredible. Manually set your date to several years ago, like 2000. It might fool the system into thinking it is way out of date, and thus trigger the update. No idea if this trick works for the Nexus 7, but it's worth a try.
    11-20-2012 08:00 PM
  13. aarora610's Avatar
    that does work.. but every single time it tries to install on the reboot, I get the red exclamation.
    11-20-2012 08:06 PM
  14. carracerz14's Avatar
    At this point I don't know what else to suggest as I don't know why it is getting stuck. The Android with the red exclamation is the screen you get before you boot into stock recovery. There is no reason it should be going there.

    The only time that happened for me was on my droid x and the update didn't fully download. Make sure your connection is good.

    Other than that I would use either wugs toolkit or fastboot commands to take your tablet back to bone stock(even further than a factory reset will) wugs is easier for some people buy I prefer the fastboot way, I will find you a link to instructions.

    Sent from my RAZR MAXXIMUS
    11-20-2012 08:12 PM
  15. B. Diddy's Avatar
    Weird. Did you try holding the power the button and then tapping the volume up button once when you see the red exclamation, as I mentioned above?
    11-20-2012 08:13 PM
  16. aarora610's Avatar
    Yes but I didn't know what to do from there? Install from adb?
    11-20-2012 08:18 PM
  17. MJKearney's Avatar
    Have you thought about contacting Google support?

    This link lets you either email them or request a call back: http://support.google.com/googleplay...cy&policy=apps

    Or call Google support. This is the US phone number: 855-836-3987. Check their website for the local number if you are outside the US.
    11-20-2012 08:30 PM
  18. carracerz14's Avatar
    http://www.androidpolice.com/2012/10...stom-recovery/

    Here you go brother, I would go this route. You're probably gonna need the android sdk to get the proper adb and fastboot files but there is a link to download it within the post

    Sent from my RAZR MAXXIMUS
    B. Diddy likes this.
    11-20-2012 08:30 PM
  19. B. Diddy's Avatar
    Here's another link that might be helpful. Perhaps you could just sideload 4.1.2.

    Pocketables How to manually update your Nexus 7 to Android 4.1.2

    Whoops. carracerz was too fast and beat me to it.
    carracerz14 likes this.
    11-20-2012 08:35 PM
  20. aarora610's Avatar
    Still no luck. Tried to sideload to no avail. I think it could be because of my build JRO030S

    Sent from my Nexus 7 using Tapatalk 2
    11-21-2012 08:54 PM
  21. aarora610's Avatar
    I got in over my head, and thanks to this.. I'm all set. it did change the build number to JOP40C (not sure if that's ok), but I'm now running 4.2 and everything seems ok
    11-22-2012 08:56 AM
  22. Matthias Lang's Avatar
    Hi,
    I've got exactly the same problem with the same tablet.
    My English is not very good, so may you please explain how you eventually fixed your Nexus 7, please?
    Have you changed the build-number by yourself?
    Matthias

    I got in over my head, and thanks to this.. I'm all set. it did change the build number to JOP40C (not sure if that's ok), but I'm now running 4.2 and everything seems ok
    11-23-2012 05:39 PM
  23. Curumo's Avatar
    I have the same problem too. TS it would be great if you could share in detail how you solved this problem.
    12-02-2012 01:39 AM
  24. aarora610's Avatar
    Search for something called the Google nexus toolkit. That should solve your issues.

    Sent from my Nexus 7 using Tapatalk 2
    12-02-2012 07:22 PM

Similar Threads

  1. possibility of later update to Android 3.0?
    By Alp in forum HTC Desire HD
    Replies: 8
    Last Post: 03-04-2011, 09:44 AM
  2. Can't connect to android history from incredible
    By eazid in forum Verizon Droid Incredible
    Replies: 6
    Last Post: 09-20-2010, 07:45 AM
  3. How can I update to 2.2 with Unrevoked3 installed?
    By sammy123 in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 18
    Last Post: 08-17-2010, 04:45 PM
  4. Can't update to froyo/update maps, facebook on moto droid (unrooted)
    By ebj in forum Motorola Droid Rooting, ROMs and Hacks
    Replies: 6
    Last Post: 08-15-2010, 10:24 PM
  5. Can't login to Android Market!!
    By whiskieman in forum Google / HTC Nexus One
    Replies: 2
    Last Post: 08-01-2010, 05:16 PM
LINK TO POST COPIED TO CLIPBOARD