Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Results 1 to 12 of 12
Like Tree2Likes
  • 1 Post By Mikesnexus
  • 1 Post By Eduardo06sp
  1. Thread Author  Thread Author    #1  

    Default Gmail "All Mail " folder issue

    Gmail app shows one unread email in the all mail folder on my N7. But there are no unread emails in any folder. Tried clear cache. Clear data. No avail.
    Any suggestions?

    Sent from my Nexus 7 using Tapatalk 2
  2. #2  

    Default Re: Gmail "All Mail " folder issue

    Keep looking, it's in there somewhere. I had the same thing. Finally found the little bugger way down the list. It might be easier doing this from your desktop or laptop browser.
    Thanked by:
  3. Thread Author  Thread Author    #3  

    Default Re: Gmail "All Mail " folder issue

    OK. I feel stupid now. Lesson learned to scroll before posting! Sucker was way down in my inbox.


    Sent from my Nexus 7 using Tapatalk 2
    MJKearney likes this.
  4. #4  
    goofysam's Avatar

    Posts
    19 Posts
    Global Posts
    22 Global Posts

    Default Re: Gmail "All Mail " folder issue

    Next time search for "is:unread"

    Sent from my HTC Sensation 4G using Android Central Forums
    Thanked by 3:
  5. #5  

    Default Re: Gmail "All Mail " folder issue

    I've had a slightly different "all mail" folder issue--it only shows messages one month old and older, even though there are far newer e-mails in my inbox. Any idea how to fix that?
  6. #6  

    Default Re: Gmail "All Mail " folder issue

    Quote Originally Posted by mlipkin View Post
    I've had a slightly different "all mail" folder issue--it only shows messages one month old and older, even though there are far newer e-mails in my inbox. Any idea how to fix that?
    Sounds like it's not syncing. Go to Settings > Accounts > Google. Tap on the Google account you're having trouble with, then scroll down to Gmail and make sure the box to the right is checked.
  7. #7  

    Default Re: Gmail "All Mail " folder issue

    Quote Originally Posted by mlipkin View Post
    I've had a slightly different "all mail" folder issue--it only shows messages one month old and older, even though there are far newer e-mails in my inbox. Any idea how to fix that?
    Try only syncing mail from the past few days.
    [Spoiler]1. Open Gmail.
    2. Click the three dots at the top-right corner.
    3. Tap on 'Settings'.
    4. Tap on your email address.
    5. The third option from the bottom should say 'Days of mail to sync'.
    6. Tap on the option.
    7. Tap on the number, and a number-pad will come up.

    You solved the problem in seven easy steps! [/spoiler]

    Sent from my Nexus 7 using Android Central Forums
    Thanked by:
  8. #8  

    Default Re: Gmail "All Mail " folder issue

    MJKearney: I tried that, but the app has been sync in just fine in all the other mailboxes, and just not All Mail

    Eduardo06sp: I tried both increasing and decreasing that number but I still don't have anything newer than October 15
  9. #9  

    Default Re: Gmail "All Mail " folder issue

    Quote Originally Posted by mlipkin View Post
    MJKearney: I tried that, but the app has been sync in just fine in all the other mailboxes, and just not All Mail
    Eduardo06sp: I tried both increasing and decreasing that number but I still don't have anything newer than October 15
    In the Gmail three dot menu, go to Settings > (your email address) > Manage Labels. Try playing with the sync settings of the individual labels there. You may or may not find some solution there. The All Mail option is not there because it's really not a label, but maybe you'll see something that helps you figure it out. If not, put in a call or email to Google support.
  10. #10  

    Default Re: Gmail "All Mail " folder issue

    Quote Originally Posted by mlipkin View Post
    MJKearney: I tried that, but the app has been sync in just fine in all the other mailboxes, and just not All Mail

    Eduardo06sp: I tried both increasing and decreasing that number but I still don't have anything newer than October 15
    I suggest you give a call to support. There's pretty much nothing you can do. My final suggestion is that you remove your Google account and re-add it. Settings---> Google---> Tap your email address---> Tap the three dots at the top right---> Remove account.

    Sent from my Nexus 7 using Android Central Forums
    MJKearney likes this.
  11. #11  

    Default Re: Gmail "All Mail " folder issue

    Remove and replace account worked for me for now. Wait and see for how long. Thanks mlipkin
  12. #12  

    Default Re: Gmail "All Mail " folder issue

    Hi there,
    had the same problem on my Nexus 7 for weeks - finally looked it up because if got tired of it.
    What worked for me: disabled the app. deleted all data. re-enabled the app. Nexus reloaded the gmail app and restarted it. "all mails" now up to date.
    Don't ask me why - but it worked fine.

Similar Threads

  1. How to stop Gmail from showing "All Mail"
    By betachains in forum Google Nexus 7 Tablet (2012)
    Replies: 0
    Last Post: 07-27-2012, 06:56 PM
  2. K9 mail - sent folder sync issues
    By selecus in forum General Help and How To
    Replies: 0
    Last Post: 03-20-2012, 10:50 AM
  3. Gmail vs. Yahoo mail issue
    By elamb23 in forum Verizon Droid Incredible
    Replies: 2
    Last Post: 08-10-2011, 08:51 PM
  4. Gmail and All Mail
    By DannyMichel in forum Android Applications
    Replies: 2
    Last Post: 07-23-2011, 12:07 PM
  5. gmails in "all mail" folder labeled as "inbox" not in my "inbox"
    By largeselection in forum Motorola Droid
    Replies: 4
    Last Post: 11-10-2009, 09:00 PM

Posting Permissions