1. Bears's Avatar
    I just installed SmoothRom 4.1 on a Nexus 7. It runs great but there's one problem. HSPA+ is not working whatsoever, while the WiFi works fine. I feel like I'm missing something obvious here but I'm currently stumped. Any ideas?
    11-23-2012 10:49 PM
  2. 2defmouze's Avatar
    I just installed SmoothRom 4.1 on a Nexus 7. It runs great but there's one problem. HSPA+ is not working whatsoever, while the WiFi works fine. I feel like I'm missing something obvious here but I'm currently stumped. Any ideas?
    A few simple ideas to start:
    a. Reboot.
    b. Remove and re-insert the sim card (they use those on the hspa ones, right? lol) and reboot..
    c. Did you do a full wipe when you flashed the ROM? Wipe data/factory reset, wipe caches, wipe system, then flashed? If not you probably want to do a full wipe and reflash it. Note that wiping data/factory reset is the most important one, to be fair.

    Let me know if this helps..
    11-23-2012 11:08 PM
  3. Bears's Avatar
    A few simple ideas to start:
    a. Reboot.
    b. Remove and re-insert the sim card (they use those on the hspa ones, right? lol) and reboot..
    c. Did you do a full wipe when you flashed the ROM? Wipe data/factory reset, wipe caches, wipe system, then flashed? If not you probably want to do a full wipe and reflash it. Note that wiping data/factory reset is the most important one, to be fair.

    Let me know if this helps..
    Thanks for the quick response.

    I actually did all the steps you mentioned. Full wipe/cache and dalvik, then flashed, and still nothing. I did notice something peculiar under the menus though. Under wireless & networks there was no mobile network option. I looked through all the menus just in case and nothing. I flashed the stock nandroid backup I made and mobile data worked fine again. I'm going to leave it as is until I can figure out why it wouldn't pick up HSPA+ signal when I flashed SmoothRom..

    Could the Kernel in use cause that problem?
    11-24-2012 12:49 AM
  4. 2defmouze's Avatar
    Thanks for the quick response.

    I actually did all the steps you mentioned. Full wipe/cache and dalvik, then flashed, and still nothing. I did notice something peculiar under the menus though. Under wireless & networks there was no mobile network option. I looked through all the menus just in case and nothing. I flashed the stock nandroid backup I made and mobile data worked fine again. I'm going to leave it as is until I can figure out why it wouldn't pick up HSPA+ signal when I flashed SmoothRom..

    Could the Kernel in use cause that problem?
    Kernel definitely could I don't know what kernel that ROM includes, also I've not heard of this ROM so it could be that, but it's less likely.

    Sent from my Nexus 4 using Tapatalk 2
    11-24-2012 12:55 AM
  5. Bears's Avatar
    Kernel definitely could I don't know what kernel that ROM includes, also I've not heard of this ROM so it could be that, but it's less likely.

    Sent from my Nexus 4 using Tapatalk 2
    Gotcha. It's a popular ROM on XDA. If I find a fix I'll post it. If not I'll try another ROM. Any suggestions?
    11-24-2012 02:20 PM
  6. 2defmouze's Avatar
    Gotcha. It's a popular ROM on XDA. If I find a fix I'll post it. If not I'll try another ROM. Any suggestions?
    I suggest sticking with more well known and respected devs, like CM and AOKP. In general I think you will find a lot of lesser known devs promise a lot of "fast, smooth, battery" tweaks in their OP descriptions, while more often than not the changes they make to the code are not only pointless but wind up breaking things, then they deliver plenty of updates to fix this and fix that, things that they broke in the first place.
    Bears likes this.
    11-25-2012 11:09 AM
  7. Bears's Avatar
    I suggest sticking with more well known and respected devs, like CM and AOKP. In general I think you will find a lot of lesser known devs promise a lot of "fast, smooth, battery" tweaks in their OP descriptions, while more often than not the changes they make to the code are not only pointless but wind up breaking things, then they deliver plenty of updates to fix this and fix that, things that they broke in the first place.
    I agree. I normally go with what you mentioned on my phones but I thought I'd give something else a shot. I'll install one of the two and see if it fixes the issue. Thanks for the help. Much appreciated
    11-26-2012 02:27 PM
  8. retsaw's Avatar
    As the 3G model was released the same time as 4.2, I expect 3G support for the Nexus 7 wasn't added until 4.2, so it may be that you need to stick to ROMs built on 4.2 or newer.
    Bears and 2defmouze like this.
    11-26-2012 06:41 PM
  9. Bears's Avatar
    As the 3G model was released the same time as 4.2, I expect 3G support for the Nexus 7 wasn't added until 4.2, so it may be that you need to stick to ROMs built on 4.2 or newer.
    Ohhh.. That's a good point. I'll look into that. Thanks!
    11-27-2012 05:20 AM
  10. dark_samus's Avatar
    I'd say it'd be a kernel issue as the kernel tells the software how to talk to the hardware... so if the software isn't told how to talk to the 3G part then no it won't work

    Sent from my LG-VM701 using Android Central Forums
    12-10-2012 03:21 PM
  11. lizards4444's Avatar
    Make sure you have a 4.2 rom, and a rom and kernal that support mobile data
    12-10-2012 11:13 PM

Similar Threads

  1. No mobile data with custom rom on unlocked g2x
    By toddrosenberger in forum G2X Rooting, ROMs, and Hacks
    Replies: 13
    Last Post: 08-13-2014, 11:59 PM
  2. No mobile network after unlock and root
    By rootbrain in forum Verizon HTC Rezound
    Replies: 1
    Last Post: 01-18-2012, 01:04 PM
  3. No data after root and Froyo upgrade
    By ming17 in forum Verizon Fascinate Rooting, ROMs, and Hacks
    Replies: 9
    Last Post: 09-01-2011, 07:38 PM
  4. No mobile data connection on thunderbolt. Wife's incredible working fine.
    By RubberToRoad in forum Verizon HTC Thunderbolt
    Replies: 13
    Last Post: 08-06-2011, 01:38 AM
  5. No streaming video after rooting?
    By AmphibiousRodent in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 8
    Last Post: 09-05-2010, 05:24 AM
LINK TO POST COPIED TO CLIPBOARD