Welcome to the Android Central Forums Create Your Account or Ask a Question Answers in 5 minutes - no registration required!
Page 2 of 2 FirstFirst 12
Results 26 to 27 of 27
  1. #26  

    Default Re: Nexus 7 - HELP - won't startup, static screen/sound shown and auto-shutdown loop

    I have the same static screen problem on my Nexus 7- working fine one day and wouldn't turn on the next. i charged it overnight and tried pressing the power button for 20 seconds, the again a couple times and it turned on, but wouldn't stay on for more than a couple seconds then shut-off at 0% battery and give me a static screen.
    Took the back off and the battery connector looks like it's in there just fine, ook it our and placed it back in the connector carefully making sure it's properly in there- still no luck, does the exact same thing.
    Anybody have any more suggestions? Going to contact Asus warranty center tomorrow but I don't have my original receipt and i'm not really banking on them solving my problem. Wondering if it may need a new battery although I can't imagine it would die out instantly and go from lasting hours on end in use to holding absolutely no charge
  2. #27  

    Default Re: Nexus 7 - HELP - won't startup, static screen/sound shown and auto-shutdown loop

    Same problem here. Static screen, not charging. I tried everything, it wasn't until I popped the back off and really pushed the battery wires back in that it was fixed. They initially looked ok but after trying everything else and then revisiting the battery I tried putting some reasonable pressure to close the connection and bingo the problem was resolved. This happened a second time and the fix was the same.
Page 2 of 2 FirstFirst 12

Similar Threads

  1. Phoenix 0.2 based Replenish won't start. Gray screen. Help!?!
    By RazzMaTazz in forum Samsung Replenish
    Replies: 4
    Last Post: 12-08-2013, 08:19 AM
  2. Help ! My Nexus 7 won't boot
    By aisen7396 in forum Google Nexus 7 Tablet (2012)
    Replies: 7
    Last Post: 09-12-2012, 12:28 AM
  3. Help with a bug: unlock screen partially shown
    By hp10BII in forum Samsung Galaxy S3
    Replies: 5
    Last Post: 08-24-2012, 10:17 AM
  4. Replies: 0
    Last Post: 02-10-2012, 04:52 PM
  5. HELP! A friend rooted my Evo 4G today and it won't go past intro/turn-on screen!
    By shtaylor1 in forum HTC EVO 4G Rooting, ROMs, and Hacks
    Replies: 4
    Last Post: 05-17-2011, 01:34 PM

Posting Permissions

B