1. dougltc's Avatar
    I swapped my N7 16 for a 32... tried to use Google Navigation and it no longer gets GPS... just sits there waiting for it. This was not an issue under Android 4.1 on the 16...

    Other apps such as Google Maps and GPS Test have no problem.

    I am connected to the web via wifi...

    Any ideas what broke this?

    Thanks

    Sent from my Nexus 7 using Android Central Forums
    11-27-2012 01:39 PM
  2. retsaw's Avatar
    Have you tried turning it off and on again? I had a problem with getting a GPS lock when I tried to use my Nexus 7 for navigation a couple of weeks ago and it didn't start working until I turned it off and back on. Mine is getting a lock in Navigation on 4.2 when I tested it just now, but I'm using a C60 16 GB model.
    11-27-2012 02:47 PM
  3. dougltc's Avatar
    Yeah... I rebooted it... I turned the GPS on and off in settings... etc...
    11-27-2012 03:53 PM
  4. dougltc's Avatar
    just for grins and giggles, I loaded Google Navigation right now and it's just sitting there "waiting for location"

    When I loaded Google Maps a few minutes ago it pinpointed my current location within 10 to 15 seconds...
    11-27-2012 03:56 PM
  5. YAYTech's Avatar
    What happens if you load directions in maps, then tell it to navigate? Same thing?
    11-27-2012 04:27 PM
  6. dougltc's Avatar
    What happens if you load directions in maps, then tell it to navigate? Same thing?
    Same thing.... I think...

    I haven't found a consistent way to get from Google Maps Directions to Google Navigation... sometimes the option is there (known locations with reviews such as restaurants) and other times it isn't (address of a home).

    If I go straight into Navigation... it just sits there waiting for location... if I am able to go from maps to navigation the way I described above, same result.

    If there is another way to go from maps to navigation I haven't found it nor have I tested it...

    Sent from my Nexus 7 using Android Central Forums
    11-27-2012 04:47 PM
  7. pbelfi's Avatar
    I just used Google Navigation today, ran flawlessly for me......also using Nexus 7 with 4.2

    Sent from my Nexus 7 using Android Central Forums
    11-27-2012 04:50 PM
  8. Rich215's Avatar
    Tthis is what still....... happens when plotting in Gmaps then trying to navigate. (no location found starting from Nav first either).

    Running stock and unrooted.....C60 with 4.2 G Maps and Nav still bunked up from the 4.2 update. Hope it gets fixed soon as I use this feature.

    My MapQuest locks in location quickly still.....

    11-27-2012 06:39 PM
  9. YAYTech's Avatar
    With 4.2.1 rolling out, I wouldn't do anything drastic to try to fix it quite yet, but if all else fails there's always things like factory reset to hopefully clear it up. Might try the clearing the cache from the recovery menu thing, that helped my few issues with 4.2.
    11-27-2012 06:58 PM
  10. sparksd's Avatar
    I had this same problem after 4.1.2 update on stock N7 and it took a factory reset to fix it - I tried everything under the sun before doing that.
    11-27-2012 08:10 PM
  11. StreetRodder's Avatar
    I'm new to the Nexus 7 so this may sound dumb. Do I have to download Google Navigation and just what does it do?

    Thanks
    11-27-2012 09:47 PM
  12. Keeb13r's Avatar
    Google Navigation is just a separate launcher icon that comes with the Google Maps application (which is standard on Nexus devices). Not sure what you're expecting, but Google Navigation is a standard GPS navigation application.
    11-28-2012 08:20 AM
  13. dougltc's Avatar
    I found the cause of the problem & the solution...

    Under settings "provide location" was unchecked...

    Settings > Accounts > Google > Location Settings > Let Google Apps Access Your Location

    I had previously set it, so no idea how it got unchecked...

    Sent from my Nexus 7 using Android Central Forums
    seattlezoid and Rich215 like this.
    11-28-2012 10:07 AM
  14. Rich215's Avatar
    I found the cause of the problem & the solution...

    Under settings "provide location" was unchecked...

    Settings > Accounts > Google > Location Settings > Let Google Apps Access Your Location

    I had previously set it, so no idea how it got unchecked...

    Sent from my Nexus 7 using Android Central Forums
    WOW....Do I feel stupid! The 4.2 update must of reset this?

    Thanks for that large clue starring me in the eye OldDogEyes.
    11-28-2012 11:08 AM
  15. sparksd's Avatar
    No need to feel stupid - feel lucky! That is a lot easier than the factory reset I had to do to resolve my problem.
    11-28-2012 11:20 AM
  16. dougltc's Avatar
    I found the cause of the problem & the solution...

    Under settings "provide location" was unchecked...

    Settings > Accounts > Google > Location Settings > Let Google Apps Access Your Location

    I had previously set it, so no idea how it got unchecked...

    Sent from my Nexus 7 using Android Central Forums
    Here is one other interesting tidbit..

    Even though that box was unchecked and Navigation couldn't get the GPS as described in the original post, Google Maps was seeing the GPS just fine...

    Wonder how that works that some Google Apps need that permission and others don't...

    My guess is that Google Maps looks at the search location permission which I had granted but Google Maps Navigation requires that extra permission...

    Wonder why it is done that way...

    Oh yeah, I know, it helps Google's ad revenue to know my location... silly me...

    Sent from my Nexus 7 using Android Central Forums
    12-04-2012 12:45 PM
  17. silk7's Avatar
    I found the cause of the problem & the solution...

    Under settings "provide location" was unchecked...

    Settings > Accounts > Google > Location Settings > Let Google Apps Access Your Location

    I had previously set it, so no idea how it got unchecked...

    Sent from my Nexus 7 using Android Central Forums
    Thank you so much!!
    This was driving me batty for weeks!!! I did this and right i'm driving from Boston to DC. So far so good!!
    08-29-2013 01:02 PM

Similar Threads

  1. Anyone not able to get the OTA?
    By JayMunOne in forum HTC EVO 4G LTE
    Replies: 6
    Last Post: 07-19-2012, 11:41 PM
  2. for those still not able to get the update....
    By 0pusX in forum Verizon HTC Thunderbolt
    Replies: 12
    Last Post: 07-09-2011, 04:49 PM
  3. not able to get amazon app on xoom
    By TSX05 in forum Motorola Xoom
    Replies: 3
    Last Post: 05-17-2011, 10:27 PM
  4. Think you'll be able to get it in store?
    By ethan in forum HTC Flyer
    Replies: 1
    Last Post: 05-02-2011, 09:27 AM
  5. Replies: 13
    Last Post: 07-04-2010, 10:59 PM
LINK TO POST COPIED TO CLIPBOARD