1. bubeo289's Avatar
    Hi guys,
    I just received my nexus 7 yesterday. It was so great.
    But in the morning, it was said that there was a system upgrade, to android 4.1.2 so I installed it.
    Then my device restarted but it stopped at nexus logo screen.
    I also tried to restart it but it stucked there.
    Can someone help me please?

    Thanks a lot
    11-28-2012 12:29 AM
  2. skyrockett's Avatar
    Lol! What a bummer.. Have you tried charging it?
    11-28-2012 12:53 AM
  3. bubeo289's Avatar
    I have it charged whole night
    11-28-2012 12:57 AM
  4. skyrockett's Avatar
    Long power button press?
    11-28-2012 01:14 AM
  5. charkzilla20's Avatar
    Yeah I guess so
    11-28-2012 01:16 AM
  6. bubeo289's Avatar
    I also tried it. After long pressing power button, N7 restarted then Google logo appeared, then forever Nexus logo. I dont know how long I have to wait...
    11-28-2012 01:22 AM
  7. MJKearney's Avatar
    Do a hard reset. Lots of posts on this forum, videos on YouTube, and articles on the web about how to do this. A little bit of Googling and you'll be there in no time. This isn't a guarantee this will fix the issue, but it's a good place to start.
    11-28-2012 02:05 AM
  8. bubeo289's Avatar
    Problem solved. I tried factory reset . Luckly there's not much data. Thanks guys
    11-28-2012 02:43 AM

Similar Threads

  1. My Phone does not vibrate!
    By ajbrickyard in forum HTC EVO 4G LTE
    Replies: 2
    Last Post: 05-29-2012, 07:51 AM
  2. Please help me my finger does not slide on screen easily
    By biggerdjam in forum Droid RAZR MAXX
    Replies: 7
    Last Post: 05-10-2012, 08:56 PM
  3. My Phone DOES NOT!
    By phikai in forum The Android Central Lounge
    Replies: 0
    Last Post: 07-13-2010, 09:35 AM
  4. My Homescreen does not turn even id witch is on turn
    By kheeder in forum Motorola Droid
    Replies: 5
    Last Post: 03-10-2010, 09:28 AM
  5. Replies: 4
    Last Post: 01-08-2010, 10:41 AM