1. GiantJay's Avatar
    My Wi-Fi on both my Nexus 7's is very slow. They stay connected fine but I'm getting about 50kbps-150kbps download speeds. I factory reset one of them to no prevail. Anyone have any insight on this or heard of others with this issue? All my other devices work fine on the same Wi-Fi connection and I tried turning everything else off so just the Nexi where connected to see if the speeds are faster, but they aren't. I'm stock on both devices and both are the 16gb version, one older than the other. I have a Netgear R6300 router with Comcast' s internet with boost plus so the internet and the router shouldn't be an issue. They have done this before a few times and it fixed itself but I've had these horrible speeds for a few days now. Both Nexi are on 4.2.1 and I just reset one and it is still getting horrible speeds. I also have the random reboot issue. It seems like possibly a hardware problem in the Nexus devices or something with Jelly Bean? My S3 works fine but it's on 4.1.1 not 4.2.1.
    Sent from my Nexus 7 using Tapatalk 2
    12-05-2012 09:55 PM
  2. GiantJay's Avatar
    I fixed it, I had to mess with my WiFi advanced settings for my router. Glad its not the Nexus devices.

    Sent from my Nexus 7 using Tapatalk 2
    B. Diddy likes this.
    12-05-2012 10:04 PM
  3. B. Diddy's Avatar
    Can you give us a little more info on what advanced settings you had to tweak? Might help someone else some day who looks at this thread!
    eze036 and Eduardo06sp like this.
    12-05-2012 10:08 PM
  4. Eduardo06sp's Avatar
    I fixed it, I had to mess with my WiFi advanced settings for my router. Glad its not the Nexus devices.

    Sent from my Nexus 7 using Tapatalk 2
    Was it something with the QoS settings? If so, I did the same, to set my Nexus 7 on medium priority, as it was recommended.

    Sent from my Nexus 7 using Android Central Forums
    12-06-2012 08:37 AM

Similar Threads

  1. My tablet is painfully slow...help
    By Bmilano3161 in forum ASUS EeePad Transformer
    Replies: 26
    Last Post: 08-16-2016, 11:29 PM
  2. Replies: 34
    Last Post: 10-15-2012, 01:13 PM
  3. 4G vs Wifi and its effect on battery while idle-my test
    By dannyro77 in forum Verizon Galaxy Nexus
    Replies: 2
    Last Post: 04-23-2012, 05:12 PM
  4. Pls. help id a symbol appearing on the top of my home screen...
    By ctychick in forum General Help and How To
    Replies: 1
    Last Post: 08-08-2010, 10:31 PM
  5. Replies: 2
    Last Post: 03-26-2010, 08:33 AM
LINK TO POST COPIED TO CLIPBOARD